locked
Command line parameters are invalid RRS feed

  • Question

  • User1793524193 posted

    Hi,

    I have created a package in ssis and i have xml configuration for Check Point File Name. When running it in visual studio, it works just fine. But when I run the package from  SQL Job, I got the error Option "<?xml" is not valid.  The command line parameters are invalid. 

    I did this for my previous packages and I don't have any problem back then. I checked the parameter value and it is correct. What could be the cause of this? And how will I solve this?

    Any help please?

    Thursday, November 30, 2017 6:36 AM

Answers

  • User991499041 posted

    Hi cess02,

    Hi,

    I have created a package in ssis and i have xml configuration for Check Point File Name. When running it in visual studio, it works just fine. But when I run the package from  SQL Job, I got the error Option "<?xml" is not valid.  The command line parameters are invalid. 

    I did this for my previous packages and I don't have any problem back then. I checked the parameter value and it is correct. What could be the cause of this? And how will I solve this?

    Any help please?

    If your SQL Server is 64 bit

    In SQL Server JOB-->Properties-->Steps--->

    In the Execution Option Tab -- Check "Use 32 bit runtime"

    In the Data Sources Tab -- Uncheck the checkboxes of the connection managers if already checked.

    Schedule the Job and run it.

    Regards,

    zxj

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, November 30, 2017 7:18 AM

All replies

  • User991499041 posted

    Hi cess02,

    Hi,

    I have created a package in ssis and i have xml configuration for Check Point File Name. When running it in visual studio, it works just fine. But when I run the package from  SQL Job, I got the error Option "<?xml" is not valid.  The command line parameters are invalid. 

    I did this for my previous packages and I don't have any problem back then. I checked the parameter value and it is correct. What could be the cause of this? And how will I solve this?

    Any help please?

    If your SQL Server is 64 bit

    In SQL Server JOB-->Properties-->Steps--->

    In the Execution Option Tab -- Check "Use 32 bit runtime"

    In the Data Sources Tab -- Uncheck the checkboxes of the connection managers if already checked.

    Schedule the Job and run it.

    Regards,

    zxj

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, November 30, 2017 7:18 AM
  • User1793524193 posted

    Hi zxj,

    I tried what you said, but still getting the same error.

    regards,

    cess02

    Thursday, November 30, 2017 7:30 AM
  • User1793524193 posted

    Am I missing something? I clicked the Use 32 bit runtime  check box and then click OK. Then I run the job, but when I go to Execution Option again, the checkbox for Use 32 it runtime is unchecked.

    Thursday, November 30, 2017 7:37 AM
  • User1793524193 posted

    Hi zxj,

    I found it! My fault. I added the configuration file in Command files tab, it should be on Configurations files tab. I overlooked it.

    Thank you :)

    Thursday, November 30, 2017 7:52 AM