none
Unrecognized format when opening ACCDE using Runtime RRS feed

  • Question

  • I have MS Access RUNTIME 2016 version 16.0.4288.1001 installed on 6 different servers.  None of which have any other version of MS Access installed.

    My development computer has MS Office version 16.0.862.2121

    Suddenly every single ACCDE file I compile from my development computer and try to open on any of my servers gives this error when I try to open the ACCDE file:

    This database is in an unrecognized format.

    The database may have been created with a later version of Microsoft Access than the one you are using. Upgrade your version of Microsoft Access to the current one, then open this database.

    I've even just created any new files I create, any existing projects I use. Everything gives this error when I transfer the ACCDE version of it to any of my servers.

    The ACCDE file runs fine on my computer.

    If I just copy the ACCDB version, it works.

    I've it happens with new databases, existing ones. But I still have tried to decompile, compact & repare. Doesn't help.

    Any suggestions welcome, thanks.


    Friday, November 10, 2017 8:13 PM

Answers

All replies

  • Just an update. I tried quick repair on my dev computer for Office. Didn't help.

    Btw, I've been developing in Access and deploying to these computers for years. This just started happening out of no where. I haven't compiled an ACCDE in a week or 2. But don't remember seeing any Office updates either, but could have missed them.  I would think that if that was the case, others developing in Access 2016 and deploying ACCDE files to 2016 runtimes would have brought this up already. So I don't think it could be updates. But not sure.

    Another Update:

    I uninstalled 2016 office suite, rebooted, reinstalled suite. Still didn't help. All computers being deployed to have all Windows updates installed. Its been 6 months since I installed updates on my dev machine(oops). I'll post back if that helps. 

    Still could use some advice, just in case it doesn't.

    Friday, November 10, 2017 10:26 PM
  • Yep, MS messed up again and the latest update causes this incompatibility.  See: http://www.devhut.net/2017/11/07/access-bug-1710-breaks-compatibility-with-accdes-and-access-runtime/

    Daniel Pineault, 2010-2017 Microsoft MVP
    Professional Support: http://www.cardaconsultants.com
    MS Access Tips and Code Samples: http://www.devhut.net


    Saturday, November 11, 2017 1:37 AM
  • Thanks Daniel, that solved it for now.

    I updated Office back to the version 1709 build 8528.2147 and all is well.

    Turned off Office Updates until Microsoft fixes this one.

    Monday, November 13, 2017 6:33 PM
  • Microsoft has fixed the bug, see

    https://technet.microsoft.com/en-us/office/mt465751.aspx

    November 20, 2017

    Version 1710 (Build 8625.2132)

    Note: Current Channel is now named Monthly Channel.
    Access: Non-security updates
    This channel release contains the following non-security updates:
    Fix an issue where opening an Access runtime application (.accde file) results in a "This database is in an unrecognized format" error message and the application won’t open.

    I can confirm that the .accde's built with this version now work on the runtime again.

    Matthias Kläy, Kläy Computing AG


    • Edited by mklaey Tuesday, November 21, 2017 11:40 AM link was not working
    Tuesday, November 21, 2017 9:55 AM