locked
Getting error when deploying website in vs-2008 RRS feed

  • Question

  • User1037547548 posted

    I checked the detailed output. Here is what I get. Any clue?

    Using "ToggleDebugCompilation" task from assembly "C:\Program Files\MSBuild\Microsoft\WebDeployment\v9.0\Microsoft.WebDeployment.Tasks.dll".

    Task "ToggleDebugCompilation"

    Updating Web.config <compilation> element debug attribute to 'False'.

    C:\Program Files\MSBuild\Microsoft\WebDeployment\v9.0\Microsoft.WebDeployment.targets(639,7): error : Section or group name 'system.web.extensions' is already defined. Updates to this may only occur at the configuration level where it is defined. (C:\Documents and Settings\pvakil0\Desktop\MyProjects\MyProject\Release\web.config line 4)

    C:\Program Files\MSBuild\Microsoft\WebDeployment\v9.0\Microsoft.WebDeployment.targets(639,7): error MSB4018: The "ToggleDebugCompilation" task failed unexpectedly.

    C:\Program Files\MSBuild\Microsoft\WebDeployment\v9.0\Microsoft.WebDeployment.targets(639,7): error MSB4018: System.ArgumentNullException: Parameter "message" cannot be null.

    C:\Program Files\MSBuild\Microsoft\WebDeployment\v9.0\Microsoft.WebDeployment.targets(639,7): error MSB4018: at Microsoft.Build.Shared.ErrorUtilities.VerifyThrowArgumentNull(Object parameter, String parameterName, String resourceName)

    C:\Program Files\MSBuild\Microsoft\WebDeployment\v9.0\Microsoft.WebDeployment.targets(639,7): error MSB4018: at Microsoft.Build.Utilities.TaskLoggingHelper.LogMessage(MessageImportance importance, String message, Object[] messageArgs)

    C:\Program Files\MSBuild\Microsoft\WebDeployment\v9.0\Microsoft.WebDeployment.targets(639,7): error MSB4018: at Microsoft.WebDeployment.Tasks.ToggleDebugCompilation.Execute()

    C:\Program Files\MSBuild\Microsoft\WebDeployment\v9.0\Microsoft.WebDeployment.targets(639,7): error MSB4018: at Microsoft.Build.BuildEngine.TaskEngine.ExecuteInstantiatedTask(EngineProxy engineProxy, ItemBucket bucket, TaskExecutionMode howToExecuteTask, ITask task, Boolean& taskResult)

    Done executing task "ToggleDebugCompilation" -- FAILED.

    Done building target "CopyToOutputDir" in project "MyProject.wdproj" -- FAILED.

    Done building project "MyProject.wdproj" -- FAILED.

    Build FAILED.


    Regard

    Imrankhan

    Friday, October 23, 2009 1:47 AM

Answers

  • User372121194 posted

    Hi,

    Did your website exist in sub directory under another website? Please make sure there is not two sections named 'system.web.extensions' in your web.config file and its inherited web.config.

    You also can publish it to another location to see whether it works?

    You also can set "MSBuild project build output verbosity" option from (Tools menu, click Options, and then select the Projects and Solutions folder and click Build and Run) to get detailed build steps.

    I look forward to receiving your test results.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, October 28, 2009 4:21 AM

All replies

  • User372121194 posted

    Hi,

    Did your website exist in sub directory under another website? Please make sure there is not two sections named 'system.web.extensions' in your web.config file and its inherited web.config.

    You also can publish it to another location to see whether it works?

    You also can set "MSBuild project build output verbosity" option from (Tools menu, click Options, and then select the Projects and Solutions folder and click Build and Run) to get detailed build steps.

    I look forward to receiving your test results.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, October 28, 2009 4:21 AM
  • User1037547548 posted

    Hi.

    Thanks for your reply. I will follow your suggesion and forward results soon.

    regard

    Imrankhan


    Wednesday, October 28, 2009 4:54 AM