none
VSTO Add-In will not load on Startup RRS feed

  • Question

  • We are running 32-Bit Office (Outlook 2016) on 64-Bit Windows (Win10)

    The Add-In shows up on the Inactive List.  It's not on the Disabled Add-ins list.

    When I bring up the COM Add-Ins Dialog, the Add-in is unchecked and it's Load Behavior is "Unloaded".

    However, the LoadBehavior value in the registry is 3.

    The Add-In will load after placing a check in the box next to it's entry in the "COM Add-ins" dialog, but when you restart Outlook it is back to its unloaded state and the LoadBehavior registry value is still 3.

    Any ideas?


    Germán Hayles

    Thursday, September 20, 2018 6:40 PM

Answers

  • Found the problem

    Microsoft's documentation states that when you have the following configuration, 32-bit Office on 64-Bit Windows, you should have two registry entries for the Add-in

    HKCU\SOFTWARE\Microsoft\Office\Outlook\Addins\<addin>
    HKLM\SOFTWARE\Wow6432Node\Office\Outlook\Addins\<addin>

    The HKCU key was missing, and I noticed that it's missing in our installation package.  Once I put the key back and changed the loadbehavior to 3 and we were good to go.

    Germán Hayles

    • Marked as answer by GermanEZI Friday, September 21, 2018 7:09 PM
    Friday, September 21, 2018 7:09 PM

All replies

  • Hi GermanH,

    We can set the load behavior for this add-in by configuring the "LoadBehavior" registry under the following path:

    Key: HKEY_LOCAL_MACHINE or HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\Outlook\Addins\<add-in name>

    Value Name: LoadBehavior

    Value Data: 3 (This value specifies that the VSTO Add-in is loaded at startup)

    For more information, please review the following link:

    Outlook Addin not load on start up

    Outlook 2016 Addin not loading on start up

    Outlook Addin starts up inactive

    Hope it helps you.

    Best Regards,

    Lina


    MSDN Community Support Please remember to click &amp;quot;Mark as Answer&amp;quot; the responses that resolved your issue, and to click &amp;quot;Unmark as Answer&amp;quot; if not. This can be beneficial to other community members reading this thread.

    Friday, September 21, 2018 2:52 AM
  • The load Behavior is already set to 3.  You may have missed that in my post.

    The Add-in is Unchecked in the Add-In Manager and it's LoadBehavior is listed as "Unloaded", but if you check the registry the "LoadBehavior" is set to 3.

    Germán Hayles

    Friday, September 21, 2018 7:19 AM
  • Hi GermanH,

    Unfortunately, we can't reproduce your problem.

    If possible, you can provide detailed logging it?

    The error you are getting is because of the value of add-in in registry editor and there is a way to active this add-in. Please refer to the following link for detailed steps.

    Outlook 2016 Addin not loading on start up

    And then go to Outlook again and check the Load Behaviour add-in will be active.

    In addition, depending on my research, there are several ways to debug VSTO and you can try it:

    Troubleshoot Office solution deployment

    Client Troubleshooter

    Hopefully it helps you.

    Best Regards,

    Lina


    MSDN Community Support Please remember to click &amp;quot;Mark as Answer&amp;quot; the responses that resolved your issue, and to click &amp;quot;Unmark as Answer&amp;quot; if not. This can be beneficial to other community members reading this thread.

    Friday, September 21, 2018 8:56 AM
  • Found the problem

    Microsoft's documentation states that when you have the following configuration, 32-bit Office on 64-Bit Windows, you should have two registry entries for the Add-in

    HKCU\SOFTWARE\Microsoft\Office\Outlook\Addins\<addin>
    HKLM\SOFTWARE\Wow6432Node\Office\Outlook\Addins\<addin>

    The HKCU key was missing, and I noticed that it's missing in our installation package.  Once I put the key back and changed the loadbehavior to 3 and we were good to go.

    Germán Hayles

    • Marked as answer by GermanEZI Friday, September 21, 2018 7:09 PM
    Friday, September 21, 2018 7:09 PM
  • It is glad to hear that you have found the solution and thanks for sharing it with us. If you have any question, or update, please feel free to let me know.

    Regards,

    Simon


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread.

    Saturday, September 22, 2018 6:41 AM
    Moderator