none
BTAHL7 2.X Disassembler for HL7 Messages RRS feed

  • Question

  • Hi,

    I am getting the below exception in BTAHL7 2.x disassembler component. 

    In a receive pipeline, Decode section - I am calling a custom pipeline component to assign some context properties

    Disassemble section - I am using BTAHL7 diassembler.

    When I dropped the hl7 messages in receive port, I am getting the below error.

    There was a failure executing the receive pipeline: "Bts.Foundation.Pipelines.ContextPromotionHL7Receive, Bts.Foundation.Pipelines, Version=1.0.0.0, Culture=neutral, PublicKeyToken=727a1d3f82728d8f" Source: "BTAHL7 2.X Disassembler" Receive Port: "Receive - Inbound CCD/HL7" URI: "C:\BizTalkLocations\ImagingResults\*.hl7" Reason: The ConnectionString property has not been initialized. 

    Regards,

    Lakshmi

    Wednesday, September 17, 2014 7:51 PM

Answers

  • In that case you need to reinstall HL7 accelerator.

    If the installation is successful, HL7 Send and Receive pipelines should be visible in default application- BizTalk Application 1.

    Rachit

    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply.


    Friday, September 19, 2014 1:15 PM
    Moderator

All replies

  • see if in your custom component there is a code for :

    properties to pull connections strings like database connections at run time. A good place to check would be in admin console, Inside Receive port and click on pipeline elipses next to your component  to see if any configurable properties are missing.

    Otherwise this has nothing to do with HL7 disassembler. The error is most likely coming from your custom component.

    Some debug options:

    1. Try using default HL7 receive pipeline with HL7 disassembler - means your custom component is not there and see if you don't get the error anymore.

    Side question: What properties are you trying to promote to context? may be there is something already available that you might use for routing.

    Thanks

    Thursday, September 18, 2014 2:17 AM
  • I have removed the decode part and deployed the pipeline and placed the new dll in "C:\Program Files (x86)\Microsoft BizTalk Server 2013\Pipeline Components". Now I have only disassemble section in my pipeline. In the receive location, I have only 4properites which are for BTAHL7 disassembler. Still getting the same error.
    Thursday, September 18, 2014 7:03 AM
  • Not your pipeline, try uisng HL7 default receive pipeline, it should be avalable in drop down menu, We are trying to see if your pipeline is broken or something related HL7 default installation/setting is wrong,

    So pick,

    Receive Pipeline = BTAHL72XReceivePipeline

    Friday, September 19, 2014 12:33 AM
  • No. It is not available in pipeline dropdown list. Do I need to reinstall HL7 accelerator?

    Thanks,

    Lakshmi

    Friday, September 19, 2014 6:57 AM
  • No, you don't need to reinstall HL7 accelerator.

    If you check BTAHL72XReceivePipeline pipeline will be visible in the default application  "BizTalk Application 1". You just need to refer that application in your current application.

    Adding a reference to another application is easy:

    Using admin console, right click on the application you want to add a reference. Select properties in the popup menu. Select References on the left, then click add button and select the application you want to add a reference to.

    I hope this helps.

    Rachit

    When you see answers and helpful posts,
    please click Vote As Helpful, Propose As Answer, and/or Mark As Answer

    Friday, September 19, 2014 7:09 AM
    Moderator
  • I couldn't find that pipeline in BizTalk Admin Console -> Application -> Pipelines
    Friday, September 19, 2014 9:22 AM
  • In that case you need to reinstall HL7 accelerator.

    If the installation is successful, HL7 Send and Receive pipelines should be visible in default application- BizTalk Application 1.

    Rachit

    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply.


    Friday, September 19, 2014 1:15 PM
    Moderator
  • Yes. I reinstalled and able to see the receive pipeline. I will get *.hl7 (ORU^R01) message in the below format. So what schema type I 've to use in orchestration Receive shape.

    MSH|^~\&|IntelePACS|IMS|COCENTRIX|COCENTRIX|20140618145016||ORU^R01|20140626125758|P|2.3
    PID|1|TEST123|TEST123||PATIENT^TEST||19310314|M|||||||||||||||||||||||
    ORC|RE|TESTACC123|TESTACC123||ZZ||||||||||||IMS|||||||||
    OBR|1|TESTACC123|TESTACC123|ABDOMEN|||20140518145016|||||||||||TESTACC123|1|1||||CT|F|||||||||||||||||||||||
    OBX|1|RP|URL||
    https://integration461.intelerad.com/view/patient/TEST123||||||F|||20140518145016||

    Friday, September 19, 2014 6:49 PM
  • You need to use ORU message with Event R01 of version 2.3. Your message type will be http://microsoft.com/HealthCare/HL7/2X#ORU_R01_23_GLO_DEF.

    Has your initial issue been resolved?

    Thursday, September 25, 2014 8:49 PM
  • HL7 components use BTAHL7(Default) database for logging. If you open BTAHL7 Configuration Explorer then you will see the exact reason.

     

    So if you see above error then you need to create Microsoft.Solutions.BTAHL7.AuditingLogging.dll.config file under .\Program Files (x86)\Microsoft BizTalk 2010 Accelerator for HL7\Bin. Update this file with following xml and provide proper connection string pointing to BTAHL7 database.

    <configuration><system.runtime.remoting><application name="alclient"><client><wellknown type="Microsoft.Solutions.BTAHL7.AuditingLogging.EventBroker, Microsoft.Solutions.BTAHL7.AuditingLogging" url="tcp://localhost:4000/EventBroker" /></client><channels><channel ref="tcp" port="0" /></channels></application></system.runtime.remoting><appSettings><add key="ConfigDb" value="Integrated Security=SSPI;database=BTAHL7;server=XXXXXX" /></appSettings></configuration>
    
    This should resolve your problem.

    Thank you.

    Sunday, April 10, 2016 11:20 PM