none
USB Tethering Driver On Wince Borad ?? RRS feed

  • Question

  • Hi,All
       I like to develop a USB driver on Wince6.0 board using smartphone's USB Tethering functionality.  or say,I want my Wince Device to use my smartphone's sharing network via USB.

       Is it feasible? Does anybody do that before?

    Thursday, August 30, 2012 9:31 AM

All replies

  • Hi Kwanvin,

    If your smartphone provides USB tethering (as a USB peripheral, I guess), and you know the protocol for it (over USB), then you can write some kind of USB driver for it for WinCE

    The kind of WinCE driver you develop depends on what the interface of the tethering protocol looks like.

    Maybe if you provide more details, we can point you in the right direction.

    Ilan.

    Thursday, August 30, 2012 1:30 PM
  • Thanks! Iian, I used this function of smartphone with PC,it worked great! And I found the name of drivers used to load the the smartphone is "SAMSUNG Android USB Remote NDIS NetWork Device",and the driver files are “rndismpx.sys” and “USB8023x.sys”. So I figured it out that the tethering protocol is RNDIS. I should develop a NDIS Intermediate Driver via USB. Am I right?
    Friday, August 31, 2012 2:42 AM
  • Kwanvin,

    Make sure to include RNDIS host components. See here: http://msdn.microsoft.com/en-us/library/gg158818.aspx

    Most likely, your smartphone is an RNDIS class device (can you examine the device/configuration descriptor and verify?)

    If it is, then it should work right out of the box, without the need to write any additional code.

    Ilan.


    • Edited by Ilan Tayari Tuesday, September 4, 2012 7:15 AM
    Tuesday, September 4, 2012 7:08 AM
  • Ilan,

         I selected RNDIS USB HOST component in the Catalog to include the USB Host RNDIS support.
    the usb8023.dll and rndismp.dll were both built in my OS. And also I edited the registry according to my device's descriptor

    bDeviceClass:0x02,   bDeviceSubClass:0x00,  bDeviceProtocol:0x00.

         When I connected  my phone to Wince broad ,I got the debug messages:

    USBD:ConvertToClientRegistry, Registry Drivers\USB\LoadClients\Default\Default\2 is  exist

    USBD: Calling client device detach proc

    USBD: Client accepted control of device

    which makes me believe that phone was loaded and accepted by the driver usb8023 device successfully.

           but What should I do  next? There was no any new connections in the NetWork Connection.I tried to make a new connection and configure it's setting,no matter what I do,it dit not work.

          I don't have the code of usb8023 and I don't know what to do next?

                                                                                                                                               Kwanvin

     

    Wednesday, September 5, 2012 1:35 AM
  • anyone else ?
    Tuesday, September 18, 2012 6:57 AM