none
I can't enter debug mode for my C++ programs. I'm getting these error messages:

    Question

  • Hi there, 

    1. The first thing I did

    When I try to enter debug mode by pressing F5 on this C++ program I'm working on, 

    what happens is that the debugging starts, ends almost right away, and then I get this error message:

    The message repeatedly says, "cannot find or open the pdb file"

    Sorry, I don't have a screenshot of the error message at this stage. But I do have a screenshot of

    "an updated version" of the error message below.

    2. The Second Thing I Did

    I went on Google and found some info that recommended to go to Tools->Options->Debugging->Symbols and select the checkbox "Microsoft Symbol Servers."

    After I did that, the problem persists only slightly differently.

    When the debugging starts, it still ends almost right away, and then I get this slightly different error message. This updated error messages says "Symbols loaded" over and over instead of "cannot find or open the PDB file" over and over:

    

    How do I go about properly entering the debug mode without it ending right away and then giving me error messages?

    Thanks guys!



    • Edited by LiamHayes Saturday, February 25, 2017 4:21 PM
    Saturday, February 25, 2017 4:03 PM

Answers

  • When I try to enter debug mode by pressing F5 on this C++ program I'm working on, 
    what happens is that the debugging starts, ends almost right away, and then I get this error message:
    The message repeatedly says, "cannot find or open the pdb file"

    That's not necessarily an error, just information.

    Have you set a breakpoint at the start of your program before you press F5?

    Have you tried pressing F10 rather than F5?

    Dave

    • Marked as answer by LiamHayes Saturday, February 25, 2017 5:10 PM
    Saturday, February 25, 2017 4:29 PM
  • Hi LiamHayes, 

    I'm glad your issue has been resolved, and also thanks for David's answer!

    And I'm going to close this thread. Please feel free to let us know if you need any other help.

    Best regards, 

    Fletch


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by LiamHayes Monday, February 27, 2017 9:09 PM
    Monday, February 27, 2017 3:44 PM

All replies

  • When I try to enter debug mode by pressing F5 on this C++ program I'm working on, 
    what happens is that the debugging starts, ends almost right away, and then I get this error message:
    The message repeatedly says, "cannot find or open the pdb file"

    That's not necessarily an error, just information.

    Have you set a breakpoint at the start of your program before you press F5?

    Have you tried pressing F10 rather than F5?

    Dave

    • Marked as answer by LiamHayes Saturday, February 25, 2017 5:10 PM
    Saturday, February 25, 2017 4:29 PM
  • That worked! Thank you very much!!!
    Saturday, February 25, 2017 5:11 PM
  • Hi LiamHayes, 

    I'm glad your issue has been resolved, and also thanks for David's answer!

    And I'm going to close this thread. Please feel free to let us know if you need any other help.

    Best regards, 

    Fletch


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by LiamHayes Monday, February 27, 2017 9:09 PM
    Monday, February 27, 2017 3:44 PM
  • Okay, sounds good.

    Thank you guys. 

    And I'll let you guys know if I have any other questions.

    Later,

    Liam


    Monday, February 27, 2017 9:10 PM