locked
deploying web application to Windows 2003 server RRS feed

  • Question

  • User746043490 posted

    Good Day,

    I have created a web application in Visual Studio Web Express 2010 and it runs as intended on my local PC. When I publish it, by way of the "File System", to a virtual directory created on the server, I get a crapload of Web.config file errors. The server is running Windows 2003 with the 3.5 framework. I do know I have the 4.0 Framework on my development PC. Besides installing the 4.0 framework on the server, is there anything else that needs to be done?

     

    thanks

    Thursday, June 13, 2013 6:55 PM

Answers

  • User-1716253493 posted

    You need to configure your virtual directory as an application, or add application instead add virtual directory

    configure the application to use netframework 4, configure permission, set default document.

    If any error, post the message here.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, June 13, 2013 9:35 PM

All replies

  • User-1716253493 posted
    After install net 4, configure app pool to use net 4
    Thursday, June 13, 2013 7:20 PM
  • User-1716253493 posted

    You need to configure your virtual directory as an application, or add application instead add virtual directory

    configure the application to use netframework 4, configure permission, set default document.

    If any error, post the message here.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, June 13, 2013 9:35 PM