none
The "Microsoft.VisualStudio.ProjectSystem.References.UnresolvedAssemblyReference" reference could not be resolved

    Question

  • Hello everyone,My English is not good。

    VS2015 + windows 10.10585 sdk 10.10240 , I add a reference, but I can't succeed. That reference -> Properties Full path is" The "Microsoft.VisualStudio.ProjectSystem.References.UnresolvedAssemblyReference" reference could not be resolved." I want post image ,but I get "Body text cannot contain images or links until we are able to verify your account."


    • Edited by Dylan_Huang Friday, January 29, 2016 12:50 AM add image
    Sunday, January 03, 2016 2:57 PM

Answers

  • Hi Dylan_Huang,

    I think I could repro this issue in my side:

    It seems that we couldn't refer to the files directly in the static library project. One workaround is that we add the whole project as the reference.

    Thanks,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, January 29, 2016 6:21 AM
    Moderator

All replies

  • Hi Dylan_Huang,

    >>Body text cannot contain images or links until we are able to verify your account.

    For this issue, maybe you could get useful information here:

    https://social.microsoft.com/Forums/en-US/f7e1de32-6b35-4926-b592-5b61d48e83c4/body-text-cannot-contain-images-or-links-until-we-are-able-to-verify-your-account?forum=reportabug

    >>VS2015 + windows 10.10585 sdk 10.10240 , I add a reference, but I can't succeed. That reference -> Properties Full path is" The "Microsoft.VisualStudio.ProjectSystem.References.UnresolvedAssemblyReference" reference could not be resolved."

    For this issue, it would be better if you could share us more detailed information, for example, which kind of app did you create? Which kind of developing language did you use? How did you add a reference? Which assembly did you really add?

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, January 04, 2016 10:59 AM
    Moderator
  • Any update? Would you mind letting us know the latest information about this issue? Dylan_Huang!

    Thanks,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, January 12, 2016 3:45 PM
    Moderator
  • Sorry,I haven't had any time recently and the issue  is not solved yet.


    Wednesday, January 20, 2016 3:23 PM
  • @Dylan_Huang,

    Thanks for your friendly response.

    >>The "Microsoft.VisualStudio.ProjectSystem.References.UnresolvedAssemblyReference" reference could not be resolved."

    Actually this forum is to discuss the VS IDE, based on the above information, we just know that this issue is related to the reference, but it is hard for us to know the real assembly reference or the project type in your side.

    Maybe you could change the .NET Framework version, as far as I know, the latest windows 10 was the 10586, the VS also includes the SDK 10586 and 10240 for UWP developments, so maybe you could check that whether it is the related to the SDK target version or the windows 10 version.

    >>Sorry,I haven't had any time recently and the issue  is not solved yet.

    If you are busy, would you mind changing the issue type to General Discussion? If you have more time to look at the issue and provide more information, please feel free to change the issue type back to Question by opening the Options list at the top of the post editor window, and changing the type again. I will follow up this case as soon as possible.

    Sincerely,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, January 21, 2016 7:10 AM
    Moderator
  • @Jack-Zhai    Thank you very much.

    I've verified my account and add a picture about this issue.

    The project type is        c++   StaticLibary(UWP) .In App project ,this reference  is automatically added.

    I want use UWP File API in a staticlibary,but now I can only use it in APP projcet.

    Now I can only add all codes in one project about this issue.

    Please forgive my English is too bad. Thanks.

    Friday, January 29, 2016 1:24 AM
  • Hi Dylan_Huang,

    I think I could repro this issue in my side:

    It seems that we couldn't refer to the files directly in the static library project. One workaround is that we add the whole project as the reference.

    Thanks,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, January 29, 2016 6:21 AM
    Moderator
  • @Jack-Zhai   Thanks for your all response.

    Friday, January 29, 2016 1:05 PM
  • You are welcome, Dylan_Huang!

    Have a nice day,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Saturday, January 30, 2016 3:38 AM
    Moderator