changes are not allowed if the project wasn't built when debugging started RRS feed

  • Question

  • User-726785505 posted

    I have googled this and found lots of suggestions on what to do, but none of them work.

    This was working just fine last week.  The only thing I've installed in the last week was SSMS 2016.

    If anyone who has ideas on how to get passed this, I would appreciate it!

    Thursday, December 15, 2016 4:41 PM

All replies

  • User-2057865890 posted

    Hi Kdn102,

    What is exact error? Could you share screen shot?

    Best Regards,


    Friday, December 16, 2016 2:45 AM
  • User-133264935 posted

    Was this ever resolved?

    I am still getting this with VS2017 building ASP.Net Web

    Monday, December 18, 2017 8:52 PM
  • User781436107 posted

    I have just started getting the same issue with Visual Studio 2017 after installing SSMS v17.9.1

    Did you ever solve this?

    Friday, March 8, 2019 10:08 PM
  • User-1038772411 posted

    Forcing you to stop debugging, edit, start debugging again. Then here’s a solution:

    1. Stop running your app.
    2. Go to Tools > Options > Debugging > Edit and Continue
    3. Disable “Enable Edit and Continue”.

    If you find that Visual Studio doesn’t alert you that files have changed and that confuses you when debugging do this:

    1. Go to Tools > Options > Debugging
    2. Enable “Require source files to exactly match the original version”.

    Now run your application again and feel free to edit while you run the application, you will have to rebuild it in case you want to check the code though.

    Hope its work fine for you.

    Wednesday, March 13, 2019 1:04 PM