none
DDL 3.5 and Application 4.0 RRS feed

  • Question

  • Hi, I have already developped a lot of .Net 3.5 library, I try to add reference these in .Net 4.0 Winform project and i have always compilation error when I compile 4.0 winform project. I don't understand why. What must I for make my the compilation run without upgrade my 3.5 DLL ?
    Friday, April 8, 2011 1:50 PM

Answers

  • You can use a .NET 3.5 DLL in .NET 4 without issues.

     

    The most likely cause is:

    Change your .NET 4 application target from ".NET 4 Client Profile" to ".NET 4" - if you're targetting the client profile, but your 3.5 assemblies use features not available in client profile, you'll get errors.

     

     

    If that's not the issue, please post the compilation errors you're receiving, and we can try to guide you in the right direction.


    Reed Copsey, Jr. - http://reedcopsey.com
    If a post answers your question, please click "Mark As Answer" on that post and "Mark as Helpful".
    • Marked as answer by eryang Tuesday, April 19, 2011 2:17 AM
    Friday, April 8, 2011 3:57 PM
    Moderator