locked
Powerpivot pivottable field list bug RRS feed

  • Question

  • Hi,

    Any idea why this happens? What has happened here is that my calculated measures are being separated out into a separate list with the same name as the fact table in which they were created (see the screenshot) - usually they appear along with the table's fields. As you can see, this separate list has the formula symbol next to it. This wouldn't be a problem but, when I expand the list and try to edit on one of my measures (not shown), they are not editable. This is a problem! Is my workbook corrupt? I have tried refreshing the data (as this solves other workbook corruption issues):



    Thx

    Monday, January 4, 2010 2:25 PM

Answers

  • I am a sad git! I post messages and then answer them myself. Alas, this keeps me amused!

    The above is due to my own sorry lack of understanding! What I am looking at above is the pivottable field list. What I need is the Gemini field list. To show the difference, right click on the pivot table and show the field list. Then, on the Powerpivot ribbon, click the "field list" option. You should now have two field lists displayed side by side. Excuse my ignorance, this is not a bug and makes sense, even though it's a bit confusing. You cannot edit the formulae in the list above because, in the pivottable field list you are simply looking at calculated measures that you have created in the PP database. This is what you see when connecting to an AS cube using Excel 2007. This is not the place to manage those measures. You need to work with them within the gemini field list accessed via the PP ribbon. Hope this helps!
    Monday, January 4, 2010 3:42 PM

All replies

  • I am a sad git! I post messages and then answer them myself. Alas, this keeps me amused!

    The above is due to my own sorry lack of understanding! What I am looking at above is the pivottable field list. What I need is the Gemini field list. To show the difference, right click on the pivot table and show the field list. Then, on the Powerpivot ribbon, click the "field list" option. You should now have two field lists displayed side by side. Excuse my ignorance, this is not a bug and makes sense, even though it's a bit confusing. You cannot edit the formulae in the list above because, in the pivottable field list you are simply looking at calculated measures that you have created in the PP database. This is what you see when connecting to an AS cube using Excel 2007. This is not the place to manage those measures. You need to work with them within the gemini field list accessed via the PP ribbon. Hope this helps!
    Monday, January 4, 2010 3:42 PM
  • Hi, Matt,

    Thank you for finding the answer yourself and sharing it with the rest of us!

    Lisa
    Monday, January 4, 2010 3:50 PM