none
Which .NET version is supported by All Devices. RRS feed

  • Question

  • Hello,

    I am College student.

    I am designing GPA Calculator Application. (www.bitsa.in)

    Most of your user is facing problem 

    such as

    1. Failed to initialize properly

    2.not supporting win32 format

    Any developer please help me.. Which framework should I choose before building an application.. Which should support all OS and all environment..

    Please. Help me. I will be thankful for you..

    Tuesday, July 2, 2013 9:59 AM

Answers

  • There is no .NET Framework that "should support all OS and all environment..".

    If you are looking for the version that is most widely installed, I'd guess it's 2.0.

    .NET Framework 2.0 is probably on over 90% of all XP systems currently in use. It comes in Vista and Win 7 by default, and is available as a user option in Win 8.

    However, if your users are having problems installing your program, getting error messages like those you listed, I doubt your issue is framework related.

    For help with application install problems, try here:

    http://social.msdn.microsoft.com/Forums/en-US/winformssetup/threads

    • Proposed as answer by Ego JiangModerator Wednesday, July 3, 2013 9:27 AM
    • Marked as answer by Appadurai Wednesday, July 3, 2013 12:10 PM
    Tuesday, July 2, 2013 2:55 PM

All replies

  • There is no .NET Framework that "should support all OS and all environment..".

    If you are looking for the version that is most widely installed, I'd guess it's 2.0.

    .NET Framework 2.0 is probably on over 90% of all XP systems currently in use. It comes in Vista and Win 7 by default, and is available as a user option in Win 8.

    However, if your users are having problems installing your program, getting error messages like those you listed, I doubt your issue is framework related.

    For help with application install problems, try here:

    http://social.msdn.microsoft.com/Forums/en-US/winformssetup/threads

    • Proposed as answer by Ego JiangModerator Wednesday, July 3, 2013 9:27 AM
    • Marked as answer by Appadurai Wednesday, July 3, 2013 12:10 PM
    Tuesday, July 2, 2013 2:55 PM
  • Dear Sir,

    Thank  you.

    Thanks for your answer.

    Is there any way to convert .NET 3.5 project to .NET 2.

    Tuesday, July 2, 2013 4:07 PM
  • Yes, in any Visual Studio version, 2008 or newer, you can choose your target framework from those available on your system.

    The targeting is done on a per project basis, so if your solution has multiple projects, you must retarget one project at a time.

    However, because 3.5 is an extension of 2.0, and not a separate framework, you will find that almost all systems that have 2.0 will also have 3.0 and 3.5, so it's doubtful that retargeting to 2.0 will be worth the effort (unless, of course, you KNOW that you have many users who have 2.0, but not 3.0 and 3.5.

    Wednesday, July 3, 2013 4:19 PM