locked
NLP Spacy model issues in docker image on azure RRS feed

  • Question

  • I have a flask python app that uses spacy model (md or lg).  I am running in a docker container in VSCode and all works correctly on my laptop.

    When I push the image to my container registry the app it doesn't seem to get past this line in the log: Initiating warmup request to container.

    If I comment out the line nlp = spacy.load('en_core_web_md'), the website loads fine (of course it doesn't work as expected).  

    I am installing the model in the docker file after installing the requirements.txt: RUN python -m spacy download en_core_web_md.

    Appreciate any help

    Friday, April 24, 2020 7:06 PM

All replies

  • Hi Joseph,

    Noticed you asked your question on stackoverflow. Since you en_core_web_sm worked by en_core_web_md and en_core_web_lg didn't work, I'm wondering if the sizes of the databases are what's causing the issue. How long are you waiting for the container to initiate? Have you tried increasing the docker timeout ( WEBSITES_CONTAINER_START_TIME_LIMIT <= 1800 sec)?

    Send us an email at AzCommunity[at]microsoft[dot]com ATTN Ryan so that we can take a closer look. Please include you app service name and subscription id.


    Thanks in advance, Ryan

    Friday, May 1, 2020 3:27 AM