locked
How to disable "User must enter a user name and password to use this computer" RRS feed

  • Question

  • Is there a setting in a component that will allow to me to turn off this setting. "User must enter a user name and password to use this computer"

    How I do it manually is by running 'control userpasswords2' and un-checking the option.
    Tuesday, September 8, 2009 6:12 PM

Answers

  • I think I found my own answer.
    The Automatic login component values set this.

    Am just going to try it now and see if it does the trick.  If not, I found the registry values that need updating.


    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
    AutoAdminLogon
    REG_SZ = 1

    DefaultUserName
    REG_SZ = <user name for the default user>

    DefaultDomainName
    REG_SZ = <the local computer or domain name>

    DefaultPassword
    REG_SZ = <the password for the default account>
    • Marked as answer by Rob Kruis Tuesday, September 8, 2009 10:13 PM
    Tuesday, September 8, 2009 9:59 PM

All replies

  • I think I found my own answer.
    The Automatic login component values set this.

    Am just going to try it now and see if it does the trick.  If not, I found the registry values that need updating.


    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
    AutoAdminLogon
    REG_SZ = 1

    DefaultUserName
    REG_SZ = <user name for the default user>

    DefaultDomainName
    REG_SZ = <the local computer or domain name>

    DefaultPassword
    REG_SZ = <the password for the default account>
    • Marked as answer by Rob Kruis Tuesday, September 8, 2009 10:13 PM
    Tuesday, September 8, 2009 9:59 PM
  • That did it.
    Tuesday, September 8, 2009 10:13 PM
  • Automatic logon is one area, but do you need to hide all of the splash screens?

    -Sean

    www.sjjmicro.com / www.seanliming.com, Book Author - XP Embedded Advanced, XPe Supplemental Toolkit, WEPOS / POS for .NET Step-by-Step
    Tuesday, September 8, 2009 11:05 PM
    Moderator
  • I use the 'Windows Logon (Standard)' component.  I haven't messed with the settings much, however, I do have 'Show "Welcome to Windows" screen before login' enabled.  And it works fine.

    The legal notice screen is not enabled.

    Are these the correct splash screens?
    Tuesday, September 8, 2009 11:29 PM

  • Do you want the users to see the Welcome screen or dialog login when the system boots up or hide them? Some developers want to hide the fact that Windows is running underneith. Hiding the login is just another screen to hide.

    -Sean

    www.sjjmicro.com / www.seanliming.com, Book Author - XP Embedded Advanced, XPe Supplemental Toolkit, WEPOS / POS for .NET Step-by-Step
    Thursday, September 10, 2009 4:45 PM
    Moderator