Unable to delete network RRS feed

  • Question

  • I'm trying to delete a virtual network, but I'm not allowed to because the portal says it is in use. It is not in use, and I have tried everything I can think of to delete it. The network was created using the preview portal. Mabye there is a bug there preventing deletion?


    Monday, April 20, 2015 7:01 PM


All replies

  • Greetings, Hallis!

    Please check if there are any VMs associated with that vNet. If yes, please delete them retrieving the disks from them. Reference: https://msdn.microsoft.com/library/azure/dn195495.aspx

    Check if the gateway is also removed from vNet. Delete the gateway: Remove-AzureVnetGateway -VNetName "xyz"

    Ensure the Point-to-Site VPN connection checkbox is unchecked (if enabled) as this will prevent the VNET from being deleted. Click Save Changes.

    Thank you,


    Tuesday, April 21, 2015 4:33 AM
  • I have deleted all VM's and also the storage accounts they used.

    Trying to delete the gateway using the PowerShell command returns this error:  "InternalError: The server encountered an internal error. Please retry the request."

    Retrying the command dosen't work. I just get the same error again.


    • Edited by Hallis Tuesday, April 21, 2015 6:49 AM
    Tuesday, April 21, 2015 6:49 AM
  • Thanks for that input, Hallis!

    Having the gateway in place, we cannot delete the vNet. You can try deleting the same via Azure Portal on the networks dashboard.

    Also, you can add -verbose to the previous cmdlet for some better error response.

    Thanks again,


    Tuesday, April 21, 2015 7:32 AM
  • The gateway is not displayed in the portal, so I cannot delete it from there. The GatewaySubnet is still showing, but it cannot be deleted either.

    Adding the verbose option didn't help. The exact same message as earlier.


    Tuesday, April 21, 2015 7:45 AM
  • Request you to raise a Technical Support ticket for us to look into subscription specifics and help further to delete the vNet.


    Thank you,


    Friday, April 24, 2015 9:22 AM