none
How to define access on a measure group using Dimension Data Security ? RRS feed

  • Question

  • I have a cube with 3 measure groups. Each measure group has around 30 measures. I'm already using Dimension data security to grant access to dimension members based on roles. Within Dimension data I see a Measures Dimension. So I tried setting the access using this mdx expression for allowed set - MEASUREGROUPMEASURES( "XYZ" ). I get an this error when I browse the cube:

     

    Unexpected Error ( <<cube name>>)(47,24): The dimension [<<Measure Name>>] was not found when the string [<<Measure Name>>]  was parsed.

     

    where the [<<Measure Name>>]  is a measure in the measure group that I want to deny access.

     

    I would like to know, how to achieve this using MDX expressions without the need to specify all the 30 measures in each measure group.

     

    Another option I tried was using the same mdx expression in Cell Data. It worked only that when the measures still show up when browsed but appear with a #NA value. Ideally I wouldn't like the user to see the measure group they don't have access to.

    Thursday, July 31, 2008 12:37 AM