locked
Failed in installing Microsoft Visual Studio 2010 Professional on Windows 7 Ultimate x64 RRS feed

  • Question

  • Hi, I was trying to install Microsoft Visual Studio 2010 Professional on Windows 7 Ultimate x64 when I got the cd shipments from Microsoft. But the installation ends up with error in the first place when the setup program attempts to install "Microsoft Application Error Reporting". I have been trying a few attempts to re-install it with few other different ways:

    - run the "setup.exe" in the cd with Administrator's right.

    - disabled anti virus program.

    - both way with and without network cable plugged in.

     

    Here's how my error log looks like:

    [12/23/10,16:59:40] Microsoft Application Error Reporting: [2] CMsiComponent::Install() expects the setup file for Microsoft Application Error Reporting, but the file failed verification. [12/23/10,16:59:40] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with HRESULT -2147467259. [12/23/10,16:59:41] VS70pgui: [2] DepCheck indicates Microsoft Application Error Reporting is not installed. [12/23/10,16:59:41] VS70pgui: [2] DepCheck indicates VC 9.0 Runtime (x86) was not attempted to be installed. [12/23/10,16:59:41] VS70pgui: [2] DepCheck indicates VC 10.0 Runtime (x86) was not attempted to be installed. [12/23/10,16:59:41] VS70pgui: [2] DepCheck indicates VC 10.0 Runtime (x64) was not attempted to be installed. [12/23/10,16:59:42] VS70pgui: [2] DepCheck indicates Microsoft .NET Framework 4 was not attempted to be installed. [12/23/10,16:59:42] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio 2010 64bit Prerequisites (x64) was not attempted to be installed. [12/23/10,16:59:42] VS70pgui: [2] DepCheck indicates Microsoft Visual F# 2.0 Runtime was not attempted to be installed. [12/23/10,16:59:42] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio Macro Tools was not attempted to be installed. [12/23/10,16:59:42] VS70pgui: [2] DepCheck indicates TFS Object Model (x64) was not attempted to be installed. [12/23/10,16:59:42] VS70pgui: [2] DepCheck indicates .NET Framework 4 Multi-Targeting Pack was not attempted to be installed. [12/23/10,16:59:42] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio 2010 Professional - ENU was not attempted to be installed. [12/23/10,16:59:42] VS70pgui: [2] DepCheck indicates Microsoft Web Deployment Tool (x64) was not attempted to be installed. [12/23/10,16:59:42] VS70pgui: [2] DepCheck indicates Microsoft ASP.NET MVC 2 - Visual Studio 2010 Tools was not attempted to be installed. [12/23/10,16:59:43] VS70pgui: [2] DepCheck indicates Microsoft ASP.NET MVC 2 was not attempted to be installed. [12/23/10,16:59:43] VS70pgui: [2] DepCheck indicates Microsoft Silverlight was not attempted to be installed. [12/23/10,16:59:43] VS70pgui: [2] DepCheck indicates Microsoft Silverlight 3 SDK was not attempted to be installed. [12/23/10,16:59:43] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio 2010 Tools for Office Runtime (x64) was not attempted to be installed. [12/23/10,16:59:43] VS70pgui: [2] DepCheck indicates Microsoft Office Developer Tools (x64) was not attempted to be installed. [12/23/10,16:59:43] VS70pgui: [2] DepCheck indicates Dotfuscator Software Services - Community Edition was not attempted to be installed. [12/23/10,16:59:43] VS70pgui: [2] DepCheck indicates Crystal Reports templates for Visual Studio 2010 was not attempted to be installed. [12/23/10,16:59:43] VS70pgui: [2] DepCheck indicates Microsoft SQL Server Compact 3.5 SP2 (x86) ENU was not attempted to be installed. [12/23/10,16:59:43] VS70pgui: [2] DepCheck indicates Microsoft SQL Server Compact 3.5 SP2 (x64) ENU was not attempted to be installed. [12/23/10,16:59:43] VS70pgui: [2] DepCheck indicates Visual Studio 2010 Tools for SQL Server Compact 3.5 SP2 ENU was not attempted to be installed. [12/23/10,16:59:44] VS70pgui: [2] DepCheck indicates Microsoft Sync Framework Runtime v1.0 (x64) ENU was not attempted to be installed. [12/23/10,16:59:44] VS70pgui: [2] DepCheck indicates Microsoft Sync Services for ADO.NET v2.0 (x64) ENU was not attempted to be installed. [12/23/10,16:59:44] VS70pgui: [2] DepCheck indicates Microsoft Sync Framework Services v1.0 (x64) ENU was not attempted to be installed. [12/23/10,16:59:44] VS70pgui: [2] DepCheck indicates Microsoft Sync Framework SDK v1.0 (x64) ENU was not attempted to be installed. [12/23/10,16:59:44] VS70pgui: [2] DepCheck indicates VC 10.0 Designtime (x64) was not attempted to be installed. [12/23/10,16:59:45] VS70pgui: [2] DepCheck indicates Microsoft SQL Publishing Wizard 1.4 was not attempted to be installed. [12/23/10,16:59:45] VS70pgui: [2] DepCheck indicates Microsoft SQL Server System CLR Types was not attempted to be installed. [12/23/10,16:59:45] VS70pgui: [2] DepCheck indicates Microsoft SQL Server System CLR Types (x64) was not attempted to be installed. [12/23/10,16:59:45] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 R2 Management Objects was not attempted to be installed. [12/23/10,16:59:45] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 R2 Management Objects (x64) was not attempted to be installed. [12/23/10,16:59:45] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 Express Service Pack 1 (x64) was not attempted to be installed. [12/23/10,16:59:46] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 R2 Data-Tier Application Framework was not attempted to be installed. [12/23/10,16:59:46] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 R2 Data-Tier Application Project was not attempted to be installed. [12/23/10,16:59:46] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2008 R2 Transact-SQL Language Service was not attempted to be installed. [12/23/10,16:59:46] VS70pgui: [2] DepCheck indicates Microsoft SharePoint Developer Tools was not attempted to be installed. [12/23/10,16:59:46] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio 2010 ADO.NET Entity Framework Tools was not attempted to be installed. [12/23/10,16:59:46] VS70pgui: [2] DepCheck indicates Microsoft Help Viewer 1.0 x64 was not attempted to be installed.

     

    Any expert out there who can point me to the right way? Thanks in advanced.

     

    Regards,

    Kenny

    Friday, December 24, 2010 6:47 AM

Answers

  • Hi Kenny LWH,

    Thank you for posting.

    Based on the installation log, it looks that your issue is related with permission.

    First of all, please check whether or not your account has Administrator account. If yes, please refer the following suggestions.

    1. Please extract installation files onto your local hard disk.

    2. Please disable UAC and try to install it again.

    About how to disable UAC, please refer the following link: http://www.mydigitallife.info/2008/12/30/how-to-disable-and-turn-off-uac-in-windows-7/

    Best Regards,

    Larcolais


    Larcolais Gong[MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Larcolais Gong Friday, December 31, 2010 5:49 AM
    Monday, December 27, 2010 5:51 AM
  • Thanks Larcolais, it is really permission problem, and I have already successfully installed Visual Studio 2010. Thank you very much.
    • Marked as answer by Larcolais Gong Thursday, February 10, 2011 10:27 AM
    Wednesday, February 9, 2011 9:45 AM

All replies

  • Hi Kenny LWH,

    Thank you for posting.

    Based on the installation log, it looks that your issue is related with permission.

    First of all, please check whether or not your account has Administrator account. If yes, please refer the following suggestions.

    1. Please extract installation files onto your local hard disk.

    2. Please disable UAC and try to install it again.

    About how to disable UAC, please refer the following link: http://www.mydigitallife.info/2008/12/30/how-to-disable-and-turn-off-uac-in-windows-7/

    Best Regards,

    Larcolais


    Larcolais Gong[MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Larcolais Gong Friday, December 31, 2010 5:49 AM
    Monday, December 27, 2010 5:51 AM
  • Thanks Larcolais, it is really permission problem, and I have already successfully installed Visual Studio 2010. Thank you very much.
    • Marked as answer by Larcolais Gong Thursday, February 10, 2011 10:27 AM
    Wednesday, February 9, 2011 9:45 AM
  • Hi,

    Thank you for your sharing. I'm glad to hear it works.

    Best Regards,

    Larcolais


    Larcolais Gong[MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, February 10, 2011 10:28 AM