locked
Visual Studio 2015 - All templates missing RRS feed

  • Question

  • User-741935677 posted

    When I try to create a new project the new project window has no templates listed - the tree to the left simply doesn't exist.

    This seems identical to the unresolved issue against 2015 RC version.: http://forums.asp.net/t/2057661.aspx?All+templates+missing+iin+Visual+Studio+2015+RC+

    I have tried repairing the installation.  I uninstalled (60+ minutes) and re-installed (another 60+ minutes) and same issue.

    premelvala finally flattened his/her computer and rebuilt to solve the problem - not something I want to do as it will take me 2-3 days to rebuild given what is on there.

    Any help appreciated as VS2015 is currently completely useless.  OS is 8.1 fully patched.  I have VS2010 and VS2012 installed but they were there first, this was a clean install of VS2015 (no prior CTP or RC version)

    [Note: Tools -> Extensions & Updates throws an "Object reference not set to an instance of an object" error as well - I guess these are connected.]

    Monday, October 5, 2015 11:39 AM

Answers

  • User-741935677 posted

    For future reference (as nobody, including Microsoft, ever came back with anything that either explained or solved the problem): 

    1. I believe this is caused by an incompatibility with other software, prime candidates are VS2010, VS2012 and SQL2012.

    2. Either try removing one or more of the above, give up on VS2015, or rebuild from scratch (I and the only other person I found who experienced this issue opted for a full rebuild - I did not install VS2010, VS2012 or SQL2012 on the new build.)

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, October 15, 2015 6:14 AM

All replies

  • User281315223 posted

    Where did you download this from as it sounds as if all sorts of things are going wrong (the Extensions & Updates throwing a null reference is certainly a problem).

    One thing that can typically help with this is ensuring that you run the installer with administrative rights (i.e. Right-click > Run as Administrator) as this resolves a majority of installation / Visual Studio related issues. 

    Monday, October 5, 2015 1:31 PM
  • User-166373564 posted

    Hi,

    the new project window has no templates listed - the tree to the left simply doesn't exist.

    You can try Devenv.exe /SafeMode to starts Visual Studio in safe mode, loading only the default environment and services, please check whether it can fix it.

    Please let me know if you need any help.

    With regards,

    Angie

    Tuesday, October 6, 2015 5:37 AM
  • User-741935677 posted

    Where did you download this from as it sounds as if all sorts of things are going wrong (the Extensions & Updates throwing a null reference is certainly a problem).

    One thing that can typically help with this is ensuring that you run the installer with administrative rights (i.e. Right-click > Run as Administrator) as this resolves a majority of installation / Visual Studio related issues. 

    Downloaded from MSDN as an ISO.  All installs, repairs and uninstalls done using an Admin account.

    And you are right LOTS of things are going wrong; if I try to open an existing solution I get a whole raft of errors and then I have to kill VS2015 in task manager as pressing the close button throws a error (the usual "object reference not set to an instance of an object".  No install errors in the log - I am guessing that it has to be some critical setting that is either wrong on not getting set and consequently it is not finding things.  Or it is using the wrong DLL - possibly VS2015 is not playing well with VS2010 or VS2012?

    A screenshot of the empty (and strange looking) New -> Project windows is in a Word document here: 

    https://onedrive.live.com/redir?resid=7EA5FF7339135660!147&authkey=!APvdGlIBOArBgwA&ithint=folder%2c

    Thursday, October 8, 2015 5:46 AM
  • User-741935677 posted

    You can try Devenv.exe /SafeMode to starts Visual Studio in safe mode, loading only the default environment and services, please check whether it can fix it.

    Hi Angie,

    Thanks for the feedback.  Tried this  and a bunch of other devenv command line options but no joy.  Something is fundamentally wrong within VS2015,  I have checked and the templates are there, VS2015 just cannot see them which makes me think it is looking in the wrong place (VS2015 is being run under an Admin account so it is not a permission issue) - it has to be an incorrect or missing setting somewhere (or it's picking up the setting that say points to VS2010 or VS2012).

    Regards,

    Neville

    Thursday, October 8, 2015 5:57 AM
  • User-741935677 posted

    For future reference (as nobody, including Microsoft, ever came back with anything that either explained or solved the problem): 

    1. I believe this is caused by an incompatibility with other software, prime candidates are VS2010, VS2012 and SQL2012.

    2. Either try removing one or more of the above, give up on VS2015, or rebuild from scratch (I and the only other person I found who experienced this issue opted for a full rebuild - I did not install VS2010, VS2012 or SQL2012 on the new build.)

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, October 15, 2015 6:14 AM