none
FSLogix Office Container | Failed to mirror Teams data RRS feed

  • Question

  • Hi,

    When using FSLogix Office Container with MS Teams the application folder is not being copied/mirrored to the VHDX disk when logging off. 

    Everything else works but I think only Robocopy is used for Teams? OneDrive for example is not an issue, just like other Office applications.

        

    -------------------------------------------------------------------------------
       ROBOCOPY     ::     Robust File Copy for Windows                              
    -------------------------------------------------------------------------------

      Started : donderdag 10 oktober 2019 14:15:01
       Source : C:\Users\TESTUSER\AppData\Local\Microsoft\Teams\
         Dest : C:\Windows\TEMP\FrxMount{C21DB02B-BDE4-4B60-B725-56C9ECD40240}\Teams\application\

        Files : *.*

      Options : *.* /S /E /COPYALL /PURGE /MIR /B /NP /IT /XJD /MT:8 /R:5 /W:1 

    ------------------------------------------------------------------------------

    2019/10/10 14:15:01 ERROR 2 (0x00000002) Accessing Source Directory C:\Users\TESTUSER\AppData\Local\Microsoft\Teams\
    The system cannot find the file specified.


    The other files are copied:

    -------------------------------------------------------------------------------
       ROBOCOPY     ::     Robust File Copy for Windows                              
    -------------------------------------------------------------------------------

      Started : donderdag 10 oktober 2019 14:15:01
       Source : C:\Users\TESTUSER\AppData\Roaming\Microsoft\Teams\
         Dest : C:\Windows\TEMP\FrxMount{0E156513-01D1-4562-970A-F2E2924BB170}\Teams\data\

        Files : *.*
        
      Options : *.* /S /E /COPYALL /PURGE /MIR /B /NP /IT /XJD /MT:8 /R:5 /W:1 

    SAMPLE of the NEW FILE copy:

    ------------------------------------------------------------------------------

        New File     20480 C:\Users\TESTUSER\AppData\Roaming\Microsoft\Teams\Cookies
        New File         0 C:\Users\TESTUSER\AppData\Roaming\Microsoft\Teams\Cookies-journal
        New File      1291 C:\Users\TESTUSER\AppData\Roaming\Microsoft\Teams\desktop-config.json
        New File        10 C:\Users\TESTUSER\AppData\Roaming\Microsoft\Teams\installTime.txt
        New File    187395 C:\Users\TESTUSER\AppData\Roaming\Microsoft\Teams\logs.txt
        New File       767 C:\Users\TESTUSER\AppData\Roaming\Microsoft\Teams\Network Persistent State
        New File      7452 C:\Users\TESTUSER\AppData\Roaming\Microsoft\Teams\preauth.json
        New File        69 C:\Users\TESTUSER\AppData\Roaming\Microsoft\Teams\Preferences
        New File     53248 C:\Users\TESTUSER\AppData\Roaming\Microsoft\Teams\QuotaManager
        New File      8720 C:\Users\TESTUSER\AppData\Roaming\Microsoft\Teams\QuotaManager-journal
        New File     63567 C:\Users\TESTUSER\AppData\Roaming\Microsoft\Teams\settings.json
        New File      3695 C:\Users\TESTUSER\AppData\Roaming\Microsoft\Teams\storage.json
        New File         0 C:\Users\TESTUSER\AppData\Roaming\Microsoft\Teams\watchdog.txt
        New File     45056 C:\Users\TESTUSER\AppData\Roaming\Microsoft\Teams\Cache\data_0
        New File    270336 C:\Users\TESTUSER\AppData\Roaming\Microsoft\Teams\Cache\data_1
        New File     1.0 m C:\Users\TESTUSER\AppData\Roaming\Microsoft\Teams\Cache\data_2
        New File     4.0 m C:\Users\TESTUSER\AppData\Roaming\Microsoft\Teams\Cache\data_3
        New File     26089 C:\Users\TESTUSER\AppData\Roaming\Microsoft\Teams\Cache\f_000001
        New File    133064 C:\Users\TESTUSER\AppData\Roaming\Microsoft\Teams\Cache\f_000002
        New File    123827 C:\Users\TESTUSER\AppData\Roaming\Microsoft\Teams\Cache\f_000003

    ------------------------------------------------------------------------------

                   Total    Copied   Skipped  Mismatch    FAILED    Extras
        Dirs :        25        25         1         0         0         0
       Files :       355       355         0         0         0         0
       Bytes :  109.43 m  109.43 m         0         0         0         0
       Times :   0:00:11   0:00:01                       0:00:00   0:00:00
       Ended : donderdag 10 oktober 2019 14:15:03

    What could be the reason that only that particular directory is an issue? I tried this on 2 systems:

    Windows 2016 with AV

    Windows 2019 without AV

    Both have the same issue. When using Profile Containers I have no issue at all.

    Thanks!

    Thursday, October 10, 2019 12:35 PM

All replies

  • @Brian Olthof, Error 2 would typically mean 'file not found'. Does the user have data in that directory (C:\Users\TESTUSER\AppData\Local\Microsoft\Teams)? Can you manually do the robocopy (and just copy it to some other temporary location as a test)?
    Friday, October 11, 2019 9:56 PM
    Moderator
  • Hi Micah,

    Thanks for the suggestion. I already tried to copy it manually and that works. The folder is not empty, it has files.

    I also tried it on a clean Windows 2016 server, no problem then and a Windows 10 VDI also not a problem. It must be something in the config on both 2016/2019 machines that is blocking this.

    I have a workaround now, I installed the Teams client now in the Program Files (x86) folder so it's not installing for every user in the %localappdata%. Now FSLogix skips the application folder and now it completes without an issue.

    If I find the issue I'll update this here.

    Brian


    Sunday, October 13, 2019 10:10 AM