locked
Visual Studio 2008 crashes while opening .vb file RRS feed

  • Question

  • User857035768 posted

    Hi all,

    i have a very big problem on my MVC 1.0 web application.

    i can open the solution successfully, i can open the aspx and ascx file successfully
    but when i try to open vb file Visual Studio 2008 crashes without any error messages.

    in past days i tried to uninstall and install VS 2008 twice but i have always the same problem.

    my pc has the following configuration:
    Windows 7 Enterprise SP1
    RAM 3 GB
    Microsoft Visual Studio 2008 Version 9.0.30729.4462 QFE
    Microsoft .NET Framework Version 1.1
    Microsoft .NET Framework Version 2.0 SP2
    Microsoft .NET Framework Version 3.5 SP1
    Microsoft .NET Framework Version 4
    Microsoft ASP.NET MVC 1.0

    please help me !!!

    thanks a lot in advance

    Andrea

    Thursday, May 2, 2013 4:19 AM

Answers

  • User857035768 posted

    Hi all,

    after many installation and reinstallation (Visual Studio, Service Pack, .NET Framework and so on) i finally fix my problem.

    following the solution that i executed:

    The first thing to do is tell the OS to increase the amount user-mode memory from 2GB to 3GB, (If you're running a 64-bit you can skip this step).

    run the following from the Visual Studio command prompt: BCDEDIT /Set IncreaseUserVa 3072

    Then we have make Visual Studio large address aware.

    1.Be sure to backup devenv.exe
    2.Using the Visual Studio command prompt, navigate to C:\Program Files\Microsoft Visual Studio 9\Common7\IDE\
    3.execute the following command:
       1:  editbin /LARGEADDRESSAWARE devenv.exe

    Finally you'll use the old Microsoft-fix-all - reboot your pc.

    thanks a lot to all for your suggestions.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, May 15, 2013 5:24 AM

All replies

  • User1508394307 posted

    Are you able to create new vb project and edit vb files there?

    Try to call "devenv /setup"

    Sunday, May 5, 2013 3:30 AM
  • User857035768 posted

    Hi Smirnov,

    first of all thanks a lot for your replay.

    yes, if i create a new vb project then i can edit all files .aspx and .vb, i think the problem depends on project, i tried to delete the .suo and .user files but the problem remains.

    i tried also to start VS from dos shell using "devenv /setup", "devenv /resetsettings" and "devenv /safemode" but i have always the same problem.

    have you got any other suggestion??? please help me!!!!

    thanks a lot

    Regards.

    Monday, May 6, 2013 3:04 AM
  • User1508394307 posted

    If this is something wrong with the project file, you can try to create a new project (with a new name or in another folder), and add all vb-files into it. If IDE crashes on some specific file only then try to add only that file. 

    Monday, May 6, 2013 3:10 AM
  • User857035768 posted

    i just created a new project and added all file, now when i try to open vb file i get the following error:

    "An unhandled exception ('System.Runtime.InteropServices.COMException') occurred in devenv.exe [4236]"

    i have a jpg file error, if you want i can send it.

    thanks a lot.

    Monday, May 6, 2013 8:13 AM
  • User-166373564 posted

    Hi,

    "An unhandled exception ('System.Runtime.InteropServices.COMException') occurred in devenv.exe [4236]"

    The exception that is thrown when an unrecognized HRESULT is returned from a COM method call, please this is helpful to troubleshoot,

    With regards

     

    Wednesday, May 8, 2013 1:20 AM
  • User857035768 posted

    Hi,

    this morning i can open vb file but when i try to save it i get two errors:

    1. Error 1 Visual Basic compiler is unable to recover from the following error: Not enough memory to execute the command.
    Save your work and restart Visual Studio.

    2. Error 4 A problem occurred while trying to set the "References" parameter for the IDE's in-process compiler. Error HRESULT E_FAIL has been returned from a call to a COM component. FuelManagement

    Wednesday, May 8, 2013 3:15 AM
  • User-166373564 posted

    Hi cina

    cina76

    1. Error 1 Visual Basic compiler is unable to recover from the following error: Not enough memory to execute the command.  Save your work and restart Visual Studio.

    Generally this error is caused by not enough memory, or a lack of available memory;

    cina76

    Error 4 A problem occurred while trying to set the "References" parameter for the IDE's in-process compiler. Error HRESULT E_FAIL has been returned from a call to a COM component. FuelManagement

    You could refer the workaround, and check whether it is helpful to fix this error,

    At the same time you could consider re-do this .VB file, I think it will fix the protential issues,

    With regards

    Sunday, May 12, 2013 11:20 PM
  • User857035768 posted

    Hi,

    about the memory i think is not the real problem, one month ago i worked on the same .net solution on the same pc that i'm using now (always 3BG of RAM), in the past I've never had this problem about the memory.

    i also tried to create a new solution adding each file and re-do the vb file but i have always the problem.

    i have no more idea, please help me !!!!

    Monday, May 13, 2013 9:03 AM
  • User1508394307 posted

    This is something wrong with your setup of VS.NET. I understand that your already reinstalled it but the thing is that it might not delete old settings from registry/file system or didn't reinstall missing or wrong COMs. 

    Even it might not help, you can try the following. Create a new empty project. Add new empty vb class. Copy code from existing vb class which usually crashes VS.NET and paste it to a new class file. See if the same error happens within the new project. If doesn't, do the same for other vb files until you don't find the one which fails. 

    If nothing helps I'm afraid you have to repair or completely reinstall Windows.

    Monday, May 13, 2013 9:19 AM
  • User857035768 posted

    Hi all,

    after many installation and reinstallation (Visual Studio, Service Pack, .NET Framework and so on) i finally fix my problem.

    following the solution that i executed:

    The first thing to do is tell the OS to increase the amount user-mode memory from 2GB to 3GB, (If you're running a 64-bit you can skip this step).

    run the following from the Visual Studio command prompt: BCDEDIT /Set IncreaseUserVa 3072

    Then we have make Visual Studio large address aware.

    1.Be sure to backup devenv.exe
    2.Using the Visual Studio command prompt, navigate to C:\Program Files\Microsoft Visual Studio 9\Common7\IDE\
    3.execute the following command:
       1:  editbin /LARGEADDRESSAWARE devenv.exe

    Finally you'll use the old Microsoft-fix-all - reboot your pc.

    thanks a lot to all for your suggestions.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, May 15, 2013 5:24 AM
  • User-166373564 posted

    Hi cina

    Congratulations! I’m glad to hear that you have solved this issue by yourself, and it is very appreciated to share your solution to us. It will be helpful for other community members who has similar problem, and welcome to post your question on our asp.net forum in the future,

     Best regards

    Wednesday, May 15, 2013 5:38 AM