none
HTTP/1.1 500 Internal Server Error (Schedule an online meeting Lync) RRS feed

  • Question

  • I'm trying to create a meeting,

    after obtaining a valid  application, as indicated in the official documentation UCWA.

    I try to schedule a meeting with the POST request

    <URL_DOMAIN>/ucwa/oauth/v1/applications/10743305177/onlineMeetings/myOnlineMeetings

    in the request body I put

    {"attendanceAnnouncementsStatus":"Disabled",

    "description":"TEST meeting",

    "subject":"test API",

    "attendees":["sip:test1@<DOMAIN>","sip:test2@<DOMAIN>"],

    "leaders":"[sip:test1@<DOMAIN>]"}

    }

    In the response I have this error:

    HTTP/1.1 500 Internal Server Error [Cache-Control: no-cache, Pragma: no-cache, Via: 1.1 lync.links.local RtcInt, Content-Length: 143, Content-Type: application/json, Expires: -1, Server: Microsoft-IIS/7.5, X-MS-Server-Fqdn: lync.links.local, X-AspNet-Version: 4.0.30319, X-Powered-By: ASP.NET, Date: Tue, 16 Sep 2014 08:17:02 GMT]

    I have tried UCWA sample code ( UCWA helper libraries. ) and it works fine.

    What is wrong in the POST request for the meeting?

    It may be a problem of missing information in the request header?

    Accept: application/json
    Content-Type: application/json
    Authorization: Bearer cwt=AAEB...buHc
    X-Ms-Origin: http://localhost
    X-Requested-With: XMLHttpRequest
    Referer: <URL_LYNC>/Autodiscover/XFrame/XFrame.html
    Accept-Language: en-US
    Accept-Encoding: gzip, deflate
    User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.2; Trident/6.0; .NET4.0E; .NET4.0C; .NET CLR 3.5.30729; .NET CLR 2.0.50727; .NET CLR 3.0.30729; InfoPath.3)
    Host: <LYNC_HOST>
    Content-Length: 185
    DNT: 1
    Connection: Keep-Alive
    Cache-Control: no-cache




    Thursday, September 18, 2014 10:48 AM

All replies

  • What does the request body look like for the failed meeting creation?  I ask this because it states in the headers that the content is application/json.

    The line with your leaders parameter looks incorrect: leaders":"[sip:test1@<DOMAIN>]"}

    The value inside the array should have quotes around it and the trailing curly brace would match with the original object meaning the final on the line below would cause validation failure.

    Thursday, September 18, 2014 7:10 PM
  • Hello Shelby,

    was my typing error the JSON request is

    {"attendanceAnnouncementsStatus":"Disabled",

    "description":"TEST meeting",

    "subject":"test API",

    "attendees":["sip:test1@<DOMAIN>","sip:test2@<DOMAIN>"],

    "leaders":["sip:test1@<DOMAIN>"]}

    }

    and I have the same error

    HTTP/1.1 500 Internal Server Error

    Friday, September 19, 2014 7:02 AM
  • Hello,

    put "leaders":[] it works fine, I cannot understand why this happens,

    Thanks

    O.

    Friday, September 19, 2014 6:35 PM