none
Biztalk 2013 configuration with remote sqlserver 2008 R2 RRS feed

  • Question

  • Hi

    can any one help me to configure Biztalk server 2013 with remote sqlserver 2008 R2(Installed in other system) ,

    what are the steps need to be follow to configure the same.

    Wednesday, April 2, 2014 9:21 AM

Answers

  • Follow the help from here


    Please mark the post as answer if this answers your question. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply.



    • Edited by Ravindar Thati Wednesday, April 2, 2014 9:36 AM
    • Marked as answer by Angie Xu Wednesday, April 9, 2014 1:29 AM
    Wednesday, April 2, 2014 9:31 AM

All replies

  • Follow the help from here


    Please mark the post as answer if this answers your question. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply.



    • Edited by Ravindar Thati Wednesday, April 2, 2014 9:36 AM
    • Marked as answer by Angie Xu Wednesday, April 9, 2014 1:29 AM
    Wednesday, April 2, 2014 9:31 AM
  • There are certain Configuration setting which you need to take care while configuring Biz Talk with remote SQL Server.

    1) Create  Windows domain Group on AD such as Biz Talk Administrator,Biz Talk Operator ,SSO Administrator ,SSO Affiliation , Biz Talk User etc.

    2) Use a domain account to communicate with APP and  Biz Talk SQL Server

    3) Enable MSDTC on both SQL and BizTalk App Server .

    4) Try DTCPing to to test the Connectivity from APP to SQL Server.

    Other details can be found on below links

    http://msdn.microsoft.com/en-us/library/jj248704%28v=bts.80%29.aspx

    Thanks

    Abhishek


    Wednesday, April 2, 2014 9:37 AM
  • configure Biztalk 2013 with remote SQL is bit similar like with Biztalk 2010 .

    Refer article

    the configuration used in the article is using Remote SQL .

    if you are facing specific problem while configuration pleases post here.

    Regards

    Mohit Gupta

    Wednesday, April 2, 2014 9:43 AM
  • Hi All,

    Thanks for the quick repose ,i am getting below error while configure the BTS 2013 .

    Error Details:

    TITLE: Microsoft BizTalk Server Configuration Wizard
    ------------------------------

    Failed to create the SQL database 'SSODB' on SQL Server '' (with SSO Administrator account 'SSO Administrators'). (SSO)

    For help, click: http://go.microsoft.com/fwlink/events.asp?ProdName=Microsoft+BizTalk+Server+2013&ProdVer=3.10.229.0&EvtSrc=SSO&EvtID

    ------------------------------
    ADDITIONAL INFORMATION:

    (0xC0002A21) An error occurred while attempting to access the SSO database.
     (SSO)

    For help, click: http://go.microsoft.com/fwlink/events.asp?ProdName=Microsoft+BizTalk+Server+2013&ProdVer=3.10.229.0&EvtSrc=SSO&EvtID

    ------------------------------

    An error occurred while attempting to access the SSO database. See the event log (on computer ' ') for more details.
     (SSO)

    For help, click: http://go.microsoft.com/fwlink/events.asp?ProdName=Microsoft+BizTalk+Server+2013&ProdVer=3.10.229.0&EvtSrc=SSO&EvtID

    ------------------------------
    BUTTONS:

    OK
    ------------------------------

    Wednesday, April 2, 2014 9:47 AM
  • Hi,

    Can you check

    1.  user is within the SSO Administrators group
    2. Check that the service of SSO is Enabled and running
    3. permissions  correctly on the user account which is used to the configuration. Have you checked that the user has Server Administrator rights on the SQL Server?

    Thanks

    Abhishek


    Wednesday, April 2, 2014 9:53 AM
  • Hi Abhishek,

    Let me clarify some points,

    1. i am using domain user to configure BTS server 2013.

    2. In local system(Installed BTS server 2013),i don't find SSO administrator group .

    3. I am not able to see the SSO service in services(In BTS installed system) ,for this we need to configure ENTSSO from BTS configuration .

    4.The user have DB creator and Server admin ,is it required to Sys admin, because manually i tried to create DB it giving select permission issue .

    Wednesday, April 2, 2014 10:11 AM
  • Hi Vittal,

    Point to be taken in consideration

    Local user group wont work if you configure BizTalk with remote sql server

    You need to create Windows group on AD for SSO Administrators,SSO Affiliate Administrators,BizTalk Server Administrators,BizTalk Server Operators,BizTalk Application Users,BizTalk Isolated Host Users and BizTalk B2B Operators Group .

    Then you need to make the domain user member of these group.

    Thanks

    Abhishek

    Wednesday, April 2, 2014 10:21 AM
  • Just one question, is this the first time Biztalk is being configured in this system?

    i mean if already BizTalk was configured and recently you unconfigured and trying to reconfigure

    then there is a chance that all biztalk databases files still present in SQL server system in configured folders and you have to delete them manually.

    The error you mentioned may occur in above cases also,i have faced it.

    Failed to create the SQL database 'SSODB' on SQL Server '' (with SSO Administrator account 'SSO Administrators'). (SSO)


    Please mark the post as answer if this answers your question. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply.



    Wednesday, April 2, 2014 10:23 AM
  • Hi

    Since you are using Domain User for configuring biztalk , then you have to manually create group for SSO as well.

    refer article

    it gives you details what are the groups you need to create and what are the rights group required in SQL Server as well.

    Regards

    Mohit

    Wednesday, April 2, 2014 10:24 AM
  • Yes Mohit, you are right, but in such case, it will explicitly displays the error that unable to find the Group.

    but such error is not found in the error posted by vittalaranga


    Please mark the post as answer if this answers your question. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply.

    Wednesday, April 2, 2014 10:28 AM
  • Just incase if this is not the first time BizTalk being configured in this system,

    you better check if the biztalk database files are present at path like below depending on your SQL version

    C:\Program Files\Microsoft SQL Server\MSSQL10_50.SQLEXPRESS\MSSQL\DATA  in SQL machine.

    if they are present you may have to delete them.


    Please mark the post as answer if this answers your question. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply.




    Wednesday, April 2, 2014 10:36 AM
  • refer article

    Article also give details about what database rights required by which user/group.

    Wednesday, April 2, 2014 11:47 AM
  • Hi Ashwin

    Is it possible to configure BTS 2013,if create only below groups in AD

                SSO Administrators,

    ·         SSO Affiliate Administrators,

    ·         BizTalk Server Administrators,

    Wednesday, April 2, 2014 3:15 PM
  • Possible?  Sure.

    Recommended.  No.

    You should also create:

    • BizTalk Server Operators
    • BizTalk B2B Operators Group
    • BizTalk Application Users
    • BizTalk Isolated Host Users (if you will be using Isolated Receive Locations, IIS)

    Reveiw the above article carefully and create Groups and Users for all services you will be using.  There's not much to gain by taking short cuts here.

    Wednesday, April 2, 2014 3:26 PM
    Moderator
  • Thanks for all ,

    we have created above mentioned Groups in Active directory ,

    i have configured SSO,Grups,runtime engine and Ruleengine successfully ,

    but while configure BAM Tool i am getting database permission issue ,please find the attached screen shot



    Thursday, April 3, 2014 11:40 AM
  • I am following  the url http://support.microsoft.com/kb/2838133/en-us ,to configure the BAM tool,will update once it done.

    if is there any other ways to configure BAM tool ,please share the details.

    Thursday, April 3, 2014 1:04 PM
  • The Protocols in SQL Server Configuraiton have to match on the client and server.

    TCP/IP is recommended and the others should be disabled on both the client and server.

    Thursday, April 3, 2014 2:50 PM
    Moderator