none
Benutzerdefiniertes Menü in Access 2007 verschwunden

    Frage

  • Hallo zusammen,

    eine mit Access 2003 entwickelte Anwendung enthält eine benutzerdefinierte Menüleiste, die unter Access 2007 ja als Add-in geladen wird. Die Anwendung zeigt nach dem Start allein diese Menüleiste an.

    Einer der Anwender hat seine Installation dazu gebracht, dass die Menüleiste nicht mehr angezeigt wird. Öffne ich die Anwendung ohne die Starteinstellungen ausführen zu lassen, fehlt der Tabreiter für Add-ins, da die Menüleiste anscheinend nicht existent ist. Alle Access-Optionen sind korrekt eingetragen, also auch der Name der Menüleiste, die nach dem Start angezeigt werden soll.

    Ich entsinne mich dunkel, dass es unter Access 2003 dieses Problem auch schon einmal gegeben hat, aber nicht mehr, wie ich es damals gelöst habe.

    Kann mir da jemand helfen?

    Vielen Dank im Voraus.

    Viele Grüße,
    Michael Schörner

    Samstag, 22. September 2012 14:54

Antworten

  • Hallo Gunter,

    die Anwendung wird über eine Starteranwendung verteilt. Ich habe daher die bestehende Anwendungsdatei gelöscht und durch die aktuelle auf dem Server ersetzen lassen. Das hatte auf das Vorhandensein der Menüleiste genausowenig einen Einfluss wie der neuerliche Import der Menüleiste aus einer anderen Version sowie die testweise Verwendung meiner Entwicklungsversion auf seinem Rechner. In allen Fällen wurde die Menüleiste nicht angezeigt. Außerdem erschient die Menüleiste nach wie vor unter "Access-Optionen | aktuelle Datenbank" als voreingestellte Menüleiste.

    Trotzdem danke für Deine Antwort.

    Nachtrag:
    Mittlerweile habe ich eine Lösung für das Problem gefunden, wenngleich ich noch keine Begründung für das Problem habe. Ich habe in der Startprozedur den Befehl

    CommandBars("Name").visible = True
    gesetzt. Nun wird die Menüleiste wieder angezeigt. Soweit so gut. Warum aber diese Menüleiste zuvor auch in ganz anderen Dateiversionen nicht angezeigt wurde, bleibt mir ein Rätsel.

    Viele Grüße,
    Michael Schörner


    Samstag, 22. September 2012 20:39

Alle Antworten

  • Hallo Michael,

    Michael Schörner schrieb folgendes:

    Einer der Anwender hat seine Installation dazu gebracht, dass die Menüleiste nicht mehr angezeigt wird. Öffne ich die Anwendung ohne die Starteinstellungen ausführen zu lassen, fehlt der Tabreiter für Add-ins, da die Menüleiste anscheinend nicht existent ist. Alle Access-Optionen sind korrekt eingetragen, also auch der Name der Menüleiste, die nach dem Start angezeigt werden soll.

    Er wird diese gelöscht haben wie unter
    http://www.accessribbon.de/index.php?FAQ:20 P2 beschrieben.

    Gruß
    Gunter


    Access FAQ: http://www.donkarl.com

          http://www.avenius.de - http://www.AccessRibbon.de
    http://www.ribboncreator.de - http://www.ribboncreator2010.de

    Samstag, 22. September 2012 16:33
    Moderator
  • Hallo Gunter,

    die Anwendung wird über eine Starteranwendung verteilt. Ich habe daher die bestehende Anwendungsdatei gelöscht und durch die aktuelle auf dem Server ersetzen lassen. Das hatte auf das Vorhandensein der Menüleiste genausowenig einen Einfluss wie der neuerliche Import der Menüleiste aus einer anderen Version sowie die testweise Verwendung meiner Entwicklungsversion auf seinem Rechner. In allen Fällen wurde die Menüleiste nicht angezeigt. Außerdem erschient die Menüleiste nach wie vor unter "Access-Optionen | aktuelle Datenbank" als voreingestellte Menüleiste.

    Trotzdem danke für Deine Antwort.

    Nachtrag:
    Mittlerweile habe ich eine Lösung für das Problem gefunden, wenngleich ich noch keine Begründung für das Problem habe. Ich habe in der Startprozedur den Befehl

    CommandBars("Name").visible = True
    gesetzt. Nun wird die Menüleiste wieder angezeigt. Soweit so gut. Warum aber diese Menüleiste zuvor auch in ganz anderen Dateiversionen nicht angezeigt wurde, bleibt mir ein Rätsel.

    Viele Grüße,
    Michael Schörner


    Samstag, 22. September 2012 20:39