none
Visual Studio stürzt nach dem debuggen ab RRS feed

  • Frage

  • Hallo

    Nach dem Erstellen eines Projektes stürzt Visual Studio ohne Fehlermeldung ab. Nach dem Neustart funktioniert das Projekt ohne Probleme und ich kann es erstellen. Verändere ich das Projekt, dann stürzt Visual Studio wieder ab. Wie komme ich an eine Fehlermeldung um das Probelm ein zu kreisen?

    Danke für Eure Hilfe im Voraus.

    Mittwoch, 20. November 2013 19:15

Antworten

  • Hi,

    dort steht aber auch, dass man regsvr32 mit einem Parameter aufrufen soll.

    For 32-bit operating systems, run the following command:
    regsvr32 "c:\Program Files\Internet Explorer\ieproxy.dll"

    For 64-bit operating systems, run the following command:
    regsvr32 "c:\Program Files (x86)\Internet Explorer\ieproxy.dll"


    Gruß, Stefan
    Microsoft MVP - Visual Developer ASP/ASP.NET
    http://www.asp-solutions.de/ - Consulting, Development
    http://www.aspnetzone.de/ - ASP.NET Zone, die ASP.NET Community

    • Als Antwort vorgeschlagen Ciprian Bogdan Donnerstag, 21. November 2013 12:08
    • Als Antwort markiert Ciprian Bogdan Dienstag, 26. November 2013 14:43
    Donnerstag, 21. November 2013 09:16
    Moderator

Alle Antworten

  • Hi,

    schau doch mal bitte ins Windows Ereignisprotokoll. Ggfs. findet sich da etwas zum Fehler.

    Tritt das bei allen Projekten auf oder nur bei einem speziellen?


    Gruß, Stefan
    Microsoft MVP - Visual Developer ASP/ASP.NET
    http://www.asp-solutions.de/ - Consulting, Development
    http://www.aspnetzone.de/ - ASP.NET Zone, die ASP.NET Community

    Mittwoch, 20. November 2013 19:17
    Moderator
  • Hallo,
    ergänzend zu Stefan, hast du irgendwelche Extras installiert? Welche Version von VS benutzt du (2010, 2012, .../Express fürs Web, Express...,Professional, ...)?

    Koopakiller [kuːpakɪllɐ] (Tom Lambert)
    Webseite | Code Beispiele | Facebook | Twitter | Snippets   C# ↔ VB.NET Konverter
    Markiert bitte beantwortende Posts als Antwort und bewertet Beiträge. Danke.

    Mittwoch, 20. November 2013 19:24
    Moderator
  • Hallo,

    schon einmal Danke für die Antworten.

    Ich nutze Visual Studio 2010 Professional mit Windows 7 /64Bit.

    Es stürzt bei allen Projekten ab, selbst wenn ich ein leeres Projekt erstelle, debugge stürzt VS ab, startet automatisch neu und dann funktioniert es.

    Könnte es hiermit zusammen hängen?

    Unbehandelte Ausnahme bei 0x76c1c41f in devenv.exe: 0xE0434352: 0xe0434352.

    Wie kann ich dieses beseitigen?

    Danke für Eure Antworten im Voraus und Gruss

    Donnerstag, 21. November 2013 07:42
  • Hallo in der Ereignisanzeige habe ich folgenden Fehlereintrag gefunden:

    Anwendung: devenv.exe Frameworkversion: v4.0.30319 Beschreibung: Der Prozess wurde aufgrund einer unbehandelten Ausnahme beendet. Ausnahmeinformationen: System.InvalidCastException Stapel: bei System.StubHelpers.StubHelpers.GetCOMIPFromRCW(System.Object, IntPtr, IntPtr ByRef, Boolean ByRef) bei Microsoft.VisualStudio.OLE.Interop.IServiceProvider.QueryService(System.Guid ByRef, System.Guid ByRef, IntPtr ByRef) bei Microsoft.VisualStudio.Shell.ServiceProvider.GetService(System.Guid, System.Type) bei Microsoft.VisualStudio.Shell.ServiceProvider.GetService(System.Type) bei Microsoft.VisualStudio.Shell.ThreadHelper.get_Invoker() bei Microsoft.VisualStudio.Shell.ThreadHelper.InvokeOnUIThread(Microsoft.VisualStudio.Shell.InvokableBase) bei Microsoft.VisualStudio.Shell.ThreadHelper.Invoke(System.Action) bei Microsoft.VisualStudio.Project.VS.Implementation.VSShellServices.InvokeOnUIThread(System.Action) bei Microsoft.VisualStudio.Project.VisualC.VCProjectEngine.ApartmentMarshaler.Invoke(System.Action) bei Microsoft.VisualStudio.Project.VisualC.VCProjectEngine.VCConfigBuildJob.BuildCompleted(Microsoft.Build.Execution.BuildSubmission) bei Microsoft.VisualStudio.Project.Contracts.Implementation.BuildProjectBase+BuildCompletedCallbackManager.BuildCompleted(Microsoft.Build.Execution.BuildSubmission) bei Microsoft.Build.Execution.BuildSubmission.<CheckForCompletion>b__0(System.Object) bei Microsoft.Build.Shared.ThreadPoolExtensions+<>c__DisplayClass1.<QueueThreadPoolWorkItemWithCulture>b__0(System.Object) bei System.Threading.QueueUserWorkItemCallback.WaitCallback_Context(System.Object) bei System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean) bei System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean) bei System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem() bei System.Threading.ThreadPoolWorkQueue.Dispatch() bei System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()

    Donnerstag, 21. November 2013 07:48
  • Hi,

    schau mal hier:

      http://connect.microsoft.com/VisualStudio/feedback/details/550458/build-crashes-the-ide

      http://connect.microsoft.com/VisualStudio/feedback/details/736940/my-visual-studio-11-is-crash-i-never-used-it-after-install

    Die Fehlermeldungen an sich sind auf Connect bekannt und dort findest Du auch ein paar mögliche Lösungen und Hinweise auf mögliche Ursachen. Probier das mal bitte. Sollte es gar nicht helfen, meld dich nochmal hier.


    Gruß, Stefan
    Microsoft MVP - Visual Developer ASP/ASP.NET
    http://www.asp-solutions.de/ - Consulting, Development
    http://www.aspnetzone.de/ - ASP.NET Zone, die ASP.NET Community


    Donnerstag, 21. November 2013 08:11
    Moderator
  • Hallo

    Danke für den sehr interessanten Link. Bei mir läuft nur VS2010 und mit den installierten Add In, lief das System ohne Probleme. Macht das jetzt wirklich sinn, dort die Einträge zu ändern?

    Danke und Gruss

    Donnerstag, 21. November 2013 08:49
  • Hi,

    zumindest einen Versuch ist es wert. Einfach mal ausprobieren und wenn es klappt, freuen :)


    Gruß, Stefan
    Microsoft MVP - Visual Developer ASP/ASP.NET
    http://www.asp-solutions.de/ - Consulting, Development
    http://www.aspnetzone.de/ - ASP.NET Zone, die ASP.NET Community

    Donnerstag, 21. November 2013 08:58
    Moderator
  • Hi.

    Der Versuch hat leider keinen Erfolg gebracht. Ich habe alles Add In's gelöscht incl. der Verzeichnisse. Das Ergebnis ist immer noch das gleiche!

    Danke und Gruss

    Donnerstag, 21. November 2013 09:09
  • Hi,

    dort steht aber auch, dass man regsvr32 mit einem Parameter aufrufen soll.

    For 32-bit operating systems, run the following command:
    regsvr32 "c:\Program Files\Internet Explorer\ieproxy.dll"

    For 64-bit operating systems, run the following command:
    regsvr32 "c:\Program Files (x86)\Internet Explorer\ieproxy.dll"


    Gruß, Stefan
    Microsoft MVP - Visual Developer ASP/ASP.NET
    http://www.asp-solutions.de/ - Consulting, Development
    http://www.aspnetzone.de/ - ASP.NET Zone, die ASP.NET Community

    • Als Antwort vorgeschlagen Ciprian Bogdan Donnerstag, 21. November 2013 12:08
    • Als Antwort markiert Ciprian Bogdan Dienstag, 26. November 2013 14:43
    Donnerstag, 21. November 2013 09:16
    Moderator
  • Hallo Stefan.

    Vielen Dank, das hatte ich überlesen. Danach scheint es zu funktionieren. Hoffen wir das es so bleibt.

    Nochmals herzlichen Dank und Gruss

    Donnerstag, 21. November 2013 09:35