none
Using oder Assemblyverweis nicht gefunden RRS feed

  • Frage

  • Hi Leute,

    mein Prof hat bei uns in der Uni Eine Datenbankbasierte Verwaltung von Fußballmannschaften Via Mdi Parent und untergeordneten Forms realisiert, welche den Inhalt aus einer SQL DB ziehen.

    Nun sollen wir als Aufgabe eine Hochschulverwaltung selber schreiben. Die Datenbank haben wir vorgegeben bekommen.

    Also gesagt getan ..... DB angebunden.... MDI Parent angelegt ---- Klasse mit Colums extra für die Tabelle Studenten geschrieben ----- StudentenTabelle aus db via DataGridView in das FormStudent angehangen.

    soweit so gut

    Im Mdi im Toolstrip über Datei öffnen - Stammdaten - Studentenverwaltung angelegt

    Nun habe ich das Problem, dass das mdi den Befehl CheckFormTypeAlreadyOpen sowie das damit verbundene FormStudent nicht finden kann mit denen c# ja mein FormStudent bei klick auf den Button öffnet.

    1. using System ;
    2. using System.Collections.Generic ;
    3. using System.ComponentModel ;
    4. using System.Data ;
    5. using System.Drawing ;
    6. using System.Linq ;
    7. using System.Text ;
    8. using System.Windows.Forms ;
    9. using System.Data.Linq ;

    1. private void studentenverwaltungToolStripMenuItem_Click( object sender, EventArgs e)
    2.         {
    3.             if ( CheckFormTypeAlreadyOpen( typeof ( FormStudent) ) == false )
    4.             {
    5.                 FormStudent student = new FormStudent( ) ;
    6.                 student.MdiParent = this;
    7.                 student.Show ( ) ;
    8.             }

    Samstag, 11. Juli 2009 12:40

Antworten

Alle Antworten