none
Access: Feldwert aus selektionierter Zeile auslesen.

    Frage

  • Hallo zusammen

    Ich habe ein Formular mit zwei Unterformularen. Nun will ich eine Zeile eines Forumlars selektionieren können, so dass dann automatisch ein Attributwert dieser Zeile als neuer Datensatz im anderen Unterformular eingefügt wird. Da ich schon länger nicht mehr mit Access gearbeitet habe, wäre es gut, wenn dies mittels Makros möglich wäre. Kann mir jemand helfen?


    Danke und Gruss,

    M. Zimmermann

    Dienstag, 26. Juli 2011 11:50

Antworten

Alle Antworten

  • Am 26.07.2011 schrieb M. Zimmermann:

    Ich habe ein Formular mit zwei Unterformularen. Nun will ich eine Zeile eines Forumlars selektionieren können, so dass dann automatisch ein Attributwert dieser Zeile als neuer Datensatz im anderen Unterformular eingefügt wird. Da ich schon länger nicht mehr mit Access gearbeitet habe, wäre es gut, wenn dies mittels Makros möglich wäre. Kann mir jemand helfen?

    Evtl. hilft dir die FAQ bei der Syntax: http://www.donkarl.com?FAQ4.2
    Ansonsten mußt Du noch etwas deutlicher werden wo genau es hakt.

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/

    Dienstag, 26. Juli 2011 17:51
  • Hallo Winfried

     

    Danke für die Antwort.

    Ich bin zwischenzeitlich ein Stück weiter und habe diverse Änderungen vorgenommen.

    Ich habe aber noch ein Problem. Die umgebung ist wie gesagt folgende. Ein Formular, mit zwei Unterformularen. Ich habe nun ein Endlosforumular im Unterformular 1 welches mit einem command-button den PK als neuen Datensatz in das Unterformular 2 überträgt. Doch der Datensatz um Unterformular 2 hat zwar den Wert ist aber noch immer "in Bearbeitung".

    Ich muss am Schluss ein einen formular aufrufen, muss aber zuerst noch den Datensatz im Unterformular 2 speichern. Aber alle Aktionen (Makroeditor) welche ich ausführe werden an der Position des command-buttons gemacht, also im Unterformular 1.

    Kannst du mir einen Tipp geben, wie ich in das Unterformular zwei springen kann damit der Datensatz übernommen wird. Es reicht mit der Maus rein zu klicken, aber dies schaffe ich mit dem Makro nicht.

    Danke für die Hilfe.

     

    Gruss, Martin

    Freitag, 29. Juli 2011 07:55
  • Es ist mir schon wieder passiert.

    Da arbeitet man lange an einer Lösungen und denkt, so jetzt bitte ich andere um Rat, und kaum hat man die Frage gestellt fällt einem eine Lösung ein.

    ich habe es gelöst, dass ich nicht den Wert in das Unterformular 2 schreiben, sondern das Formular welches dem Unterformular 2 zu Grunde liegt öffe, den Wert setze, speichere und schliesse. Denn das Unterformular 2 wird ansonsten auf dem Hauptformular garnicht benötigt. Ich muss hier eine "Konstruktion" eines Anderen etwas verbessern. Das macht das Ganze so kompliziert.

    Trotzdem Danke,

     

    Gruss, Martin

    Freitag, 29. Juli 2011 08:16