none
Datenbank in inkonsistenten Zustand RRS feed

  • Frage

  • Hallo

    ich habe es letzte zeit vermehrt das die Backend DB im inkonsistenten Zustand

    ist

    auf verschiedenen PC's - Verschiedene Programmversionen(meine Access DB)

    die sonst keine Probleme gemacht haben

    hat jemand ein ähnliches phänomen?

    bis jetzt sind es nur PC's mit windows 7

    Office ist immer ein 365(2016) oder Access Runtime 2013

    Backend liegt auf Windows PC oder auch auf einem NAS

    Dienstag, 5. Juni 2018 06:42

Antworten

  • ...Ich würde es zur Sicherheit am Server und auf den Clients machen...

    So lautet nun auch die aktuelle Empfehlung des Access-Teams. Nachzulesen in dieser Diskussion in den Beiträgen von Shane Groff, einem der zuständigen MS-Techniker. Er erwähnt dort noch einen zweiten potentiellen Workaround. Aber derzeit sieht es so aus, als wäre das erwähnte Leasing-Abschalten erfolgreich.


    Karl
    http://www.AccessDevCon.com
    http://www.donkarl.com

    • Bearbeitet Karl DonaubauerMVP Dienstag, 12. Juni 2018 09:48 Sig
    • Als Antwort markiert MCDPone Donnerstag, 14. Juni 2018 07:19
    Dienstag, 12. Juni 2018 09:47
  • leider finde ich unter Win10 Pro die regeinträge für opportunistic locking

    nicht.

    Mir ist auch nicht ganz klar ob ich die Einstellungen beim Client machen muss oder beim "Server"
    (Welcher in dem Fall ein Win 10 Pro PC ist)

    Hallo!

    Die Beschreibung, wie man das sog. Leasing ausschaltet, findest du unten in diesem Support-Artikel. Es geht also darum, diesen Eintrag hinzuzufügen:

    Key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters
    Value:  DisableLeasing
    Type:  DWORD
    Data:  0x1

    Ich würde es zur Sicherheit am Server und auf den Clients machen. Das ist aber reine Theorie. Praktisch habe ich es zum Glück noch nicht gebraucht, weil ich versionsmäßig immer so weit hinten wie möglich arbeite (-n lasse). Teufelszeug wie ständig upgedatetes Win10 kommt mir erst auf die Rechner, wenn es sich nicht mehr vermeiden lässt. ;-)


    Karl
    http://www.AccessDevCon.com 
    http://www.donkarl.com

    Montag, 11. Juni 2018 16:28

Alle Antworten

  • Hi,
    diesen Zustand hatte ich leider in der Vergangenheit zur Genüge. Er trat immer dann auf, wenn besonders intensiv an mehreren Clients gearbeitet wurde. Die Ursache bei mir war die Zerstörung der ldb. Abhilfe hat nur die Umstellung auf einen Datenbankserver gebracht, da die Access-Datenbank leider nur als Ein-Platz-System konzipiert ist.

    --
    Viele Grüsse
    Peter Fleischer (ehem. MVP)
    Meine Homepage mit Tipps und Tricks

    Dienstag, 5. Juni 2018 10:44
  • Hi,
    Probier doch mal folgendes Setting: 'opportunistic locking'  und disable den falls das nicht der Fall ist.
    Siehe auch:

    https://access-programmers.com/corruption-issues
    oder 
    https://infoage.freshdesk.com/support/solutions/articles/6000007972-access-and-file-based-systems-windows-2012-server-oplocks

    HTH 
    Grüße Alexander

    Mittwoch, 6. Juni 2018 17:58
  • Hallo!

    Ich möchte nur bestätigen, dass es ein Problem ist, das seit ca. Mitte Mai in sämtlichen Access-Foren dieser Welt oft gemeldet wird. Wir haben MS informiert, bisher kam aber noch nicht viel zurück.

    Der einzige potentielle Lösungshinweis, den ich bisher gesehen habe, wurde hier auch schon genannt. Ein paar Leute vermuten, dass mit dem Windows 10 Build 1803 von Mitte Mai das alte OpLocks-Problem "reaktiviert" worden sein könnte. Ich kenne aber noch nicht genug Bestätigungen, dass die Registry-Änderung wirklich hilft. Falls du es versuchst, dann gib bitte über die Wirkung Bescheid.


    Karl
    http://www.AccessDevCon.com
    http://www.donkarl.com


    Donnerstag, 7. Juni 2018 13:31
  • Hallo Danke für die Infos

    leider finde ich unter Win10 Pro die regeinträge für opportunistic locking

    nicht.

    Mir ist auch nicht ganz klar ob ich die Einstellungen beim Client machen muss oder beim "Server"
    (Welcher in dem Fall ein Win 10 Pro PC ist)

    Samstag, 9. Juni 2018 08:28
  • leider finde ich unter Win10 Pro die regeinträge für opportunistic locking

    nicht.

    Mir ist auch nicht ganz klar ob ich die Einstellungen beim Client machen muss oder beim "Server"
    (Welcher in dem Fall ein Win 10 Pro PC ist)

    Hallo!

    Die Beschreibung, wie man das sog. Leasing ausschaltet, findest du unten in diesem Support-Artikel. Es geht also darum, diesen Eintrag hinzuzufügen:

    Key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters
    Value:  DisableLeasing
    Type:  DWORD
    Data:  0x1

    Ich würde es zur Sicherheit am Server und auf den Clients machen. Das ist aber reine Theorie. Praktisch habe ich es zum Glück noch nicht gebraucht, weil ich versionsmäßig immer so weit hinten wie möglich arbeite (-n lasse). Teufelszeug wie ständig upgedatetes Win10 kommt mir erst auf die Rechner, wenn es sich nicht mehr vermeiden lässt. ;-)


    Karl
    http://www.AccessDevCon.com 
    http://www.donkarl.com

    Montag, 11. Juni 2018 16:28
  • ...Ich würde es zur Sicherheit am Server und auf den Clients machen...

    So lautet nun auch die aktuelle Empfehlung des Access-Teams. Nachzulesen in dieser Diskussion in den Beiträgen von Shane Groff, einem der zuständigen MS-Techniker. Er erwähnt dort noch einen zweiten potentiellen Workaround. Aber derzeit sieht es so aus, als wäre das erwähnte Leasing-Abschalten erfolgreich.


    Karl
    http://www.AccessDevCon.com
    http://www.donkarl.com

    • Bearbeitet Karl DonaubauerMVP Dienstag, 12. Juni 2018 09:48 Sig
    • Als Antwort markiert MCDPone Donnerstag, 14. Juni 2018 07:19
    Dienstag, 12. Juni 2018 09:47
  • Ich kann das so bestätigen - nach Änderung habe ich jetzt Ruhe

    für mich sieht es aber so aus das es Mit dem Office 2013 zusammen hängt da ich bei reinen 365 Installationen (2016) keine Probleme habe

    aber das ist nur gefühltes Wissen


    Donnerstag, 14. Juni 2018 07:23
  • Ich kann das so bestätigen - nach Änderung habe ich jetzt Ruhe

    für mich sieht es aber so aus das es Mit dem Office 2013 zusammen hängt da ich bei reinen 365 Installationen (2016) keine Probleme habe

    aber das ist nur gefühltes Wissen

    Danke für die Rückmeldung!

    Ich habe das genau so an das Access-Team weitergegeben. Es gibt inzwischen einige Bestätigungen, dass das Leasing-Abschalten wirkt.

    Man kann nur hoffen, dass sie bald die genaue Windows-Update-Ursache finden, und dass ein wirkungsvoller Bugfix im nächsten Update kommt.


    Karl
    http://www.AccessDevCon.com 
    http://www.donkarl.com

    Donnerstag, 14. Juni 2018 08:08