none
LOB App verabschiedet sich laufend mit Exception 0xc000027b / Faulting Module: combase.dll RRS feed

  • Allgemeine Diskussion

  • Hallo allseits

    Wir betreiben eine LOB-App welche sich - ob gearbeitet wird oder nicht - völlig unmotiviert und nicht reproduzierbar verabschiedet. In den Windows Application Logs erscheint dann jeweils ein Error - Eintrag:

    Weiss jemand Abhilfe? Was kann ich weiter machen, um dem Fehler auf die Spur zu kommen?

    Vielen Dank allseits!

    Mit besten Grüssen

    Willi


    Dienstag, 14. Juni 2016 19:50

Alle Antworten

  • Hallo Willi,

    da wir nicht wissen, was deine App alles macht und was nicht, schau bitte zuerst mal nach der Fehlernummer 0xc000027b.

      https://www.google.de/#q=0xc000027b

    Es finden sich einige Hinweise auf möglkiche Fehlerursachen.

    Ggfs. die Suche mit combase.dll einschränken.


    Gruß, Stefan
    Microsoft MVP - Visual Developer ASP/ASP.NET
    http://www.asp-solutions.de/ - Consulting, Development
    http://www.aspnetzone.de/ - ASP.NET Zone, die ASP.NET Community

    Dienstag, 14. Juni 2016 21:51
    Moderator
  • Hallo Stefan

    Ich habe mir die paar besten/nächsten Problemstellungen/Lösungen im Internet nochmals angeschaut, komme aber damit nicht wirklich weiter. Ich denke die meistens geschilderten Problemfälle unterscheiden sich m.E. in zwei Merkmalen: Es handelt sich meist um Apps aus dem Shop und zweitens treten die Fehler fix auf (beim Starten, nach ein paar Sekunden usw.).

    Unsere App ist eine LOB App die in C# im Visual Studio entwickelt wurde. Sie kommuniziert über SOAP mit einem Webserver der dann auf der andern Seite auf eine SQL-DB zugreift. Die DB sowie der Webserver können auf derselben Maschine wie die App laufen, oder aber auf separaten Maschinen. Wir haben alle möglichen Varianten im Betrieb. App/Webserver/SQL-DB alles auf einem Notebook (Win 10 Pro) oder Surface (Win 10 Pro) oder einem Windows 2012 R2 Server (nicht in Domäne), oder Webserver und SQL auf einem Windows Server 2012 R2 (2x in einer Workgroup und 1x in einer Domäne), kurz - jede erdenkliche Kombination. Alle Maschinen sind auf dem neuesten Stand (Updates). Und der Fehler passiert in jeder Konstellation. Mal mehr, mal weniger. Weniger heisst: jeden Monat vielleicht einmal, mehr heisst: so alle paar Klicks ist die App weg (unbrauchbar!).

    Und noch etwas Wesentliches: Das Problem tritt unabhängig davon auf, ob jemand an der App arbeitet oder nicht!!

    Ich habe auch mit procmon etwas herum hantiert, aber der frisst halt in kurzer Zeit alle Ressourcen auf und killt sich selber bevor ich etwas Brauchbares finden konnte

    Hier noch ein Screenshot der Insidern vielleicht etwas sagt:

    Sorry, dass ich damit nochmals komme, aber vielleicht läuten ja jetzt irgendwo die Ahaaa, daaas - Glocken :)

    Besten Dank und Gruss

    Willi



    Mittwoch, 15. Juni 2016 13:39
  • Hallo Willi,

    wenn das hier:

    The important point to understand here is that all async exceptions raised in Windows 8.1 Windows Store apps now result in a 0xC000027B error code in the Exception Record, not the error code passed by the caller.

    Quelle: https://blogs.msdn.microsoft.com/ntdebugging/2014/01/13/debugging-a-windows-8-1-store-app-crash-dump/

    stimmt, wird das richtig eklig.

    Du findest in obigem Link auch eine Anleitung zum Debuggen bzw. zum Auswerten des Crashdumps. Und leider sehe ich da keinen anderen Weg, wie Du dem eigentlichen Problem auf die Schliche kommen könntest.


    Gruß, Stefan
    Microsoft MVP - Visual Developer ASP/ASP.NET
    http://www.asp-solutions.de/ - Consulting, Development
    http://www.aspnetzone.de/ - ASP.NET Zone, die ASP.NET Community

    Mittwoch, 15. Juni 2016 13:57
    Moderator
  • Hallo Stefan

    Besten Dank für den Tipp!

    Nun denn, ziehe ich mich mal ins Hinterstübchen zurück um in aller Ruhe auf den Fehler zu warten...

    Gruss Willi

    Mittwoch, 15. Juni 2016 14:12