'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine error RRS feed

  • Frage

  • Hi<o:p></o:p>

    Host Win 2008 R2 Server (64 bit).<o:p></o:p>

    My app configuration is set to 'Any CPU' in VS2010. I have installed Microsoft Access Database 2010 64 bit. I am using Microsoft.ACE.OLEDB.12.0 as provider. When I run the app I get a The 'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine error. <o:p></o:p>

    What am I doing wrong and how can I access the MS Access db on 64bit Windows 2008 Server?<o:p></o:p>



    Sonntag, 17. Juni 2012 01:29


Alle Antworten

  • Hi<o:p></o:p>

    installed Microsoft Access Database 2010 64 bit. I am using Microsoft.ACE.OLEDB.12.0 a

    ACE.oledb.12.0 dosen't work in the 64-bit os

    download patch from



    • Als Antwort vorgeschlagen s3xs1 Freitag, 4. Oktober 2013 16:03
    Sonntag, 17. Juni 2012 11:25
  • Hi

    I have already installed the 64-bit version (AccessDatabaseEngine_x64.exe) of the Microsoft Access Database Engine 2010 from the link you posted. What am I missing? Do I need to install the 32-bit version (AccessDatabaseEngine.exe)? What provider do I need to use?



    • Als Antwort vorgeschlagen Stuart Clowes Montag, 29. Juni 2020 12:22
    Sonntag, 17. Juni 2012 12:04
  • Hi Yahya,

    Welcome to MSDN Forum.

    Here's a discussion about this error, please refer to it and let me know whether it is worked for you.

    HOW TO: FIX ERROR - "the 'microsoft.ace.oledb.12.0' provider is not registered on the local machine"

    Best Regards

    Allen Li [MSFT]
    MSDN Community Support | Feedback to us

    • Als Antwort vorgeschlagen Janos BerkeMVP Montag, 18. Juni 2012 07:52
    • Als Antwort markiert Allen_MSDN Montag, 25. Juni 2012 03:18
    Montag, 18. Juni 2012 07:36
  • The setup you described appears to be correct. I would verify the install by checking the below path to insure that the data provider exists:

    "C:\Program Files\Common Files\Microsoft Shared\OFFICE14\ACEOLEDB.DLL"

    Paul ~~~~ Microsoft MVP (Visual Basic)

    Montag, 18. Juni 2012 13:40
  • Hi Yahya,

    Any update about this issue? If you need further help, please feel free to let me know.

    Best Regards

    Allen Li [MSFT]
    MSDN Community Support | Feedback to us

    Donnerstag, 21. Juni 2012 02:26
  • Hi

    Check your MS Application if installed as x64 or 32 bit environment. On Web App Server (IIS Manager) try to change your application pool on advance settings >> Enable 32 bit Application - set True/false then restart the application. On windows app try to publish in x86/64 bit.

    Hope it helps

    Best regards

    To better the Man

    • Bearbeitet Frequent J Freitag, 21. September 2012 06:10
    Freitag, 21. September 2012 06:10
  • This worked fine for me.

    DBA in Pinellas County Schools

    • Als Antwort vorgeschlagen JohnK.NET Samstag, 2. Februar 2013 03:10
    Donnerstag, 11. Oktober 2012 13:50
  • Good link!  Perfect fix.  Thanks, Allen.
    Dienstag, 13. November 2012 02:30
  • worked here as well..BUT, had to install both x64 and x86
    Freitag, 21. Dezember 2012 17:15
  • The second link worked for me 100%

    Win 7 x64 and Office 2010 x64.

    Mittwoch, 27. Februar 2013 03:03
  • Thanks issue resolved after downolading
    Freitag, 8. März 2013 07:48
  • I am still have issues trying to get rid of this error.  The 32 bit does not recognize the .accdb file type.  All my databases are local on my laptop and I am trying to create a connection from my Access database to VBA 2010 express.  Did I miss something in this thread?  I am using Windows 7 home, 64x, VBA express 2010
    Samstag, 16. März 2013 18:28
  • Worked for me Windows Server 2008 R2, SQL Server 2012 (error using import export wizard and Excel files)
    Donnerstag, 4. April 2013 12:51
  • Sweet, perfect!  This has been driving me bat-crazy, but your solution worked on SQL 2008 R2 64-bit w/ Office 2013 64-bit installed on the same machine.

    Thanks so much!


    • Bearbeitet Bryce White Mittwoch, 1. Mai 2013 14:48 edit
    Mittwoch, 1. Mai 2013 14:47
  • Dude u Rock, thanks
    Mittwoch, 5. Juni 2013 17:42
  • This issue is caused by a missing 64-bit installation of the required driver.
    To fix this issue, perform the following steps...

    1.) Install ONLY the 64-bit driver from the following location

    2.) Go to the website's application pool in IIS, choose advanced settings, and set Enable 32-bit applications to FALSE

    3.) Restart the website


    • Als Antwort vorgeschlagen oggynr1 Montag, 30. Juni 2014 12:04
    Mittwoch, 12. Juni 2013 11:01
  • I am using:

    • Win 7 x64
    • Office 2010(32 bit).
    • MSFT Access Database 2010(32 bit)
    • MSFT Office Access Database engine 2007.

    My project is ANY CPU but still getting this error. Here is my connection string

    "Provider=Microsoft.ACE.OLEDB.12.0;Data Source=" + fileLocation + ";
    Extended Properties=\"Excel 12.0;HDR=Yes;IMEX=1\";"

    And also set the app pool to false for 32 bit. but it is still giving some problem.

    ANy clue?

    Montag, 17. Juni 2013 21:34
  • If you are working with 32-bit Office then you need to set the Platform option to x86 for Windows apps. If it's a web app then the Enable 32-Bit Applications option should be set to True for the app's application pool.

    Paul ~~~~ Microsoft MVP (Visual Basic)

    • Als Antwort vorgeschlagen Mina Nagy Dienstag, 29. Oktober 2013 13:07
    Montag, 17. Juni 2013 22:07
  • I am trying to access an Excel (Office-2010 32 Bit) on a WIN-7 machine (64 Bit) using Powershell and receiving this error 'The 'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine.'.

    Any help to fix this..

    Mittwoch, 14. August 2013 14:30
  • Any solution for the Excel (32-bit) on a Win-7 (64-bit) machine using powershell? Having the exact same problem
    • Als Antwort vorgeschlagen SB54 Sonntag, 4. Oktober 2015 19:10
    • Nicht als Antwort vorgeschlagen SB54 Sonntag, 4. Oktober 2015 19:10
    Freitag, 16. August 2013 15:57
  • This error usually occurs when there is a mismatch between the bits allocation of the system on which the application  is built and that of the server system it is hosted into.

    If the base system is 32-bits and server is say, 64 bits....This error will erupt.

    To resolve,

    1.) Go to IIS on the server

    2.) Check for the application pool on which the website is hosted.

    3.) Right Click on that application pool and go to properties.

    4.) Set "Enable32-bitsApplication" to true.

    Donnerstag, 29. August 2013 09:21
  • If you are using a compiled application compile to 32 bit so it matches Office/Access Redistributable.

    Donnerstag, 5. September 2013 20:21
  • Had the same problem with connecting to MS Access 2013 database from SSDT on x64 and installing the x32 access database engine 2007 solved the problem!
    Donnerstag, 21. November 2013 14:49
  • I am getting this error, when i adding a reference in the project

    Mittwoch, 27. November 2013 15:30
  • Thanks. It works for me~
    Donnerstag, 12. Dezember 2013 02:31
  • This worked for me.

    I have recently upgraded to office 2013 (64bit) and was trying to import data from Excel to SQL Server 2008 R2. Using the import wizard generated the error you described above. Installing the fix Allen Li posted above worked flawlessly. It even fixed the excel preview issue in Outlook 2013 that I had for excel files.

    Thanks again,

    Ralph Schwehr

    Database Administrator

    State Center Community College District


    Freitag, 20. Dezember 2013 17:31
  • I tried running this on a Windows Server 2008 R2 and got the following error:

    Error 1935.  An error occurred during the installation of assembly component {98CB24AD-52FB-DB5F-A01F-C8B3B9A1E18E}.  HRESULT: 0x80070BC9.

    Freitag, 7. Februar 2014 18:51
  • That is the download address, not a patch.


    Dienstag, 11. Februar 2014 03:53
  • THank You man
    Samstag, 22. Februar 2014 09:34
  • Hi guys

    I have a similar one but a little more complicated.

    Two servers, one is a virtual directory of the first one. Both need to access OLEDB12. The driver is installed on the 1st machine, 64bit. How to make it available on the 2nd machine?

    Dienstag, 1. Juli 2014 12:04
  • Install it...


    Dienstag, 1. Juli 2014 13:34
  • Yes.. It works!!

    I have SQL Server 2012 64 bit, MS Office 64 bit and Win 7 64 Bit.  When I tried to import an Excel File created in 32 bit I got this error.


    Download and install this 32 bit Access Database Engine


    I tried to install first the 64bit Access engine did nor work, from 


    The solution is 32 bit engine from the:



    Mittwoch, 9. Juli 2014 16:46
  • I ve installed it but no such dll in this file path what should I do now?
    Freitag, 11. Juli 2014 11:31
  • Try to add new build configration in to your project: Like this
    Donnerstag, 24. Juli 2014 15:25
  • Allen Li wrote:

    Hi Yahya,

    Welcome to MSDN Forum.

    Here's a discussion about this error, please refer to it and let me know whether it is worked for you.

    HOW TO: FIX ERROR - "the 'microsoft.ace.oledb.12.0' provider is not registered on the local machine

    Hi Allen,

    I reviewed that link but it states that it works only for 64 bit Office installations.

    I am running 32-bit Office (on 64 bit Windows 7), and I am attempting to connect to Access 2010 through VBScript (vs a web-app).  Do you know of a solution that will work for me?  Thanks!

    [EDIT]:  I found an alternate method which is working for me, which is to run my VBScript via 32-bit cscript.exe  ref: stackoverflow.com/questions/2806584/how-do-i-run-a-vbscript-in-32-bit-mode-on-a-64-bit-machine

    However, I would still be interested in knowing if there is a solution that is more closely related to the 64-bit Office method that Allen provided.  Thanks again!

    • Bearbeitet SkiReturn14 Freitag, 15. August 2014 19:42
    Freitag, 15. August 2014 18:13
  • Or you could do like we did and uninstall 32 bit and install 64 bit Office. Less problems overall esp. when build .NET CPU=ANY apps which doesn't really work well with the ACE provider.


    Freitag, 15. August 2014 20:49
  • it helps me a lot....
    Montag, 18. August 2014 08:04
  • Have tried all the above but still get

    The ‘Microsoft.ACE.OLEDB.12.0’ provider is not registered on the local machine

    running windows 8.1 with sp1 x64

    can someone please advise how you register it.

    Montag, 8. September 2014 03:02
  • Even when using the Server Explorer in Visual Studio to connect to an Access Database you get the message

    The ‘Microsoft.ACE.OLEDB.12.0’ provider is not registered on the local machine

    Montag, 8. September 2014 03:09
  • Visual Studio (Server Explorer) runs 32-bit so you would need to have the 32-bit version of the ACE OLEDB Provider installed.

    Paul ~~~~ Microsoft MVP (Visual Basic)

    Montag, 8. September 2014 03:34
  • Changing the Application Pool worked for me.  Thanks!
    Montag, 24. November 2014 22:41
  • It actually helped. Thanks :)
    Samstag, 13. Dezember 2014 15:42
  • Same problem here

    Basically Office 64 bit will not install with any 32 bit version of Office on it.

    The database engine for 32 bit get's removed even if it is needed by other applications that seem to only use the 32 bit call. So you have re-install the 32 database engine after Office 64 bit is installed.

    Even 64 bit version of SQL server 2012 seems to only recognize the 32 bit database engine, why I do not know.

    Microsoft needs to correct this rather glaring issue with SQL Server

    Dienstag, 13. Januar 2015 16:59
  • works for me after installing "2007 Office System Driver: Data Connectivity Components". Thanks!!!
    Donnerstag, 12. Februar 2015 19:29
  • Hi,

    I have similar issue when we are reading Excel file.

    History of the problem:

    We recently migrated our application from 32-bit to 64-bit because of the memory requirement. For that we migrated our windows 7 from 32-bit to 64-bit. But still we installed 32-bit office on our machines.

    because, of this we had this issue while importing Excel data into application.


    I downloaded 64-bit version of the http://www.microsoft.com/en-us/download/details.aspx?id=13255 and installed with argument as,

    AccessDatabaseEngine_x64.exe /passive

    Without any code change my issue get resolved.


    On 64-bit OS and 64-bit office, my functionality was working fine without this fix. This fix is only required while our application is 64-bit running on 64-bit OS which is having 32-bit office installed on it.

    Thanks, Rahul Techie.

    Freitag, 13. Februar 2015 08:57
  • I would be somewhat cautious here when installing both the 32-bit and 64-bit Access Database Engine when 32-bit Office is installed. I installed the 64-bit version and immediately some features in 32-bit Microsoft Outlook (such as adding a new folder) stopped functioning. After uninstalling the 64-bit version it worked fine again.

    Paul ~~~~ Microsoft MVP (Visual Basic)

    Freitag, 13. Februar 2015 14:52
  • Hi Paul,

    When I communicated with Microsoft for this, even they are not in favor of such type of solution.

    But, after applying this solution, I didn't face any kind of such issue.

    Still, I am replacing my office from 32-bit to 64-bit.

    Thanks, Rahul Techie.

    Montag, 16. Februar 2015 06:58
  • wow, this finally worked for me,

    i have 64 bit OS, but 32 bit office product...

    AccessDatabaseEngine_x64.exe /passive

    Thanks mate

    Donnerstag, 14. Mai 2015 15:12
  • Now, you also need to make sure that you are compiling to 64 bits. you can check that in the project properties, under debugging.
    Samstag, 6. Juni 2015 03:32
  • thanks.. it worked

    Ravikiran. S

    Donnerstag, 27. August 2015 15:35
    Freitag, 18. September 2015 14:55
  • If you use the 32 bit version of Powershell, it works out of the box.
    On my Windows 8.1 box, I found the 32 bit version here:


    Sonntag, 4. Oktober 2015 19:13
  • The download recommended on the thread you refer to worked for me.

    The original Access 2010 Redistributable worked fine on my laptop: Windows-10 32-Bit, Office 2016, VS 2010

    However, I needed the 2007 Office System Driver: Data Connectivity Components for my Desktop running Windows-10 64-Bit, Office 2016, VS 2010. Why?? Don't ask me!

    Thanks very much.

    Sonntag, 6. Dezember 2015 13:04

  • I have created a Console Application, its running fine on my system but throws error on other systems with Ace.Oledb.12.0 is not registered. 

    I have installed the patches from above link with no success. Am I missing anything?

    I also ran the below script in Powershell to check if oledb.12 is there in system or not, and it shows no entry for oledb.12 or oledb.10.

    (New-Object system.data.oledb.oledbenumerator).GetElements() | select SOURCES_NAME, SOURCES_DESCRIPTION 

    Please help!

    Mittwoch, 20. Januar 2016 08:15
  • Please ask a new question in the forum.

    Paul ~~~~ Microsoft MVP (Visual Basic)

    Mittwoch, 20. Januar 2016 14:28
  • Sure Paul. Thanks 

    Mittwoch, 20. Januar 2016 15:12
  • I had Microsoft Access Database Engine 2010 Redistributable already installed on my machine but was still receiving the Microsoft ACE OLEDB Provider error. 

    Then I recalled that I had upgraded to Office 2016 recently, so, may be I should try reinstalling Microsoft Access Database Engine 2010 Redistributable. And that fixed the problem on my machine. 

    So, if you have upgraded to different version of MS Office or even repaired/reinstalled your MS Office then try reinstalling Microsoft Access Database Engine 2010 Redistributable before wasting time with finding other fixes. Good luck!
    Montag, 18. April 2016 18:42
  • This worked for me. Thanks a lot.
    Donnerstag, 25. August 2016 16:36
  • Hi Allen,

    Is there any workaround which will not require me to uninstall my present version of MS Office and Install and a different version altogether.

    Montag, 17. Oktober 2016 10:23
  • I have had this error many times, as I run 64-bit Office and SSMS 2012, which does not seem to include a 64-bit Import/Export Wizard bundle by default (that's a whole other issue!).

    When you have 64-bit Office, you don't have the 32-bit ODBC drivers for Excel (fe.), which SSMS 32 (fe.) depends upon. Installing the 32-bit AccessDatabaseEngine.exe installs those ODBC drivers and resolves.

    If running 32-bit Office with a 64-bit app that relies on 64-bit ODBC Excel drivers (fe.), same issue occurs, and installing AccessDatabaseEngine_x64.exe resolves.

    I only posted this, because there is no clear explanation of this simple and straight forward issue anywhere on the internet! ... and if I forget, maybe Google can actually help now ;)

    • Bearbeitet _DHV_ Donnerstag, 1. Dezember 2016 17:34
    • Als Antwort vorgeschlagen _DHV_ Donnerstag, 1. Dezember 2016 17:38
    Donnerstag, 1. Dezember 2016 17:32
  • Good morning

    Thank you for these posts. I followed the links

    For me it's a conflict with 64bit OS's (Win7 is mine) and 32bit Office.

    I uninstalled 32bit office and installed 64bit office still same problem. I installed AccessDatabaseEngine_X64.exe from microsoft.com/en-us/download/details.aspx?id=13255

    And it works now

    Hope this helps.

    Sincerely, Wesley

    Dienstag, 18. April 2017 15:38
  • Thank you. this really help me.
    Dienstag, 18. April 2017 21:38
  • Thanks. This helped!
    Mittwoch, 5. Juli 2017 14:52
  • It works for me with

    Microsoft Access Database Engine 2007

    • Bearbeitet vbdear Dienstag, 22. August 2017 13:53
    Dienstag, 22. August 2017 13:50
  • Thank you!!!!!
    Mittwoch, 6. Dezember 2017 22:58
  • This link worked for me! The second link inside:


    Dienstag, 30. Januar 2018 22:10
  • This link worked for me! The second link inside:


    That link no longer works.

    VB .NET Developer

    Freitag, 13. September 2019 16:28
  • Microsoft Access Database 2010 64 bit Worked for me After I  have installed Microsoft Access Runtime 64- bit Application .


    Donnerstag, 19. September 2019 13:14
  • Hi Allen,

    I'm having the same issue. Microsoft.ACE.OLEDB.12.0 provider is not registered on the local machine.

    I'm using Windows 10 64-bit, Office 365 ProPlus 64-bit, Access Database Engine.

    As searched for the solution i found this link.

    HOW TO: FIX ERROR - "the 'microsoft.ace.oledb.12.0' provider is not registered on the local machine"

    When i went into this link, it was mentioned to go through the second link in that page, and the link is


    And in this, it is mentioned as This download is no longer available.

    I request you kindly provide the solution.



    Montag, 21. Oktober 2019 16:43
  • Thanks, works for me
    Dienstag, 3. März 2020 13:20
  • Try this out instead.  Microsoft Access Database 2010 64 bit cleared the error for me.  Follow the installation steps in the link below.


    Donnerstag, 4. Juni 2020 22:33
  • https://docs.google.com/document/d/15GTXgazw_OiRJE4L02Ur9fgYsM7QqNDkAxHfsM2A1VU/edit
    Mittwoch, 9. September 2020 18:14