none
Warnung: Bei mindestens einer abhängigen Assembly liegen Versionskonflikte vor RRS feed

  • Frage

  • Hallo zusammen,

    ich habe mir diese Warnung in meinem Projekt eingefangen:

    Könnt Ihr mir bitte sagen wonach ich suchen muss. Ich habe keine Ahnung.

    das letzte was ich getan habe, war das Importieren von namespaces

    System.Data.Linq

    System.XML.Linq

    System.Linq

    Gruss Ellen


    Ich benutze/ I'm using VB2008 & VB2010

    Dienstag, 3. April 2012 06:44

Antworten

  • Hallo Ellen,

    Die Ursache für die Meldung kann sein, dass Du in einem .NET 4.0 Projekt eine Assembly verwendest,
    die .NET 2.0 (... 3.5) als Voraussetzung hat.
    Umleitungen
    sind in solchen Fällen meist nicht sinnvoll (bzw. funktionieren nicht wirklich).
    Die von Dir aufgeführten Namespaces gehören sollten niemals eine Umleitung benötigen.

    Zunächst solltest Du Dir die eingebundenen Assemblies in den Projekteinstellungen genauer anschauen,
    siehe dazu Gewusst wie: Hinzufügen oder Entfernen von importierten Namespaces (Visual Basic) (und ff.)

    Gruß Elmar

    • Als Antwort vorgeschlagen Sebastian Dau Dienstag, 3. April 2012 15:23
    • Als Antwort markiert Ellen Ramcke Mittwoch, 4. April 2012 07:42
    Dienstag, 3. April 2012 07:12
    Beantworter

Alle Antworten

  • Hallo Ellen,

    Die Ursache für die Meldung kann sein, dass Du in einem .NET 4.0 Projekt eine Assembly verwendest,
    die .NET 2.0 (... 3.5) als Voraussetzung hat.
    Umleitungen
    sind in solchen Fällen meist nicht sinnvoll (bzw. funktionieren nicht wirklich).
    Die von Dir aufgeführten Namespaces gehören sollten niemals eine Umleitung benötigen.

    Zunächst solltest Du Dir die eingebundenen Assemblies in den Projekteinstellungen genauer anschauen,
    siehe dazu Gewusst wie: Hinzufügen oder Entfernen von importierten Namespaces (Visual Basic) (und ff.)

    Gruß Elmar

    • Als Antwort vorgeschlagen Sebastian Dau Dienstag, 3. April 2012 15:23
    • Als Antwort markiert Ellen Ramcke Mittwoch, 4. April 2012 07:42
    Dienstag, 3. April 2012 07:12
    Beantworter
  • Hallo Elmar,

    Problem gelöst.

    Schuld war eine Oracle NET Komponente. Und zwar hatte ich in einer Solution von 2 Projekten jeweils einen Verweis darauf eingerichtet. Nun hat aber auch das Projekt1 einen Verweis auf Projekt2 (Klassenbibliothek) . Komisch, bei NET Framework Klassen spielt das keine Rolle.

    UND Die Fehlermeldung von Visual Studio könnte schon etwas detailierter sein. So sucht man ja die berühmte Stecknadel.

    Vielen Dank und Gruss Ellen


    Ich benutze/ I'm using VB2008 & VB2010

    Mittwoch, 4. April 2012 07:41