Ordinal 968 was not found with MSVC RRS feed

  • Frage

  • Hi

    I wanted to try out this linear algebra library. It's a header only library similar to Eigen3. So I started with a simple "Hello World" program (with CMake). I added a vector of that library, printed them (cout) and added addition, nothing complex. Then I added a simple assignment ( b=a ) for a second instance of that type.

    However this caused the error. While there was no compilation error, when the app was executed I got a dialog saying

    The Ordinal 968 was not found in DLL "PATH/blaze-test.exe"

    In Visual Studio 2019 the output was

    Exception at 0x00007FFA7128EB78 (ntdll.dll) in blaze-test.exe: 0xC0000138: Ordinal Not Found.

    This was all with compiled with MSVC. To see if I get some helpful warning I tried compiling it with Clang. But the error was gone.

    I tried to find out more about this error using google. Everything I found suggested that there might be a conflict between different dll versions or something similar. The only dll mentioned was ntdll.dll, so I checked. But as far as I can tell the version in system32 is the only one actually used.

    I don't really know what to do about this error now. For now I can compile with Clang, although it can't find OpenMP.

    I hope I can get some helpful pointers gere.



    ps: Bin wohl irgendwo falsch abgebogen. Wollte das eigentlich im englisch sprachigen Forum posten.
    Freitag, 26. Juli 2019 07:57


  • I found the problem. It seems as if MKL came with a lib for OpenMP. As a consequence there were two OpenMP libraries due to the find_package(OpenMP) in CMake. It worked with Clang because Clang didn’t find OpenMP.

    However I don’t understand why this happend when I used an assignment.I would expect it to happen either always or when I use an operation which uses OpenMP.

    • Als Antwort markiert Thorsten9090 Freitag, 26. Juli 2019 09:35
    Freitag, 26. Juli 2019 09:34