none
Filtern mit Acc 2010

    Frage

  • Hallo,

    per Button setzte ich den Filter zurück:

        Me.Filter = ""
        Me.FilterOn = False

    schließe ich das Formular und sehe in den Eigenschaften nach, steht die alte Filterbedingung immer noch drin die beim Start ausgeführt wird. Wie setze ich den Filter richtig zurück?

     

    Andreas


    http://www.AccessBlog.de
    Dienstag, 25. Oktober 2011 13:16

Antworten

  • Ist es nicht so das wenn mann beim Formular öffnen

        Me.Filter = ""
        Me.FilterOn = False

     

    rein setzt, das es dan "GUT" geht.

    Also nicht unter dem Knopf gehe zu einem Formular, sondern unter Eigenschaften vom Formular und dan auf Formular Öffnen

     

    gr.

     

     

    Donnerstag, 3. November 2011 14:31
  • Hallo,

    Iemhoff wrote:

    Ist es nicht so das wenn mann beim Formular öffnen

        Me.Filter = ""
        Me.FilterOn = False

    rein setzt, das es dan "GUT" geht.

    Also nicht unter dem Knopf gehe zu einem Formular, sondern unter
    Eigenschaften vom Formular und dan auf Formular Öffnen

    Nein, das gilt zur Laufzeit bis das Formular geschlossen wird, genau wie
    Andreas' Ansatz. Wenn er es dauerhaft weghaben will, muss er das Feld im
    Formularentwurf in den Eigenschaften, Tab Daten, Eigenschaft Filter
    loeschen.

    Gruss - Peter


    Mitglied im http://www.dbdev.org
    FAQ: http://www.donkarl.com

    Donnerstag, 3. November 2011 16:08
    Moderator

Alle Antworten

  • Hallo Andreas,

    Andreas Vogt wrote:

    per Button setzte ich den Filter zurück:

        Me.Filter = ""
        Me.FilterOn = False

    schließe ich das Formular und sehe in den Eigenschaften nach, steht die
    alte Filterbedingung immer noch drin die beim Start ausgeführt wird. Wie
    setze ich den Filter richtig zurück?

    Nach dem Neustart findest du die Filterbedingungen, die du irgendwann mal
    mit dem Formularentwurf gespeichert hast. Sie spielen zur Laufzeit i.d.R.
    keine Rolle. Wenn du sie loswerden willst, loesche sie im Entwurf und
    speichere das Formular, dann sollte der Spuk vorbei sein.

    Gruss - Peter


    Mitglied im http://www.dbdev.org
    FAQ: http://www.donkarl.com

    Mittwoch, 2. November 2011 19:46
    Moderator
  • Ist es nicht so das wenn mann beim Formular öffnen

        Me.Filter = ""
        Me.FilterOn = False

     

    rein setzt, das es dan "GUT" geht.

    Also nicht unter dem Knopf gehe zu einem Formular, sondern unter Eigenschaften vom Formular und dan auf Formular Öffnen

     

    gr.

     

     

    Donnerstag, 3. November 2011 14:31
  • Hallo,

    Iemhoff wrote:

    Ist es nicht so das wenn mann beim Formular öffnen

        Me.Filter = ""
        Me.FilterOn = False

    rein setzt, das es dan "GUT" geht.

    Also nicht unter dem Knopf gehe zu einem Formular, sondern unter
    Eigenschaften vom Formular und dan auf Formular Öffnen

    Nein, das gilt zur Laufzeit bis das Formular geschlossen wird, genau wie
    Andreas' Ansatz. Wenn er es dauerhaft weghaben will, muss er das Feld im
    Formularentwurf in den Eigenschaften, Tab Daten, Eigenschaft Filter
    loeschen.

    Gruss - Peter


    Mitglied im http://www.dbdev.org
    FAQ: http://www.donkarl.com

    Donnerstag, 3. November 2011 16:08
    Moderator
  • Hallo,

    danke für eure Antworten.

    ich habe es jetzt so gelöst indem ich beim laden des Formulars definitive Filterbedingungen setze.

    Gruß Andreas


    http://www.AccessBlog.de
    Donnerstag, 3. November 2011 17:51