none
Unglaubliches Phänomen - Anwendung wird nur durch Fernwartung mit TeamViewer schnell RRS feed

  • Allgemeine Diskussion

  • Hallo zusammen,

    wir sind am verzweifeln. Bei unserer WPF Anwendung tritt bei einigen Benutzern das Problem auf, dass die Anwendung teilweise bis zu 10 Sekunden wartet, bevor ein neuer Vorgang gestartet wird. D.h. das Problem tritt sporadisch auf, in der Regel aber wenn die Anwendung länger als 10 Minuten pausiert.

    Der Hammer ist jetzt aber, dass sobald wir per Fernwartung bei den Kunden drauf sind, die Anwendung perfekt funktioniert.

    Habt Ihr ne Idee?

    Bisher haben wir folgendes versucht.

    - Renderqualität von Bildern auf Low gesetzt

    - Die Anzeigeneinstellungen bei Windows auf "schnellere Leistung" gesetzt

    - Alle Ressourcen in der Anwendung von dynamisch auf statisch umgestellt.

    - Objekte werden beim Start geladen und im Speicher gehalten.

    - Da wir auf einer Maske viele ctrl haben, die nicht immer sichtbar sind - Visibility von hidden auf collapsed umgebaut

    Danke für Eure Ideen

    Ciao Waldi

    Dienstag, 21. November 2017 10:23

Alle Antworten

  • Bei unserer WPF Anwendung tritt bei einigen Benutzern das Problem auf, dass die Anwendung teilweise bis zu 10 Sekunden wartet, bevor ein neuer Vorgang gestartet wird. D.h. das Problem tritt sporadisch auf, in der Regel aber wenn die Anwendung länger als 10 Minuten pausiert.

    Was ist bei den Benutzern wo es auftritt anders, als bei den Benutzern wo es nicht auftritt?

    Top Kandidaten: Virenscanner, Firewall

    Mit ein wenig Info über die Art der Anwendung bekommst du vermutlich mehr Ideen.


    - Gruß Florian

    Dienstag, 21. November 2017 11:18