none
Frage zu geteilten Formularen

    Frage

  • Hallo,

    ich habe ein geteiltes Formular erstellt. Die Daten kommen aus einer Abfrage, bei der ein Feld zu einer anderen Abfrage mit einer 1:n-Beziehung verknüpft ist und diese andere Abfrage ist in Form eines Unterformulars in meinem Formular enthalten.

    Das klappt soweit auch alles wie gewünscht. Jetzt möchte ich aber in der Ansicht, die dieses Formular zur Verfügung stellt, in der Datenliste (bei mir auf der linken Seite) gerne nicht nur die Unterdatenblätter eingeklappt haben, sondern ich möchte sie in der Auflistung ganz weghaben, im Datailbereich sollen sie aber angezeigt werden.

    Erlaubt Access das irgendwie (ich befürchte eher: nein)?

    Falls jemand dazu eine Idee hat: im Voraus vielen Dank für jede Antwort.

    Beste Grüße, J. Dessecker

     

     

    Sonntag, 25. Januar 2015 11:00

Antworten

  • Bei den Tabellen gibt es die Eigenschaft "Unterdatenblattname" auch. Diese ist standardmässig auf [Automatisch] eingestellt. Wenn man dort auf [Keines] umstellt, werden die +-Zeichen nicht mehr angezeigt.  Also bei den Tabellen auf [Keines] setzen, und bei der Abfrage im Detailbereich, wo Sie es ja haben wollen, die gewünschte Tabelle (oder Abfrage) angeben. Dann sollte es so klappen, wie Sie es wollen.

    Matthias kläy, Kläy Computing AG

    Montag, 2. Februar 2015 11:37

Alle Antworten

  • Die Abfrage des Hauptformulars in der Entwurfsansicht öffnen und in den Eigenschaften der Abfrage den Eintrag bei "Unterdatenblattname" löschen.

    Matthias Kläy, Kläy Computing AG

    Sonntag, 1. Februar 2015 10:09
  • Hallo Herr Kläy,

    zunächst vielen Dank für Ihre Antwort. Ich habe gerade nachgeschaut: die Eigenschaft 'Unterdatenblattname' in der betreffenden Abfrage ist bereits leer. Im Formular zeigt die Datenblattansicht zwar nicht die Unterformulare (das kann man ja im Formular abstellen), an, jedoch natürlich die diese Kreuze links von jedem Datensatz mit einer 1:n-Verknüpfung (an der 1-Seite). Und die wäre ich gerne los, falls möglich.

    Vielen Dank daher im Voraus für weitere Antworten.

    Beste Grüße, J. Dessecker 

    Montag, 2. Februar 2015 07:30
  • Bei den Tabellen gibt es die Eigenschaft "Unterdatenblattname" auch. Diese ist standardmässig auf [Automatisch] eingestellt. Wenn man dort auf [Keines] umstellt, werden die +-Zeichen nicht mehr angezeigt.  Also bei den Tabellen auf [Keines] setzen, und bei der Abfrage im Detailbereich, wo Sie es ja haben wollen, die gewünschte Tabelle (oder Abfrage) angeben. Dann sollte es so klappen, wie Sie es wollen.

    Matthias kläy, Kläy Computing AG

    Montag, 2. Februar 2015 11:37
  • Hallo Herr Kläy,

    haben Sie (mit reichlich Verspätung wegen Grippe...) vielen Dank für Ihre Antwort: es hat funktioniert, genau nach dieser Möglichkeit hatte ich gesucht.

    Beste Grüße, J. Dessecker

    Donnerstag, 12. Februar 2015 17:05