none
Fehler beim Outlook-Client bei on premise CRM 2011 mit IFD

    Frage

  • Guten Morgen allerseits!

    Ich durchsuche nun seit Stunden das Internet nach meinem Problem, finde aber immer nur Antworten, die nicht so ganz passen und vor allem nicht helfen. Ich möchte mal schildern:

    SQL-Server "SQLsrv.firma.local", Win 2008 R2, SQL-Server 2012
    CRM-Server "CRMsrv.firma.local", Win 2008 R2, CRM 2011, discovery: https://internalcrm.my-ext-firma.de
    IFD (ADFS-Server) "ADFSsrv.firma.local", Win 2008 R2, IFD 2.1
    Terminalserver "WTSsrv.firma.local", Win 2008 R2, Outlook 2010

    Das Upgrade von CRM 4 auf 2011 hat funktioniert, alles Tests sind toll, nur den Outlook-Client habe ich nicht getestet. Klar ist, dass Murphys law immer zuschlägt, oder?

    Der Zugriff im Browser über https://internalcrm.my-ext-firma.de/OrgaName funktioniert einwandfrei. Authentifizierung über IFD läuft, wer es mit dem lokalen Namen (crmsrv) versucht, wird umgeleitet, Zertifikat passt, Proxyausnahmen, alles bestens. Auch die Installation des Outlook-Client hat noch geklappt. Immerhin hat der alte mit CRM 4 auch funktiioniert und wurde rege genutzt. Und jetzt das:

    "Mit dem Microsoft Dynamics CRM-Server kann keine Verbindung hergestellt werden, da Ihre Anmeldeinformationen nicht authentifiziert werden können. Überprüfen Sie die Verbindung oder wenden Sie sich an ... mich?" Oha!

    Nun gut, die Meldung und die Fragen dazu gibt es wie Sand am Meer, viele Antworten auch, nur leider beziehen die sich alle entweder auf die Online-Version oder auf die Installation an sich oder auf inkompatible Serverversionen oder - bringen mich nicht weiter.

    Unsere Installation ist on premise, also im lokalen Netzwerk, eben mit einem ADFS-Server, also IFD-Authentifizierung und https ohne irgendwelche Portverbiegungen. Alle Installationen haben stur nach MS-Whitepapern stattgefunden. In Sachen MS-Updates sind wir per WSUS auf einem weitgehend aktuellen Stand, CRM hat das RU 14 und es gibt keine Besonderheiten wie trusted Domains oder dergleichen. Alles ganz simpel eigentlich. Und trotzdem will der Outlook-Client nicht. Ich habe inzwischen die Registry-Schlüssel im HKCU entsorgt, um mal keine Vorversionsinfo zu haben (bis vor ein paar Stunden lief noch CRM 4 bei uns) und diverse Einstellungen hauptsächlich am ADFS-Server vorgenommen, die laut verschiedenen Foren schon mal Schuld sein können.

    Kann mir jemand sagen, was genau der Outlook-Client da versucht und warum er möglicherweise nicht zugreifen kann? Normalerweise gebe ich als Server https://internalcrm... ein, habe es aber auch schon mit dem internen Namen versucht, leider ohne Erfolg. Was genau passiert da, wo kann ich noch hinschauen? Die ganzen Whitepaper und grundlegenden Installations-Dokus kenne ich weitgehend. Was mir fehlt, ist: was genau macht der da? Besondere Ports? Irgendwas am ADFS-Server, was falsch sein könnte? Sowas wie die Sache mit den Browsern außer IE? Wenn die Konfiguration einen grundlegenden Knick hätte, würde der Browserzugriff schon nicht funktionieren können. Der läuft aber problemlos.

    Weiß da jemand mehr?

    Dienstag, 3. Juni 2014 01:13

Alle Antworten

  • Hallo Jörg!

    Die Version des Outlook-Clients muss zu der CRM-Version passen.

    Hast du nach dem Upgrade von CRM4 auf CRM 2011 den bestehenden CRM4-Outlook-Client deinstalliert
    und den CRM-2011-Outlook-Client installiert?


    Ich hoffe das bringt weiter. Andreas(a)Donaubauer.com www.crmfaq.de

    Dienstag, 3. Juni 2014 10:10
  • poste mal das client trace während du die config laufen lässt

    gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Dienstag, 3. Juni 2014 13:55