none
VS2015 Enterprise Xamarin kann keine APK's erstellen RRS feed

  • Frage

  • Ich versuche ein Android Projekt zu starten bekomme aber nur folgende Fehlermeldungen:


    Bisher habe ich nur die MainActivity.cs klasse wie folgt bearbeitet:

    using System;
    using Android.App;
    using Android.Content;
    using Android.Runtime;
    using Android.Views;
    using Android.Widget;
    using Android.OS;
    using Android.Bluetooth;
    
    namespace Dragonate
    {
        [Activity(Label = "Dragonate", MainLauncher = true, Icon = "@drawable/icon")]
        public class MainActivity : Activity
        {
            int count = 1;
            string deviceName;
    
            BluetoothAdapter bta;
    
            protected override void OnCreate(Bundle bundle)
            {
                base.OnCreate(bundle);
    
                // Set our view from the "main" layout resource
                SetContentView(Resource.Layout.Main);
    
                bta = BluetoothAdapter.DefaultAdapter;
                if(bta != null)
                {
                    deviceName = bta.Name;
                    bta.SetName("Dragonate_User1");
                }
            }
    
            protected override void OnDestroy()
            {
                base.OnDestroy();
                if (bta != null)
                {
                    bta.SetName(deviceName);
                }
            }
    
            protected override void OnPause()
            {
                base.OnPause();
                if (bta != null)
                {
                    bta.SetName(deviceName);
                }
            }
    
            protected override void OnResume()
            {
                base.OnResume();
                if (bta != null)
                {
                    deviceName = bta.Name;
                    bta.SetName("Dragonate_User1");
                }
            }
        }
    }

    und nichts zusätzlich installiert (Verweise hizugefügt und sowas) und auch keine anderen Dateien & Klassen hinzugefügt. Weswegen es auch nicht an einem "-" liegen kann^^

    Zudem habe ich versucht alle Komponenten zu installieren bzw zu reparieren, weswegen es nicht an fehlenden VS-Studio Komponenten liegen kann.

    Visual Studio: VS2015 - Enterprise

    Betriebssystem: Windows 10

    Sollten weitere Informationen benötigt werden fragt einfach.

    Ich bitte um schnelle hilfe. Danke im vorraus.



    Dienstag, 17. Mai 2016 14:36