none
In Access 2003 wird ein Filter gesetzt wenn Frontpage gestartet wird.

    Allgemeine Diskussion

  • Salü alle zusammen

    Bitte nicht Lachen|schimpfen|kritisieren|xy. Aber ich bekomme es nicht hin und brauche ein bischen Erleuchtung von jemandem dessen Kristallkugel gerade nicht in Reparatur ist.

    Ich habe eine umfangreiche Access 2003 Datenbank vor mir. Geöffnet ist ein Formular mit mehreren Unterformularen. Ich positioniere meinen Cursor in mehreren Formularen auf dem 3. Datensatz.

    Jetzt starte ich über Start Programme das Programm Frontpage. Schwup werden in meinem Access Filter aktiviert und ich stehe überall auf dem 1. Datensatz.

    Starte ich hingegen Word oder den Internet Explorer, bleiben alle Fokusse auf dem 3. Datensatz, es wird nichts bewegt.

    Ich habe ein anderes Formular in der gleichen Datenbank, dort passiert dieses Verhalten ebenfalls. In einem Dritten Formular ohne Unterformulare passiert nichts.

    Habe versucht eine neue Datenbank zu erstellen, nur mit einem Haupt und einem Unterformular. Hier passiert auch nichts.

    Liebe Leser dieses Trades, was könnte ich gemacht haben, dass beim Start von Frontpage der Fokus verschoben wird und der Filter angewendet wird?

    Oder anders gefragt, wenn ich sowas machen wollte, dass nur beim Start von Frontpage, nicht beim Start von Word oder dem Explorer, ein Filter angewendet wird?

    Vielen lieben Dank für Eure Hinweise
    Gruss Sabrina

     

    Montag, 2. August 2010 13:47

Alle Antworten

  • Hallo, Sabrina,
     
    Sabrina Sanders:
     
    > Ich habe eine umfangreiche Access 2003 Datenbank vor mir. Geöffnet ist ein Formular mit mehreren Unterformularen. Ich positioniere meinen Cursor in
    > mehreren Formularen auf dem 3. Datensatz.
    >
    > Jetzt starte ich über Start Programme das Programm Frontpage. Schwup werden in meinem Access Filter aktiviert und ich stehe überall auf dem 1.
    > Datensatz.
    >
    > Starte ich hingegen Word oder den Internet Explorer, bleiben alle Fokusse auf dem 3. Datensatz, es wird nichts bewegt.
     
    das ist schon erstaunlich und ich habe so etwas noch nicht beobachtet.
    Hast Du vielleicht irgendwo Code in Deinen Formularen, der auf das
    Ereignis Fokusverlust reagiert?
     
    Gruss - Mark
     
    Dienstag, 3. August 2010 09:31
  • Lieber Mark, vielen Dank, dass Du nicht einfach lachst und mir hilfst bei diesem speziellen Problem. Wenn mir das jemand dieses Problem schildern würde, ich wüsste auch nicht ob ich lachen oder weinen sollte.

    Ich habe auch daran gedacht, dass es etwas wie FokusVerlust oder ein ähnliches Ereignis sein müsste. Bitte korrigiere mich, wenn ich jetzt falsch denke. Ein FokusVerlust müsste doch auch dann eintreten, wenn ich Word starte oder wenn ich den Windows Explorer starte. Das ist es aber nicht. Bei Word und Windows Explorer bleibt mein Formular exakt so, wie es war. Nur bei Frontpage reagiert mein Access.

    Und müsste der Fokus Verkust nicht schon beim Klick auf den Start Knopf ausgelöst werden?

    Mein Access Formular hat einige Makros drauf, die aber mehr bei Klick reagieren. Und es ist in der Tat so, dass ich mit Filtern in dem Formular arbeite. Wie aber kann Frontpage diese Filter auslösen ohne dass diese auch von Word ausgelöst werden?

    Was macht Frontpage im Startvorgang anders als Word oder der Windows Explorer?

    Habe soeben noch folgende Beobachtung gemacht:
    Wenn mein Access Formular mit den 5 Unterformularen geöffnet ist, und ich Frontpage starte (Start Programme..), dann wird der Fokus in den Formularen bewegt. Gehe ich nun zu Access zurück, wähle wieder in jedem Unterformular den 3. Datensatz an, und starte ein zweites Frontpage, so passiert meinem Formular nichts. Schliesse ich beide geöffneten Frontpages und öffne ein neues, so stehe ich wieder überall auf dem 1. Datensatz und habe Filter angewendet.

    Es scheint mir, als ob der erste Start von Frontpage ein Ereignis in Access auslöst. Und dies auch, wenn Access gar nicht den Fokus hat, also wenn ich zuerst Word starte, in Word schreibe und dann erst Frontpage starte, werden meine Datensätze in Access bewegt.

    Nein, liebe Leser dieses Trades, ich habe nichts getrunken, habe keinen Sonnenstich und das Problem ist jederzeit nachvollziehbar.

    Vielen lieben Dank für jegliche Anregung welche in irgend einer Form irgend wie weiter hilft.
    fast am verzweifeln
    Gruss Sabrina

    Dienstag, 3. August 2010 13:34
  • Hallo, Sabrina,
     
    Sabrina Sanders:
     
    > Ich habe auch daran gedacht, dass es etwas wie FokusVerlust oder ein ähnliches Ereignis sein müsste. Bitte korrigiere mich, wenn ich jetzt falsch
    > denke. Ein FokusVerlust müsste doch auch dann eintreten, wenn ich Word starte oder wenn ich den Windows Explorer starte. Das ist es aber nicht. Bei
    > Word und Windows Explorer bleibt mein Formular exakt so, wie es war. Nur bei Frontpage reagiert mein Access.
     
    das klingt logisch. Leider habe ich kein Frontpage installiert, um das
    zu testen. Aber vielleicht ja ein hilfreicher Mitleser?
     
    Gruß - Mark
     
    Dienstag, 3. August 2010 16:17
  • Hallo Mark,

    Mark Doerbandt [MVP] wrote:

    Sabrina Sanders:
     

    Ich habe auch daran gedacht, dass es etwas wie FokusVerlust oder ein
    ähnliches Ereignis sein müsste. Bitte korrigiere mich, wenn ich jetzt
    falsch denke. Ein FokusVerlust müsste doch auch dann eintreten, wenn
    ich Word starte oder wenn ich den Windows Explorer starte. Das ist es
    aber nicht. Bei Word und Windows Explorer bleibt mein Formular exakt
    so, wie es war. Nur bei Frontpage reagiert mein Access.

     
    das klingt logisch. Leider habe ich kein Frontpage installiert, um das
    zu testen. Aber vielleicht ja ein hilfreicher Mitleser?

    Ich z.B. ;-) Aber das Problem nachvollziehen kann ich auch nicht.
    @Sabrina,

    Da Frontpage wie alle Office-Produkte auch VBA und somit Automation
    unterstuetzt, koennte noch eine Moeglichkeit sein, dass beim Start von
    Frontpage etwas ausgefuehrt wird, was das Verhalten erklaeren koennte.

    Schau mal in Frontpage, ob irgendwelche Add-Ins oder Makros existieren.

    Schau dir auch mal die Verknuepfung zu Frontpage im Startmenue an. Evtl.
    wird garnicht Frontpage direkt gestartet (kuriose Probleme fuehren zu
    ebenso kuriosen Loesungsansaetzen ;-).

    Gruss - Peter


    Mitglied im http://www.dbdev.org
    FAQ: http://www.donkarl.com

    Donnerstag, 5. August 2010 09:34
    Moderator
  • Salü Peter

    Vielen lieben Dank für Deine Gedanken.

    Im Start Programme habe ich bei Frontpage wirklich Frontpage in den Eigenschaften ohne irgendwelche Parameter.

    In Frontpage selbst habe ich keine AddIns geladen, die Liste verfübarer AddIns ist leer.

    Ich habe das identische Problemchen (masslose Untertreibung) auch wenn ich Frontpage mit dem Shell Befehl über einen Button starte. Auch hier nachvollziehbar, Frontpage bewegt, Word und der Windows Explorer starten ohne sich zu bewegen.

     

    Neu habe ich folgendes ausprobiert.

    1. Formular ist mein Formular mit den vielen Unterformularen

    2. Formular ist eines der Unterformulare

    Wenn ich Formular 1 öffne und den Cursor auf bestimmte Datensätze positioniere, nun in Formular 2 gehe dort einen Datensatz markiere und den Button Frontpage aufrufe, welcher mit dem Shell Befehl Frontpage startet, wird der Datensatzmarkierer im 1. Formular, das gar nicht aktiv ist, bewegt. Das 2. Formular bleibt ruhig....

    Ich wünsche Euch allen ein wunderbares Wochenende
    Gruss Sabrina

    Freitag, 6. August 2010 15:32