none
Windows 8 Pro - "connected standby" unerwünscht RRS feed

  • Frage

  • Hallo an das Forum,

    auf einem Tablet-PC (Dell Latitude 10) habe ich zur Erfassung von Arbeitszeiten ein Programm installiert, das rund um die Uhr laufen soll. Nach etwa 15 Stunden wird der "connected standby" aktiviert, so dass eine Fernwartung mit dem Teamviewer 8 einfach unterbunden wird.

    Bisher habe ich keine Hinweise auf Einstellungen gefunden, wie ich das verhindern, beziehungsweise das Gerät wieder reaktivieren kann, ohne zum Einsatzort zufahren, das Gehäuse aufzuschließen und das Knöpfchen zu drücken...

    Dieser Modus mag ja bei Akku-Betrieb seine Daseinsberechtigung haben, bei konstanter Stromversorgung ist es aber nicht zielführend, wenn erst nach 15(!) Stunden Betrieb der Tablet-PC quasi abgeschaltet wird. Der Akku wäre in der Regel bereits leer.

    Es ist wohl auch nicht zielführend, seine Meinung an einem Sonntag nach der Messe offen darüber zu äußern, warum ein Hersteller einen Mechanismus einführt, der, wenn die Software stabil läuft, das Betriebssystem bewusst abschaltet und nur noch für "vom Hersteller definierte, vermeintlich wichtigere" Zwecke (gelegentlich) arbeiten lässt.

    Fragen:

    Gibt es Einstellungen in der Registry, die den Betrieb unterbinden oder zumindest regeln?

    Gibt es einen Weg, eine WLAN-Verbindung vom Sparmodus zu verschonen und aufrecht zu erhalten?

    Lässt sich der USB-Anschluss aktiv halten, um das Lesegerät zu betreiben und vielleicht als "Wecker" zu fungieren?

    Welche .NET-Klasse könnte den Tablet-PC sinnvoll beschäftigen, um von seinem Nickerchen abzusehen? 

    Ich freue mich über jeden Tipp, wenn es nicht gerade ein stündlicher Neustart im Schichtbetrieb ist. Das gibt nämlich Ärger...

    Beste Grüße

    Gunnar

    Sonntag, 2. Juni 2013 11:33

Antworten

  • Hallo Gunnar,

    Ist diese Programm eine Windows 8 App? Du kannst versuchen in Device Manager->Network Adapters-> Properties->Power Management zu gehen un dort gib es so etwas "Allow the computer to turn off this device to save power".

    Gruss,

    Ionut

    • Als Antwort markiert GuSte Freitag, 7. Juni 2013 08:19
    Montag, 3. Juni 2013 16:04
    Moderator

Alle Antworten

  • Hallo Gunnar,

    Ist diese Programm eine Windows 8 App? Du kannst versuchen in Device Manager->Network Adapters-> Properties->Power Management zu gehen un dort gib es so etwas "Allow the computer to turn off this device to save power".

    Gruss,

    Ionut

    • Als Antwort markiert GuSte Freitag, 7. Juni 2013 08:19
    Montag, 3. Juni 2013 16:04
    Moderator
  • Hallo Ionut,

    der Vorschlag ist bestechend logisch. Ich habe an der beschriebenen Stelle natürlich die Erlaubnis zum Abschalten des WLANs gefunden und gleich deaktiviert. Morgen Nachmittag weiß ich mehr. Wenn die Fernwartung aufrecht erhalten bleibt, ist das schon die halbe Miete.

    Probeweise habe ich dieselbe Einstellung auch für den USB-Hub deaktiviert. Vielleicht bleibt der USB-Reader auch aktiv. Dann wäre das Problem gelöst.

    Die Anwendung ist keine Windows 8 App (noch nicht...). Ist aber nur eine Frage der Zeit.

    Herzlichen Dank die Hilfe.

    Einen schönen Abend noch

    Gunnar

    Montag, 3. Juni 2013 18:21
  • Hallo Ionut,

    nochmals ein herzliches Dankeschön für den Tipp. Seitdem läuft das System wie erhofft.

    Beste Grüße

    Gunnar

    Freitag, 7. Juni 2013 08:19
  • Hallo Ionut,

    leider habe ich das Problem vorschnell als gelöst betrachtet. Die vermeintliche Lösung hat den "connected standby" Modus lediglich verzögert. Wenn niemand seine Arbeitszeit für ca. 15 Stunden erfasst, fallen jetzt beide Geräte (Dell Latitude 10 Win 8 Pro) trotz eines Neustarts im 5-Stunden-Takt in diesen Modus und verbleiben dort. Vielleicht werden irgendwelche live tiles, E-Mail Konten oder was weiß ich aktualisiert, aber bei der Zeiterfassung ist es nicht hilfreich.

    Da die Software keine Win 8 App ist, lässt sich an dem "AUSFALL der Geräte/INSTABILITÄT des Betriebssystems" (O-Ton Kunde) nichts ändern. Auch der Teamviewer wird da ausgebootet, sonst könnte ich Sonntag abends die Geräte wieder aktivieren. Der Einsatz im Schichtbetrieb steht damit vor dem Aus, da niemand montagmorgens um 3 Uhr die verschlossenen Geräte wieder zum Leben erwecken kann, weil sie über das Wochenende nicht verwendet wurden und damit ausgefallen sind.

    So langsam dämmert es mir, warum viele Steuerungen in der Mess- und Regeltechnik immer noch in Delphi 5/6 entwickelt werden und unter XP eingesetzt werden. Dass ich an so einer banalen und eigentlich sinnvollen Neuentwicklung scheitere, hätte ich nicht erwartet. Da MS bekanntermaßen bei Problemen ein dickes Fell hat und mit Verbesserungen frühestens nach 2-3 Jahren reagiert, war es das wohl mit den Tablets in diesem Einsatzbereich. Wenn von Euch keiner eine zündende Idee hat, muss ich mal checken, ob die Geräte mit Windows 7 laufen.

    Nochmals besten Dank für die Hilfe

    Gunnar

    Sonntag, 21. Juli 2013 12:47
  • Hallo,

    haben Sie das Problem mittlerweile lösen können? Ich habe bei meinem Dell Venue ein ähnliches Problem. Zwar ist Connected Standby in der Registry deaktiviert und das Gerät hängt permanent am Netzteil (daher habe ich die Energiesparoptionen deaktiviert). Allerdings schaltet es trotzdem alle paar Tage in den Connected Standby (=Bildschirm aus) und dabei gehen alle angeschlossenen USB-Festplatten auch aus. 

    Als Server also denkbar ungeeignet. Und selbst als Eingangshallen-Präsentiertablet ungeeignet.

    Gibt es eine Option in der Registry oder im BIOS, die ich übersehen habe? 

    Habe sogar ein Makro geschrieben, was alle 15 Minuten eine Mausaktivität vorspielt, aber auch das hat nicht geholfen.

    Würde mich über eine Rückmeldung sehr freuen.

    MfG

    Dienstag, 30. Juni 2015 09:40
  • Hallo Dell_Tester,

    schlussendlich war die Lösung recht simpel. Es lassen sich wohl Programme mit erhöhter Priorität nicht zum "Schlafen" bewegen. Eine Programm namens "don't sleep" löst dieses Problem auf elegante Weise. Meine seinerzeit in Betrieb genommenen Zeiterfassungsterminals (Dell Latitude 10) laufen seit über 2 Jahren mit der Version 3.01 rund um die Uhr, davon 1 Jahr mit SIM-Karten...

    http://www.chip.de/downloads/Don-t-Sleep_42626965.html

    Viel Erfolg

    Gunnar Steentjes

    Dienstag, 30. Juni 2015 11:04