none
Problem beim Zuweisen von Aufgaben RRS feed

  • Frage

  • Hallo zusammen,

    folgendes Problem:
    Beim Zuweisen einer Aufgabe an einen anderen Benutzer bekommt ein Kollege von mir immer die Fehlermeldung: "Der angemeldete Benutzer besitzt keine entsprechenden Sicherheitsberechtigungen, um diese Datensätze anzuzeigen oder diese Aktion auszuführen."
    Zu diesem Sachverhalt findet man ja einige Sachen hier im Forum.
    Nachdem ich jetzt aber RU8 installiert habe, und auch das Tool, welches die "HiddenPrivileges"  zu den selbst erstellten Sicherheitsrollen hinzufügt, ausgeführt habe, weiß ich langsam nicht mehr, wo ich noch ansetzten könnte.
    Wie gesagt, es handelt sich hier um über die Oberfläche erstellte neue Sicherheitsrollen.

    Nach mehrmaligem Bestätigen der Fehlermeldung wird der Datensatz meist sogar zugewiesen. Aber das muss doch auch korrekt funktionieren.

    Wo könnte ich hier noch ansetzen?

    Viele Grüße,
    Stefan
    Montag, 25. Januar 2010 16:23

Antworten

  • Du solltest am besten eine neue Sicherheitsrolle auf Basis einer bestehenden erstellen, diese mit den gewünschten Berechtigungen versehen und die alte Sicherheitsrolle damit ersetzen.

    Viele Grüße,
    Jürgen


    Jürgen Beck

    Dipl. Kfm./Wirtschaftsinformatik
    MVP, MCSD.NET, MCITP DBA, MCDBA, MCSE
    Microsoft Certified Business Management Solutions Professional
    Microsoft Certified CRM Developer
    Microsoft Certified Trainer

    ComBeck IT Services & Business Solutions
    Microsoft Gold Certified Partner
    Microsoft Small Business Specialist

    Developing & Supporting Business Applications from small business to big enterprises covering scores of sectors

    http://www.combeck.de
    Mittwoch, 12. Mai 2010 14:31
    Moderator

Alle Antworten

  • Hallo Stefan,

    gib dem Benutzer einmal temporär eine der vorhandenen Systemrollen. Danach muss er sich einmal anmelden, anschließend kannst du ihm diese Rolle wieder entziehen, dann sollte es funktionieren.
    Viele Grüße

    Michael Sulz
    axcentro GmbH
    MVP für Microsoft Dynamics CRM
    Dienstag, 26. Januar 2010 07:02
  • Hallo Michael,

    danke für deine erneute Hilfe.
    Es funktioniert, solange eine Standardrolle dem Benutzer zugewiesen ist. Sobald ich die Rolle wieder entferne (so, dass er nur eine selbst erstellte Rolle hat) , geht wieder nichts.
    Ich meine, Workaround wäre, eine der Rollen zu "leeren" damit man eine Standardrolle hat, welche quasi keine Rechte gewährt. Aber ist das denn wirklich die einzige Möglichkeit?

    Gruß & Danke nochmals,
    Stefan
    Dienstag, 26. Januar 2010 12:59
  • Du solltest am besten eine neue Sicherheitsrolle auf Basis einer bestehenden erstellen, diese mit den gewünschten Berechtigungen versehen und die alte Sicherheitsrolle damit ersetzen.

    Viele Grüße,
    Jürgen


    Jürgen Beck

    Dipl. Kfm./Wirtschaftsinformatik
    MVP, MCSD.NET, MCITP DBA, MCDBA, MCSE
    Microsoft Certified Business Management Solutions Professional
    Microsoft Certified CRM Developer
    Microsoft Certified Trainer

    ComBeck IT Services & Business Solutions
    Microsoft Gold Certified Partner
    Microsoft Small Business Specialist

    Developing & Supporting Business Applications from small business to big enterprises covering scores of sectors

    http://www.combeck.de
    Mittwoch, 12. Mai 2010 14:31
    Moderator
  • Ok, das werde ich mal testen. Danke für den Tip!
    Mittwoch, 12. Mai 2010 14:42