none
WP8.1 Emulator installation fehler: "Nicht unterstützt" RRS feed

  • Frage

  • Schönen guten Tag,

    ich möchte Apps für Windows Phone 8.1 entwickeln.

    Nun hab ich mir extra Windows 8.1 installiert und Visual Studio Express 2013.

    Beim öffnen der Installation für den Emulator kommt der fehler das es nicht unterstützt wird.

    Mein Laptop ist von ASUS x55sv. Der Prozessor ist von Intel T7500.

    Nach meinem check hab ich die Bedingungen erfüllt:

    -4 GB or more of RAM.

    -64-bit version of Windows 8 Pro edition or higher.

    -Hardware-assisted virtualization.

    -Second Level Address Translation (SLAT).

    -Hardware-based Data Execution Prevention (DEP).

    Dazu muss ich leider sagen dass ich im BIOS keine Einstellungsmöglichkeiten dafür habe.

    Ich hoffe es gibt eine Lösung dafür.

    Mit freundlichen Grüßen


    • Bearbeitet germantobi Donnerstag, 16. Oktober 2014 09:54
    Donnerstag, 16. Oktober 2014 09:48

Antworten

  • Hallo germantobi,
    Wurden auch die Netzwerkanforderungen vor dem Installationsversuch erfüllt (DHCP, DNS samt Gatewayeinstellungen)? Wenn Du sie nicht explizit erwähnst, kann das bedeuten, dass entweder ihre Erfüllung sich von selbst versteht oder sie noch nicht konfiguriert wurden.
    Grüße,

    Dimitar


    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip „IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.

    Freitag, 17. Oktober 2014 09:16
    Moderator
  • Sieh Dir folgenge Artikel an:

    Troubleshooting the Windows Phone 8 Emulator -> Cannot connect to network destinations when network settings require manual configuration

    System requirements for the emulator for Windows Phone 8

    Soweit ich Deiner ersten Nachricht im Thread entnehmen kann, sind die Hyper-V- und die Systemanforderungen erfüllt, aber den Netzanforderungen sollte ebenfalls Rechnung getragen werden.

    Das Netz, mit dem das WP 8.1 mittels des virtuellen Switches (der virtuelle Switch ist intern, nicht wahr?) verbunden ist, muss automatische Konfiguration der DNS- und Gatewayeinstellungen zulassen und außerdem muss DHCP aktiviert werden. Das sind zwei der Anforderungen vor der Installation. Hoffentlich wird das Befolgen der dortigen Anleitungen die Installation ermöglichen.

    Folgende Diskussion könnte auch Aufschluss geben, wenn die obigen Anleitungen zum Lösen des Problems nicht ausreichen: Windows Phone 8.0 SDK Emulator (VM failure) issue

    Grüße,

    Dimitar


    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip „IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.




    Freitag, 17. Oktober 2014 10:48
    Moderator
  • Im folgenden MSDN-Artikel werden (Hyper-V-bezogene) Anforderungen aufgezählt, die vor der Installation des Emulators zu erfüllen sind. Aus der bisherigen Diskussion kann man schließen, dass die BIOS-Einstellungen angepasst wurden und das Hyper-V Feature aktiviert ist.

    Artikel: How to enable Hyper-V for the emulator for Windows Phone 8

    Würdest Du mithilfe der zwei dort verlinkten Tools überprüfen, ob die Nachrichten „ You have a SLAT capable machine“ bzw. Hypervisor is presentVMX“ auftauchen. Auch ob Datenausführungsverhinderung unter Leistungsoptionen in der Systemsteuerung aktiviert ist.

    Grüße,
    Dimitar


    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip „IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.

    Mittwoch, 22. Oktober 2014 09:38
    Moderator

Alle Antworten

  • Hallo germantobi,
    Wurden auch die Netzwerkanforderungen vor dem Installationsversuch erfüllt (DHCP, DNS samt Gatewayeinstellungen)? Wenn Du sie nicht explizit erwähnst, kann das bedeuten, dass entweder ihre Erfüllung sich von selbst versteht oder sie noch nicht konfiguriert wurden.
    Grüße,

    Dimitar


    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip „IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.

    Freitag, 17. Oktober 2014 09:16
    Moderator
  • Ich bin mir jetzt nicht ganz sicher was mit "Netzwerkanforderungen" gemeint ist.

    Ich hab mit meinem Laptop Internetverbindung, zuvor wurde ja auch Visual Studio auf diesem Weg installiert.

    Ich hoffe das ist die Antwort auf die Frage.

    Freitag, 17. Oktober 2014 09:47
  • Sieh Dir folgenge Artikel an:

    Troubleshooting the Windows Phone 8 Emulator -> Cannot connect to network destinations when network settings require manual configuration

    System requirements for the emulator for Windows Phone 8

    Soweit ich Deiner ersten Nachricht im Thread entnehmen kann, sind die Hyper-V- und die Systemanforderungen erfüllt, aber den Netzanforderungen sollte ebenfalls Rechnung getragen werden.

    Das Netz, mit dem das WP 8.1 mittels des virtuellen Switches (der virtuelle Switch ist intern, nicht wahr?) verbunden ist, muss automatische Konfiguration der DNS- und Gatewayeinstellungen zulassen und außerdem muss DHCP aktiviert werden. Das sind zwei der Anforderungen vor der Installation. Hoffentlich wird das Befolgen der dortigen Anleitungen die Installation ermöglichen.

    Folgende Diskussion könnte auch Aufschluss geben, wenn die obigen Anleitungen zum Lösen des Problems nicht ausreichen: Windows Phone 8.0 SDK Emulator (VM failure) issue

    Grüße,

    Dimitar


    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip „IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.




    Freitag, 17. Oktober 2014 10:48
    Moderator
  • Ich weiß irgendwie immer noch nicht richtig was ich machen oder einstellen soll.

    Ich hab jetzt mal das gemacht was hier geschrieben wurde:

    "Go into Hyper V. Go into the Virtual Switch Manager. Create a virtual switch called "Windows Phone Emulator Internal Switch" Make it's connection type Internal."

    Ich habs aber ja immer noch nicht installiert.

    Freitag, 17. Oktober 2014 11:26
  • Ich nehme an, Deine Virtuelle Maschine (wo WP OS 8.1 läuft) war bislang an keinem virtuellen Switch verbunden. Du hast jetzt einen (internen) im Manager für Virtuelle Switches erstellt. Dann verknüpfe die Virtuelle Maschine an den Switch (Rechtsclick auf die VM, nachdem sie gestoppt wurde -> Einstellungen -> Hardware hinzufügen, dann wähle den neulich erstellten Switch und bestätige). Danach starte die VM und aktiviere DHCP wie unten beschrieben:

    Setting up DHCP Policies for Virtual Machines

    Und dann probiere erneut (nachdem die automatische Konfiguration der DNS- und Gatewayeinstellungen für das Netz sichergestellt wurde), den Emulator zu installieren.

    Grüße,

    Dimitar


    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip „IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.


    Freitag, 17. Oktober 2014 11:52
    Moderator
  • Ich glaub wir haben etwas aneinander vorbei geredet.

    Ich hab Windows 8.1 Pro am laufen und Visual St. 2013 E. installiert.

    Da dort kein Emulator aufgelistet ist wollte ich den nachinstallieren.

    Ich bekomm aber beim Installationsstart eine Fehlermeldung:

    (Da ich noch keine Bilder hochladen kann hier der Link vom Screenshot)

    myimg.de/?img=installvswp81e586e7.jpg

    Freitag, 17. Oktober 2014 12:09
  • Hast Du das Hyper-V Feature des Betriebssystems aktiviert (die Checkboxen unter Systemsteuerung -> Windows-Features aktivieren oder deaktivieren -> Windows-Features -> Hyper-V) ?

    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip „IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.

    Freitag, 17. Oktober 2014 13:59
    Moderator
  • Ja hab ich.

    Mittwoch, 22. Oktober 2014 08:25
  • Im folgenden MSDN-Artikel werden (Hyper-V-bezogene) Anforderungen aufgezählt, die vor der Installation des Emulators zu erfüllen sind. Aus der bisherigen Diskussion kann man schließen, dass die BIOS-Einstellungen angepasst wurden und das Hyper-V Feature aktiviert ist.

    Artikel: How to enable Hyper-V for the emulator for Windows Phone 8

    Würdest Du mithilfe der zwei dort verlinkten Tools überprüfen, ob die Nachrichten „ You have a SLAT capable machine“ bzw. Hypervisor is presentVMX“ auftauchen. Auch ob Datenausführungsverhinderung unter Leistungsoptionen in der Systemsteuerung aktiviert ist.

    Grüße,
    Dimitar


    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip „IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.

    Mittwoch, 22. Oktober 2014 09:38
    Moderator
  • Mittwoch, 22. Oktober 2014 10:42