none
Access 2016 Update 1707 ListView TreeView gehen nicht mehr

    Frage

  • Nach den Office Update auf die Version 1707 gehen die  ListView TreeView nicht mehr

    also sprich die MSCOMCTL.OCX macht probleme

    wenn ich auf dem gleichen PC das Access Programm über Runtime 2013 starte geht alles wie gewohnt.

    also ich denke kein Problem mit alter neuer version oder Registrierung oder einträge in der Registry

    muss irgendwie mit Access 2016 und sperre zur MSCOMCTL.OCX zu tun haben

    Mittwoch, 2. August 2017 07:57

Antworten

  • Hallo,

    Alternativ kann man sich im Moment folgendermaßen behelfen, wenn man kein Downgrade machen möchte:

    1. Schließt alle Office-Programme (Outlook, Excel, Word & Co.).

    2. Benennt die Datei MSCOMCTL.OCX im Ordner:
        C:\Program Files (x86)\Microsoft Office\root\VFS\SystemX86
        um. Z.B. in MSCOMCTL.OCX_

    3. Kopiert die Datei MSCOMCTL.OCX aus dem Ordner (die Datei sollte bestenfalls die Versionsnummer 6.1.98.46 haben) 
       C:\Windows\SysWOW64
       in den Ordner
       C:\Program Files (x86)\Microsoft Office\root\VFS\SystemX86

    Ein De- und Registrieren ist nicht erforderlich.

    Ich wünsche euch ein schönes Wochenende 
    Manuela


    • Als Antwort vorgeschlagen FrancescoCZY Montag, 21. August 2017 19:00
    • Als Antwort markiert MCDPone Freitag, 25. August 2017 08:03
    Freitag, 18. August 2017 04:07

Alle Antworten

  • Hi,

    Du bist doch schon solange im Forum unterwegs. Da solltest Du doch wissen, dass "geht nicht" nichts ist, mit dem man auch nur irgendwas anfangen kann. Poste daher bitte die fehlenden Informationen.


    Gruß, Stefan
    Microsoft MVP - Visual Developer ASP/ASP.NET
    http://www.asp-solutions.de/ - Consulting, Development
    http://www.aspnetzone.de/ - ASP.NET Zone, die ASP.NET Community

    Mittwoch, 2. August 2017 08:01
    Moderator
  • Ja recht hast du

    also das Steuerelement bleibt weiss - die meldung dazu ist auf einmal

    Sie verfügen nicht über die Lizenz, die erforderlich ist um dieses ActiveX Steuerelement einzusetzen....

    aber wie gesagt bis 1706 alles OK und bei Access 2013 Runtime auch kein Problem

    ab 2016 1707 bekomme ich die meldung

    Mittwoch, 2. August 2017 19:57
  • Bei mir ist genau das gleiche Problem aufgetreten nach dem Office-Update vom 27. Juli 2017. Sobald ein Formular geöffnet wird, in dem sich das Treeview Steuerelement befindet, stürzt Access ab.
    Montag, 7. August 2017 19:46
  • Ich kann das Problem ebenfalls bestätigen.

    Das TreeView bleibt seit den letzten Updates leer.

    Nachvollziehbar auf einem Office 2016 32bit als Click2Run Installation, welches über den Aktuellen Updatekanal (Current) aktualisiert wurde.
    Das betroffene TreeView sollte auf einem Forumlar in einer MDB (MDE) die mit einem älterem Build erstellt wurde, erscheinen. Tut es leider nicht mehr.


    Aktuelle Build-Nummer 1707 (8326.2070)

    heutiges Update auf

    Aktuelle Build-Nummer 1707 (8326.2073)
    zeigt diese Problem ebenfalls noch.


    Es scheint dass diese Inkompatibilität mit Update Build-Nummer 1707 (Build 8326.2058)
    installiert wird. Die vorheriger Version 1706 (Build 8229.2103) funktionierte noch.

    (vgl. https://technet.microsoft.com/de-de/office/mt465751)

    Wir werden für die betroffenen Systeme als Workaround erstmal ein Downgrade auf die letzte
    funktionierende Office Buildnummer empfehlen.

    (vgl. https://support.microsoft.com/de-de/help/2770432/how-to-revert-to-an-earlier-version-of-office-2013-or-office-2016-clic)



    Noch ein paar Hintergrundinfos, was uns mit dem Update aufgefallen ist.
    Die MSCOMCTL.OCX wird auf Version 7.0.45.30876 (FileVersion) aktualisiert.
    (Merkmwürdige Produktversion: 7.0.45-Acc-g9c783e41a4).



    Damit tritt das Problem auf.

    Im VBA kann man dann auch auf keine Eigenschaften zugreifen. Sondern bekommt lediglich Fehlermeldungen wie

    2683 - In diesem Steuerelement befindet sich kein Objekt.

    oder (wahrscheinlich) als Folge davon:

    438- Objekt unterstützt diese Eigenschaft oder Methode nicht

    bsp. beim Zugriff auf Methode TreeView.Nodes.Clear


    Wenn man MCSCOMCTL.OCX durch eine ältere Version z.B. mit MSCOMCTL.OCX 6.1.98.46 ersetzt, würde es erstmal wieder gehen. (Dies ist aber ein NOGO für Produktivumgebungen).

    Die MSCOMCTL.OCX  7.0.45.30876 scheint auch nicht gänzlich defekt, denn wenn man einen neuen Dialog mit einem TreeView aus dieser Version erstellt scheint dieses zu funktionieren, nur eben nicht auf vorhandenen mit einer älteren Build-Version erstellten Dialogen. (Alle bestehenden Dialoge neu zu erstellen wäre jedoch kein akzeptabler Workaround.)

    Darüber hinaus ist es auch nicht möglich MSCOMCTL.OCX (7.0.45.30876) mittels RegSvr32 zu deregistrierung, bzw. reregistrieren.
    Dieser Versuch wird mit der Fehlermeldung: 0x80004005 (-> E_FAIL    Unspecified failure) quittiert.

    https://msdn.microsoft.com/de-de/library/windows/desktop/aa378137(v=vs.85).aspx


    Für mich stellen sich die Fragen:

    * Ist Microsoft das Problem bekannt und ein Fix in Arbeit?
    * Gibt es einen Plan, wann das Problem mit einem neuen Update behoben werden wird?
    Dienstag, 15. August 2017 14:48
  • Bedauerlicherweise habe ich bei mehr als 150 Projekten auch das Problem und stehe massiv im Regen.

    Ich habe versucht es neben Deinen Versuchen mit dem simplen Austausch der dll zu probieren hat leider auch nichts genutzt..

    Mittwoch, 16. August 2017 04:40
  • Ich habe versucht es neben Deinen Versuchen mit dem simplen Austausch der dll zu probieren hat leider auch nichts genutzt..

    Dann war das Ergebnis dieses Versuchs bei uns vielleicht auch einer Zufall.

    Wie gesagt, ich halte den Austausch der MSCOMCTL.OCX eh für ungeeignet!!!!! So etwas ist ok in einer Testumgebung, um das Problem initial einzugrenzen.  Aber die Chance ist sehr hoch das man mit soetwas auch nur noch mehr Schaden anrichtet. Daher also nix für produktive Umgebung.

    Hast Du ausprobiert die Office Updates auf den Stand vom Juni zurückzusetzen?

    Wir hatten dies gestern bei unseren Projekten nach Anleitung für Click2Run Versionen (siehe Links oben) erfolgreich ausprobiert.

    Das halte ich für den besseren Weg, erstmal systematisch mit dem Problem umzugehen, bis (vielleicht?) ein Bugfix Update kommt.

    Wie gesagt meine Erkenntnisse beruhen auch nur auf der Click2Run Variante der aktualisierten Office 2016 Version.

    Mittwoch, 16. August 2017 09:16
  • * Ist Microsoft das Problem bekannt und ein Fix in Arbeit?
    * Gibt es einen Plan, wann das Problem mit einem neuen Update behoben werden wird?

    Hallo, Stefan!

    Ich hab's vorhin anhand deiner sehr genauen Beschreibung beim Access-Team in Redmond gemeldet. Ich halte euch auf dem Laufenden, sobald ich etwas erfahre.


    Karl
    http://www.AccessDevCon.com
    http://www.donkarl.com


    Mittwoch, 16. August 2017 17:25
  • Update:

    Der Fehler ist bei MS bekannt. Liegt komplett an ComCtl. Ein Fix kommt. Wann, wird noch ermittelt.

    Bis dahin ist das Zurückgehen auf älteres Office der "sicherste" Workaround.


    Karl
    http://www.donkarl.com/?AEK
    http://www.AccessDevCon.com


    • Bearbeitet Karl DonaubauerMVP Donnerstag, 17. August 2017 07:19
    • Als Antwort vorgeschlagen --Stefan-- Mittwoch, 23. August 2017 06:58
    • Nicht als Antwort vorgeschlagen --Stefan-- Mittwoch, 23. August 2017 07:12
    Donnerstag, 17. August 2017 07:14
  • Update:

    Der Fehler ist bei MS bekannt. Liegt komplett an ComCtl. Ein Fix kommt. Wann, wird noch ermittelt.

    Bis dahin ist das Zurückgehen auf älteres Office der "sicherste" Workaround.


    Karl
    http://www.donkarl.com/?AEK
    http://www.AccessDevCon.com


    Seit dem Downgrade läuft es bei mir wieder.

    Der Downgrade geht wohl offiziell nicht bei Office Home and Business. So kann man dennoch downgraden:

    Kommandozeile starten und dies eingeben:

    "C:\Program Files\Common Files\microsoft shared\ClickToRun\officec2rclient.exe" /update user updatetoversion=16.0.8229.2103

    Jetzt sollte ein Office-Update-Fenster erscheinen und der Downgrade sollte nach etwa 10 Minuten durchgeführt sein.

    In Access bitte die automatischen Updates noch deaktivieren: Datei -> Konto -> Updates deaktivieren.

    Donnerstag, 17. August 2017 09:12
  • Super, das hat mir schon einmal sehr geholfen !!!!! Wohin soll ich den Kaffee und Kuchen mailen ??? :-)
    Donnerstag, 17. August 2017 14:42
  • Hallo,

    Alternativ kann man sich im Moment folgendermaßen behelfen, wenn man kein Downgrade machen möchte:

    1. Schließt alle Office-Programme (Outlook, Excel, Word & Co.).

    2. Benennt die Datei MSCOMCTL.OCX im Ordner:
        C:\Program Files (x86)\Microsoft Office\root\VFS\SystemX86
        um. Z.B. in MSCOMCTL.OCX_

    3. Kopiert die Datei MSCOMCTL.OCX aus dem Ordner (die Datei sollte bestenfalls die Versionsnummer 6.1.98.46 haben) 
       C:\Windows\SysWOW64
       in den Ordner
       C:\Program Files (x86)\Microsoft Office\root\VFS\SystemX86

    Ein De- und Registrieren ist nicht erforderlich.

    Ich wünsche euch ein schönes Wochenende 
    Manuela


    • Als Antwort vorgeschlagen FrancescoCZY Montag, 21. August 2017 19:00
    • Als Antwort markiert MCDPone Freitag, 25. August 2017 08:03
    Freitag, 18. August 2017 04:07
  • Danke für die CMD hat mir sehr geholfen
    Freitag, 18. August 2017 06:11
  • Hallo Manuela,

    weder downgrade (hat zwar gearbeitet aber danach war die Vesion immer noch 1707) noch
    Umbenennen/Kopieren wie o.beschrieben haben geholfen.
    Es gab nur eine Verhaltensänderung:
    - Vor dem Umbenennen/Kopieren erhielt ich die Fehlermeldung: "Sie  habe Lizenz zum Verwenden des ocx-Contols"
    - nach dem Umbenennen/Kopieren kommt die Fehlermeldung "In diesem Steuerelement befindet sich kein Objekt"

    Die kopierte (bisher funktionierende) Version aus SysWOW64 hat bei mir die Versionsnummer: 6.0.88.62
    vom 22.05.2000

    Gibt es noch andere Hilfsvorschläge? Es laufen bei mir und bei Kunde wichtige Produktivsysteme nicht mehr.
    Es gib noch ein System, das läuft und das hat statt Office2016 das bewährte Office 2010.

    MfG MichaMGA

    Freitag, 18. August 2017 07:40
  • Hallo zusammen,

    nach einem weiteren Tag Reparaturversuch, hat nun folgendes geholfen:
    1. Irgend ein Office-Programm mit leerem Dokument (am einfachsten Excel) öffnen
    2. Unter Datei/Konto die aktuelle Officeversion prüfen, bei: Version 1707(Build ....) besteht Handlungsbedarf
    3. Im gleichen Menü UpdateOptionen "Updates deaktiviere" auswählen.
        - danach habe ich an 3 vermeindlich gleich eingerichteten PCs folgende Reaktionen erlebt:
          a) Updates sind ohne "Murren" direkt deaktiviert
          b) es ist mit einem Domänen Administrator-Account anzumelden
          c) es ist ein Neustart erforderlich
        - in jedem Fall ist zu prüfen, ob neben der Schaltfläche UpdateOptionen
          "Für dieses Produkt wird kein Update ausgeführt" angezeigt wird
    4. ein CMD-Fenster als Administrator(!) ausführen
    5. Hier den Befehl:

    "C:\Program Files\Common Files\microsoft shared\ClickToRun\officec2rclient.exe" /update user updatetoversion=16.0.8229.2103

    ausführen. (Dauert etwa 3 Stunden - nicht die Geduld verlieren, ein orangefarbenes Fenster mit
    dem Text "Office-Updates werden heruntergeleaden ..." erscheint. Eine Art Aktivitätsanzeige aber
    leuder kein Fortschrittsbalken erscheint, wenn alles fertig ist, ist das Fenster kommentarlos verschwunden)
    6. Nun wieder die Office-Versione prüfen: wenn Version 1706 (Build...) ist alles OK und
        Access sollte wieder mit den Controls Treeview und Listview funktionieren.

    Freitag, 18. August 2017 11:40
  • Danke für die Info, Karl.

    Update:

    Wir haben dasselbe Problem auch auf Systemen mit der MSI Installation von Microsoft Office 2016 festgestellt, die nach dem 1. August über Windows Update aktualisiert wurden.

    Auf diesem Systemen wurde die MSCOMCTL.OCX offenbar nicht aktualisiert. Sie hatte noch die Version 6.1.98.46.

    Auf zwei dieser Systeme mit MSI Installation konnten wir das Problem durch Deinstallation des Updates "1. August 2017 Update für Office 2016 (KB4011051)" vorläufig beheben.


    Montag, 21. August 2017 10:06
  • 1. Schließt alle Office-Programme (Outlook, Excel, Word & Co.).

    2. ...

    Vielen Dank, Manuela - durch das Update funktionierte mein Treeview auch nicht mehr und blieb weiss. Nach dem Kopieren musste ich noch den Verweis neu setzen - seitdem funktioniert es wieder. Ich hoffe, es wird auch noch zentral offiziell gelöst.

    Montag, 21. August 2017 18:59
  • Wir haben dasselbe Problem auch auf Systemen mit der MSI Installation von Microsoft Office 2016 festgestellt, die nach dem 1. August über Windows Update aktualisiert wurden.

    Auf diesem Systemen wurde die MSCOMCTL.OCX offenbar nicht aktualisiert. Sie hatte noch die Version 6.1.98.46.

    Auf zwei dieser Systeme mit MSI Installation konnten wir das Problem durch Deinstallation des Updates "1. August 2017 Update für Office 2016 (KB4011051)" vorläufig beheben.


    Hallo, Stefan!

    Der Fix sollte bald kommen. Das Datum muss aber noch bestätigt werden.

    Bist du dir bei den MSI-Installationen sicher? Mein Kontakt meint, dass es bei MSI das Problem nicht geben sollte und auch das Update aus dem von dir zitierten KB-Artikel keine Rolle spielen sollte.

    Deshalb ersucht er um Repro-Schritte. Zitat:

    Can you give repro steps you are using to see this problem in an MSI build? (assuming that this repros from scratch and not only with specific existing databases)

    Nachtrag: Soeben und endlich ging eine Access-Problem-Referenz-Seite online, in der die comctl-Geschichte der neueste Eintrag ist.


    Karl
    http://www.donkarl.com/?AEK
    http://www.AccessDevCon.com


    Dienstag, 22. August 2017 22:13
  • ...

    Bist du dir bei den MSI-Installationen sicher? Mein Kontakt meint, dass es bei MSI das Problem nicht geben sollte und auch das Update aus dem von dir zitierten KB-Artikel keine Rolle spielen sollte.

    Deshalb ersucht er um Repro-Schritte. Zitat:

    Can you give repro steps you are using to see this problem in an MSI build? (assuming that this repros from scratch and not only with specific existing databases)


       

    Hi Karl,

    ersteinmal vielen Dank für Deine Unterstützung und Mühen!

    Ich fand dies auch anfangs auch etwas merkwürdig. Die Beschreibung dieses Updates für die MSI Installation deutet eigentlich keinen Zusammenhang damit an. Daher war ich anfangs noch etwas vorsichtigt mit einer Mutmaßung.

    Aber wir haben jetzt schon 3 Produktivsysteme mit einer MSI Office 2016 gefunden, die nach den August Updates dieses Symptom mit unserer Access basierten Anwendungen aufwiesen (-> Leeres Treeview). In jedem dieser Fälle half die Deinstallation des Office Updates KB4011051.

    Ich habe dieses heute nochmal selbst auf einem separaten Testsystem reproduziert.

    Dabei ist mir aufgefallen: Mit einer neuen Datenbank (erstellt heute mit Office 2016 Click2Run 1706 16.0.8229.2103 32bit) ist es mir dabei nicht gelungen, das Problem auf der aktualisierten MSI Installation zu reproduzieren.
    In dieser Situation funktionierte das TreeView Control korrekt. Daher habe ich die Datenbank aus unserer Anwendung auf dieses Testszenario reduziert. Damit konnte ich es auf zwei verschiedenen Testsystemen reproduzieren.

    Dies ist zwar ein Forum in deutscher Sprache, aber zur Vereinfachung der Kommunikation schreibe ich die Anleitung gleich in Englisch:


    Under following OneDrive link you can find a ZIP archive containing some test databases to reproduce/demonstrate the issue.

    https://1drv.ms/u/s!Akf0uxwbK2xMpFy4SkZ4danZuCUM

    Steps to reproduce:

    1. Install Microsoft Office 2016 MSI!! 32bit and all recent updates
    2. Ensure "August 1, 2017, update for Office 2016 (KB4011051)" is installed, too.
    3. Open database "August2017Updates_TreeViewProblem_Click2Run_OriginalForm.mdb" or "August2017Updates_TreeViewProblem_Click2Run_OriginalForm.mde"
        -> Expected Result: The AutoExec macro should open a form, containing a treeview control with some dummy nodes.
        -> Actual Result: The AutoExec macro opens the form but the treeview is empty. Some error messages appear instead.
    4. Close Access / Office completely
    5. Uninstall update "August 1, 2017, update for Office 2016 (KB4011051)"
    6. Open database "August2017Updates_TreeViewProblem_Click2Run_OriginalForm.mdb" or "August2017Updates_TreeViewProblem_Click2Run_OriginalForm.mde" again
       -> Actual Result == Expected Result from Step 3): The form is opened showing the Treeview with some dummy nodes and without any error messages.

    After that you can install update KB4011051 again and repeat the sequence from step 3 to 6.


    Additional notes:

    We have seen this issue on Windows 10 , Windows 8.1 and Windows 7 systems all 64bit, but Office 2016 MSI 32bit.

    The database August2017Updates_TreeViewProblem_Click2Run_OriginalForm.[mdb|mde] demonstrating this issue was the original source of our application.
    Using Office 2016 Click2Run 1706 16.0.8229.2103 (32bit) I just removed anything, except the original problematic form and treeview control on it. I just added a test method to fill the TreeView with some dummy nodes.

    Additionally you will find a database [August2017Updates_TreeViewProblem_Click2Run.[mdb|mde] in the linked test data archive.
    I created this database completely new from scratch using Office 2016 Click2Run 1706 16.0.8229.2103 32bit to reproduce this issue today. (Un)fortunately with this new database this issue is not reproducible.


    Mittwoch, 23. August 2017 16:59
  • Hallo, Stefan!

    Ich habe deine Repro-Anleitung an das Access-Team weitergeleitet. Das kann durchaus noch interessant sein für die Techniker dort.

    Vorhin kam auch eine inhaltliche Antwort zur MSI-Variante, die besagt, dass es sich anscheinend um ein komplett separates comctl-Problem handelt, das aber ähnliche Symptome bei MSI-Installationen bewirkt.

    Wer davon betroffen ist, solle KB4011093 installieren, um das Problem zu beheben, das von KB4011051 erzeugt wurde. Lustig finde ich, dass weder der Verursacher noch die Kur das Problem erwähnen.

    Erschlagt nicht den Boten, der selber nie die comctl verwenden würde, die ja immer wieder mal von MS-Updates vermurkst wird. ;-)


    Karl
    http://www.donkarl.com/?AEK
    http://www.AccessDevCon.com

    Mittwoch, 23. August 2017 21:18
  • Vorhin kam auch eine inhaltliche Antwort zur MSI-Variante, ...

    Wer davon betroffen ist, solle KB4011093 installieren, um das Problem zu beheben, das von KB4011051 erzeugt wurde. Lustig finde ich, dass weder der Verursacher noch die Kur das Problem erwähnen.


    Vielen Dank für die Info!

    Kann ich bestätigen nach Installation von KB4011093 tritt dass Problem mit dem TreeView nicht mehr auf.Und das TreeView zeigt wieder alle erwarteten Knötchen.


    Donnerstag, 24. August 2017 12:28
  • Hallo zusammen,

    das listview funktioniert auch nach dem neusesten update immer noch nicht, irgendwie frustrierend. Gibst den irgendeine Lösung ?

    Viele Grüße an Euch

    Donnerstag, 24. August 2017 15:43
  • Sie verfügen nicht über die Lizenz, die erforderlich ist um dieses ActiveX Steuerelement einzusetzen....

    Dazu gibt es nun auch ein Blog Artikel vom Office Team:
    https://blogs.technet.microsoft.com/the_microsoft_excel_support_team_blog/2017/08/22/license-errors-for-mscomctl-ocx-after-julyaugust-2017-update-of-office-365-proplus/

    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Freitag, 25. August 2017 11:49
  • An dieser Stelle der Hinweis, dass sich KB4011093 nicht bei allen betroffenen Usern installieren lässt! Hier kommt manchmal "Von dem auf diesem System installierten Paket sind keine Produkte betroffen".

    Der Tipp von Manuela oben sollte jedoch immer klappen, auch wenn dies die Office-ClickOnce-Installation verbiegt. Hier reicht übrigens das reine Umbenennen der mscomctl.ocx aus, da in der Regel die gleichnamige bereits unter SysWOW64 zu finden und registriert ist.

    In eigener Sache: Wer meinen VBA-ProcBrowser benutzt, welcher das Treeview verwendet und mit dem neuen OCX ebenfalls nichts anfangen kann, ergo nicht mehr funktioniert, sollte dieses Umbenennen vornehmen. Dann läuft er wieder.


    Sascha Trowitzsch

    Freitag, 25. August 2017 12:11
  • Hallo!

    Der angekündigte Fix für das ComCtl-Problem in den O365-Versionen ist nun in den Office-Updates drin. Er wird ab der nächsten Woche automatisch ausgerollt. Ihr könnt ihn aber jetzt schon manuell holen, über den Jetzt-Updaten-Link in Office. Wenn es geklappt hat, sollte die gefixte Buildversion lauten: 16.0.8326.2087

    Was den fast gleichzeitigen und ähnlichen, aber unabhängigen Bug in der MSI-Variante betrifft, so wird jetzt sowohl im Verursacher-Artikel KB4011051 als auch im Fix-Artikel KB4011093 die ComCtl-Geschichte erwähnt.

    Ich habe übrigens den Eindruck, dass unser gemeinsames Anschieben ein bissel geholfen hat. Bezüglich der Info im MSI-Fall sogar sicher. Das machen wir also beim nächsten ComCtl-Vermurksen durch Updates wieder so. Wetten über den Zeitpunkt werden noch angenommen. ;-)


    Karl
    http://www.donkarl.com/?aek
    http://www.AccessDevCon.com


    • Bearbeitet Karl DonaubauerMVP Samstag, 26. August 2017 11:31 wie immer - Sig gefixt
    • Als Antwort vorgeschlagen --Stefan-- Dienstag, 29. August 2017 09:46
    Samstag, 26. August 2017 11:30
  • Super!

    Der TreeView funktioniert wieder mit 16.0.8326.2087 für die Click2Run Variante.

    Besten Dank für Deine Vermittlung und auch an Deinen MS Kontakt!

    Ja der nächste Fall wird sicher irgendwann kommen. Ist halt so, Seiteneffekte sind blöd. Passieren aber halt selbst mit den besten Qualitätssicherungsprozessen. Insofern bin ich happy, dass es so schnell behoben werden konnte.

    Dienstag, 29. August 2017 09:55
  • Ich habe das Problem relativ schnell gelöst. Alle Listviews löschen und durch neue ersetzen. Einfach die Objektbezeichnung kopieren, Listview löschen, neues einsetzen und den Objektnamen wieder einfügen. Eventuell noch die Anker korrigieren und das wars. Für 4 Formulare weniger als 10 min.

    Voraussetzung ist natürlich, dass man das gesamte Listview programmiert hat (solle man immer machen) und keine manuellen Einstellungen vorgenommen hat.


    It's no problem, it's just the syntax

    Donnerstag, 3. Mai 2018 11:47