none
Fehlermeldung: Wer kann helfen?

    Frage

  • "Fehler im benutzten Ereignis dieses Felds. Feld: crmForm Ereignis: onsave Fehler: Die Eigenschaft "getValue" eines undefinierten oder Nullverweises kann nicht abgerufen werden."

    Wird beim Speichern von Kontakten angezeigt, Datensätze werden dennoch gespeichert. Wie gelange ich zu diesem Feld und woher kam diese Fehlermeldung? Hat jemand eine Ahnung?

    Danke im voraus

    Montag, 17. März 2014 11:21

Alle Antworten

  • Es kann vorkommen, dass Windows das Benutzerprofil nicht korrekt liest, wenn auf Ihrem Computer beispielsweise während der Anmeldung ein Antivirenprogramm ausgeführt wird. Bevor Sie die hier beschriebenen Methoden ausführen, versuchen Sie, den Computer neu zu starten und sich erneut mit Ihrem Benutzerkonto anzumelden, um das Problem zu beheben. Wenn Sie den Computer neu starten und das Problem dadurch nicht behoben wird, verwenden Sie die folgenden Methoden zur Problembehebung.

    Hinweis Sie müssen sich bei einem Administratorkonto anmelden können, um Ihr Benutzerprofil zu reparieren oder Ihre Daten in ein neues Konto zu kopieren. Melden Sie sich bei Windows mit einem anderen Konto mit Administratorberechtigungen an, oder starten Sie den Computer im abgesicherten Modus, um sich über das vordefinierte Administratorkonto anzumelden, bevor Sie mit der Problembehebung beginnen. Weitere Informationen zum Starten im abgesicherten Modus finden Sie auf der folgenden Website von Microsoft:

    Seite von Microsoft ( Support.Microsoft )

    Montag, 17. März 2014 11:31
  • Hallo,

    Ein paar mehr Informationen wären für eine Fehlersuche von Vorteil:

    * Welche CRM Version?

    * Welcher Rollup-Stand?

    * Wo tritt der Fehler auf - IE oder Outlook Client?

    * Tritt der Fehler bei jedem Benutzer auf?

    * Sind Programmierungen bei diesem Formular hinterlegt?

    Liebe Grüße,

    Andreas


    Andreas Buchinger
    Microsoft Dynamics Certified Technology Specialist

    Montag, 17. März 2014 12:09
  • Hallo Herr Buchinger,

    Version: CRM 2011 5.0.9690.391

    Der Fehler tritt bei, Outlook Client auf. Leider auch in der der IE Version, bei allen Benutzern, auch Administrator.

    Programmierungen waren hinterlegt, die dann abgeschaltet worden sind, dennoch tritt der Fehler auf?

    Ich weiß keinen Rat, weiß auch nicht wo ich hinpacken soll. Dazu sei erwähnt das ich USER mit Admin rechten bin - kein Programmierer...

    Aber in unserer IT hat man es bisher auch nicht gefunden. Ich dachte erst auch das ein Wert abgefragt wird der "NULL" ist aber nicht NULL sein darf... Nun aber ratlos..

    Montag, 17. März 2014 12:19
  • Hallo,

    dann würde ich einfach mal das Tracing einschalten. Im Trace File sollte dann im Details stehen, wodurch dieser Fehler produziert wird.

    Als ihr die Programmierungen abgeschaltet habt, habt ich da nicht nur OnLoad sondern auch OnSave abgeschaltet?


    Viele Grüße

    Michael Sulz
    MVP für Microsoft Dynamics CRM
    Blog
    Website XING LinkedIn Facebook Twitter

    Dienstag, 18. März 2014 07:34
    Moderator
  • Programmierungen waren es ja nicht direkt - ich habe Workflows eingestellt und aktiviert, dann wieder deaktiviert. Wo kann ich denn ein "Tracing" einschalten?

    Was ist ein Tracefile? Wo finde ich das dann?

    Dienstag, 18. März 2014 07:42
  • Hallo,

    Das Tracing kannst du direkt am Server mit diesem Tool aktivieren: http://crmdiagtool2011.codeplex.com/

    Das Log-File kannst du mit diesem Tool analysieren: http://www.stunnware.com/crm2/topic.aspx?id=tracelogviewer

    Liebe Grüße,

    Andreas


    Andreas Buchinger
    Microsoft Dynamics Certified Technology Specialist

    Dienstag, 18. März 2014 08:13
  • Es könnte ein Javascriptfehler sein.

    Deaktivier zur Probe doch einmal alle Scripte in diesem Formular und teste dann ob der Fehler immer noch vorkommt.

    Falls nicht, kannst du eins nach dem anderen wieder aktivieren und dich so an den Fehler heranarbeiten.

    Donnerstag, 27. März 2014 21:53