none
Dotnet Core Linux - Remote SQL verbindung scheitert RRS feed

  • Allgemeine Diskussion

  • Hallo zusammen,

    ich habe eine dotnet core 3.1 Webanwendung geschrieben die Daten vom SQL Server, der in der Coud ist, auflistet. Auf IIS läuft alles wie gehabt.  Nur auf dem Linux Server (Debian mit Apache) geht die SQL verbindung nicht. Vermute mal daß das was mit dem Proxy zu tun hat. Kann mir einer helfen?

    Benutze folgene Verbindungsaufbau:

    StartUp.cs

    services.AddDbContext<ConnectionDbClass>(options => options.UseSqlServer(Configuration.GetConnectionString("MyConnection")));
      "ConnectionStrings": {
        "MyConnection": "Server=IPADRESSE,PORT;Database=DATENBANK;User=USER;Password=PASSWORD;"
      },
    Danke im voraus


    Freitag, 29. Mai 2020 11:05

Alle Antworten

  • Hallo,

    es wäre hilfreich, wenn Du die vollständige Fehlermeldung postest, die Du erhältst.


    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Freitag, 29. Mai 2020 11:11
  • Also Die WebApp funktioniert soweit auch auf Linux, nur sobald eine Datenbank anfrage gemacht wird kommt folgendes

    Fehlermeldung im Browser

    Proxy Error

    The proxy server received an invalid response from an upstream server.
    The proxy server could not handle the request

    Reason: Error reading from remote server

    Hier die Fehlermeldung vom Log:

    [Fri May 29 11:21:52.671311 2020] [proxy_http:error] [pid 991:tid 140023301326592] (70007)The timeout specified has expired: [client 192.168.188.114:60382] AH01102: error reading status line from remote server 0.0.0.0:5000
    [Fri May 29 11:21:52.671452 2020] [proxy:error] [pid 991:tid 140023301326592] [client 192.168.188.114:60382] AH00898: Error reading from remote server returned by /

    Freitag, 29. Mai 2020 11:25
  • Hab das ganze Projekt auch auf Azure geladen um zu testen.... gleiches Problem

    502 - Web server received an invalid response while acting as a gateway or proxy server. There is a problem with the page you are looking for, and it cannot be displayed. When the Web server (while acting as a gateway or proxy) contacted the upstream content server, it received an invalid response from the content server.

    Freitag, 29. Mai 2020 11:42
  • Hallo lollos781,

      "ConnectionStrings": {
        "MyConnection": "Server=IPADRESSE,PORT;Database=DATENBANK;User=USER;Password=PASSWORD;"
      },

    Würdest Du es mit User Id=USER; anstatt User=USER; in der Verbindungszeichenfolge probieren?

    Gruß,
    Dimitar


    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip „IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.

    Freitag, 5. Juni 2020 06:57
    Moderator