locked
Sudden Visual Studio 2017 SmartDeviceException DEP6200 error RRS feed

  • Frage

  • Yesterday I was able to Code with VS2017 on my Win 7 (upgrade to 10)/Lumia 950XL. I am writing on an UWP-App which targets Mobile-Devices and PC.

    I was happily writing on my app and debugging it on my phone, everything worked great. The suddenly I had to leave and I ran the app a last time on my phone, to see if my changes worked -> worked. So I sent my Laptop on Standby and after returning I wanted to run it again -> This Error appeared:

    DEP6200: Bootstrapping failed. Device cannot be found. SmartDeviceException - Deployment failed because no device was detected. Make sure a device is connected and powered on. [0x80131500]


    Common Answer:

    • I tried to turn of "Developer Mode" - run and expected the error.
    • Then turn "Developer Mode" on - run and expected it to work - it didn't.

    I also tried to connect my Phone without connection to W-Lan. I also tried to repair VS2015 (I am not able to repair VS2017 - somehow).

    I did not try to uninstall and install because that would take a full day away and I need the time to Code.

    Open for help.

    Edit:

    I have this Phone and this Laptop, no other Windows Devices to debug. (and not enough RAM to run an emulator that would help).

    Mittwoch, 24. Mai 2017 10:29

Alle Antworten

  • Runs the Service "IpOverUsbSvc" ??

    Take a look here: http://stackoverflow.com/questions/30292782/windows-phone-deploy-issue

    Greeting, Stefan


    Freiberufler im Bereich Softwareentwicklung Von der PLC und Robotik zu VB.NET & C#, vorrangig WPF und UWP


    Donnerstag, 25. Mai 2017 07:52
  • I updated and repaired VS2017 and tried your link. Now it seems to work. 
    What could have been the cause?
    Donnerstag, 25. Mai 2017 19:41