none
SharePoint 2019 - System.ServiceModel 4.0.0.0 RRS feed

  • Frage

  • Hallo,

     

    wir haben bei uns im Unternehmen eine Einzelserverfarm laufen. Nichts besonderes. Drei Websitesammlungen mit jeweils 25-30 Unterseiten. Auf den Unterseiten sind auch nur Dokumentenbibliotheken.

     

    Leider haben wir bei unserem SharePoint ab und zu das Problem das wenn Leute morgens die Räume aufrufen das denen dann nicht die Unterseiten angezeigt werden. Es kommt dann die Meldung: Listenfehler.

    Ab und zu werden die Unterseiten angezeigt aber sobald man dann eine der Unterseiten aufruft bekommt man den Listenfehler in der Unterseite.

     

    Jetzt zum wirklich komischen part. Dann starte ich auf dem Server selber den SharePoint Designer und verbinde mich mit der Websitesammlung und dann ist das Problem weg.

     

    Ein paar Tage geht es mal gut und dann auf einmal habe ich den Fehler wieder...

    Fehler in der Ereignisanzeige:

    WebHost konnte eine Anforderung nicht verarbeiten.
    Absenderinformationen: System.ServiceModel.ServiceHostingEnvironment+HostingManager/44643599
    Ausnahme: System.ServiceModel.ServiceActivationException: Der Dienst '/_vti_bin/client.svc' kann aufgrund einer Ausnahme während der Kompilierung nicht aktiviert werden. Die Ausnahmemeldung lautet: Die Webanwendung auf 'https://si-00514.login.sitte.de:443/_api/Microsoft.SharePoint.Portal.SuiteNavData.GetSuiteNavData?v=...' wurde nicht gefunden. Überprüfen Sie, ob Sie die URL richtig eingegeben haben. Falls die URL vorhandenen Inhalt anbietet, muss der Systemadministrator der entsprechenden Anwendung möglicherweise eine neue Anforderungs-URL-Zuordnung hinzufügen.. ---> Microsoft.SharePoint.SPException: Die Webanwendung auf 'https://si-00514.login.sitte.de:443/_api/Microsoft.SharePoint.Portal.SuiteNavData.GetSuiteNavData?v=...' wurde nicht gefunden. Überprüfen Sie, ob Sie die URL richtig eingegeben haben. Falls die URL vorhandenen Inhalt anbietet, muss der Systemadministrator der entsprechenden Anwendung möglicherweise eine neue Anforderungs-URL-Zuordnung hinzufügen.
    bei Microsoft.SharePoint.Utilities.SPUtility.ConfigServiceHostIfClaimsAuth(ServiceHost serviceHost)
    bei Microsoft.SharePoint.Client.SPClientServiceHost.OnServiceHostOpening(ServiceHost serviceHost)
    bei Microsoft.SharePoint.Client.Services.MultipleBaseAddressWebServiceHost.OnOpening()
    bei System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
    bei System.ServiceModel.ServiceHostingEnvironment.HostingManager.ActivateService(ServiceActivationInfo serviceActivationInfo, EventTraceActivity eventTraceActivity)
    bei System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath, EventTraceActivity eventTraceActivity)
    --- Ende der internen Ausnahmestapelüberwachung ---
    bei System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath, EventTraceActivity eventTraceActivity)
    bei System.ServiceModel.ServiceHostingEnvironment.EnsureServiceAvailableFast(String relativeVirtualPath, EventTraceActivity eventTraceActivity)
    Prozessname: w3wp
    Prozess-ID: 17376

    Donnerstag, 20. Januar 2022 07:09

Alle Antworten

  • Wenn der IIS ggf. auf Web-Ressourcen außerhalb des eigenen Raumes zugreifen will, müssen diese auch verfügbar sien. Ggf. machst du diese mit deinem Designeraufruf verfügbar.
    Wenn der Server ider IIS aber neu gestartet werden, stehen diese u.U. halt nicht mehr zur Verfügung.
    Dazu musst du die Url mal genau auf Erreichbarkeit untersuchen und was du beim Designerzugriff anderes machst.

    Donnerstag, 20. Januar 2022 09:39