none
SQL Datenbank Update

    Frage

  • Hallo zusammen,

    ich versuche seit 2 Wochen eine Änderung im meine Datenbanktabelle zu speichern ohne Erfolg.

    ich mache es mit einer WPF Anwendung und sobald die Anwendung geschlossen ist gehen alle Änderungen verloren.

    Wenn ich aber eine Änderung durchführe und dannach eine Abfrage zeigt er mir den Neuen Antrag aber wenn ich die Anwendung neu starte zeit er mir die Alte Daten wieder. Ich habe schon "alles" probiert aber es geht immer noch nicht.

    Danke schonmal!

    VG


    • Bearbeitet Yeumeus Donnerstag, 29. September 2016 14:59
    Donnerstag, 29. September 2016 14:53

Antworten

  • Hallo,

    in den meisten Entwicklungs-Umgebungen ist es so, das im Debug Modus immer mit einer Kopie der Datenbank gearbeitet wird, damit man beim Testen nicht durch Programmfehler o.ä. die eigentlich Datenbank beschädigt wird. Wenn Du mit Visual Studio arbeitest, dann sieh mal im Debug/Release Ordner nach, dort wirst Du die MDF/LDF Datei mit den eingefügten Daten finden.


    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    • Als Antwort markiert Yeumeus Donnerstag, 29. September 2016 16:52
    • Tag als Antwort aufgehoben Yeumeus Montag, 12. Dezember 2016 09:42
    • Als Antwort markiert Yeumeus Montag, 12. Dezember 2016 15:04
    Donnerstag, 29. September 2016 16:05

Alle Antworten

  • Hallo,

    in den meisten Entwicklungs-Umgebungen ist es so, das im Debug Modus immer mit einer Kopie der Datenbank gearbeitet wird, damit man beim Testen nicht durch Programmfehler o.ä. die eigentlich Datenbank beschädigt wird. Wenn Du mit Visual Studio arbeitest, dann sieh mal im Debug/Release Ordner nach, dort wirst Du die MDF/LDF Datei mit den eingefügten Daten finden.


    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    • Als Antwort markiert Yeumeus Donnerstag, 29. September 2016 16:52
    • Tag als Antwort aufgehoben Yeumeus Montag, 12. Dezember 2016 09:42
    • Als Antwort markiert Yeumeus Montag, 12. Dezember 2016 15:04
    Donnerstag, 29. September 2016 16:05
  • Danke! 

    ich habe mit der .exe Datei probiert. hat funktioniert.

    Donnerstag, 29. September 2016 16:52