none
Installationsproblem SQL Server 2008 R2 RRS feed

  • Frage

  • Hallo an Alle!

     

    Ich wollte den neuen SQL-Server auf einer frischen Windows Server 2008R2-Maschine installieren, allerdings kommt jedesmal wenn ich den Setup starte folgender Fehler:

    "SQL Server setup media does not support the language of the OS or does not have ENU localized files.Use the matching language-specific SQL-Server media or change the OS locale through Control Panel"

    Sowohl der Server als auch der SQL server sind deutschsprachige Versionen.

     

    Ich bedanke mich schonmal im Vorraus für eure Hilfe!

    MFG

    Freitag, 7. Mai 2010 08:16

Antworten

Alle Antworten

  • Freitag, 7. Mai 2010 08:39
    Beantworter
  • Vielen Dank; jetzt gehts.
    Freitag, 7. Mai 2010 09:33
  • Ich habe jetzt das gleiche Problem auf zwei Rechnern.

    Ein Rechner hat ein 64-bit Windows 7 Professional, der andere  ein Windows 7 Starter (32-bit).

    Beide stehen auf Deutsch-Deutschland in den Systemeinstellungen.

    Eine Gemeinsamkeit auf beiden Rechnern ist ein vorinstalliertes Microsoft Office 2007, bei denen im Setup deutsch und "english" steht.

    Das Englisch kann aber einzeln nicht entfernt werden.

    Verhindert etwa dieses Englisch die Installation eines deutschen SQL-Servers 2008 R2?

    Wo holt das Setup die Angabe zum Vergleich her?

    Gruß

    Andreas Nitschke

    Mittwoch, 13. Oktober 2010 15:11
  • Jetzt habe ich die Antwort noch selbst gefunden.

    Das Setup holt sich die Sprache aus der Registry von
    HKEY_CURRENT_USER\Control Panel\International\Locale

    Dort stand bei beiden betroffenen Systemen die 00000409 (für USA). Nach Änderung auf 00000407 (für Deutschland) und Windows-Neustart konnte die deutsche Version von SQL Express 2008 R2 installiert werden.

    Die Eintrag LocaleName stand bei beiden Systemen de-DE entsprechend den in der Systemsteuerung sichtbaren Einstellungen. Aber das reicht nicht zum Aufruf des Installationsprogrammes.

     

    Gruß

     

    Andreas


    Donnerstag, 14. Oktober 2010 09:33
  • Hallo allerseits

    Ich kann obigen Lösungsansatz bestätigen, obwohl ich nicht in Deutschland, sondern in der Schweiz sitze und demzufolge wie wohl die meisten User hier (im deutschsprachigen Teil der Schweiz), als Sprache "Deutsch ( Schweiz, deutsch)" als OS-Sprache eingerichtet habe:

    Und obwohl wir hier nicht alle viersprachig aufwachsen, so unterscheiden sich halt auch die deutschsprachigen Tastaturen der Schweiz von jenen in Deutschland, z.B. wegen den Tasten mit den französischen Akzenten.

    Beim Installieren von "Microsoft SQL Server 2008 R2 RTM - Express mit Verwaltungstools" (auf Windows XP, SP3) musste auch ich den Wert der "Locale" (Registry HKEY_CURRENT_USER\Control Panel\International\Locale) von 00000807 auf 00000407 (für Deutschland) umstellen und nach erfolgreicher Installation wieder auf 00000807 zurücksetzen.

    Besten Dank allen, die mir mit ihren hier obenstehenden Einträgen sehr geholfen haben, mein Problem - beim Installieren eines "Express"-Produktes (?!) - zu lösen. 

     

    Sonntag, 17. Oktober 2010 08:47
  • Hallo

     

    Habe auch das Installationsproblem.

    Locale per Hand auf 00000407 gestellt, Installation geht trotzdem nicht.

     

    Was nun?

     

    Englischen SQL Server könnte ich installieren, will ich aber nicht!

     

    LG

     

    P.

    Montag, 10. Januar 2011 17:16
  • Auf einmal gehts, im dritten Anlauf! Nicht sehr User freundlich das Ganze. :-( LG P.
    Montag, 10. Januar 2011 17:31
  • Hallo zusammen

    Danke euch allen, eure Beiträge haben auch mir geholfen, hatte dasselbe Problem. Bin ebenfalls aus der deutschsprachigen Schweiz.

    Gruss

    Samstag, 15. Januar 2011 10:21
  • Hallo Zusammen,

    Vielen Dank, auch mir hat dies sehr geholfen. Wichtig, nach der Änderung ein Neustart des Servers durchführen. Ansonsten funktioniert es nicht.

    (Ich bin ebenfalls aus der deutschsprachigen Schweiz)

     

    Ich wünsch Euch allen ein tolles Wochenende

    Gruss

    Freitag, 4. Februar 2011 09:20
  • Hallo,

     

    vielen Dank, die obige Anweisung (Änderung auf 00000407) hat auch bei mir geholfen.

     

    Grüße aus dem Salzburger Seenland

    Sonntag, 15. Mai 2011 09:25
  • Hallo,

    habe das gleiche Problem und alle Hinweise halfen nichts. Habe die gleiche Fehlermeldung beim Installieren der deutzschen Version mit der ENU locale.

    In der Registry (Windows 7) gabs den Eintrag HKEY_CURRENT_USER\Control Panel\International\Locale Locale nicht. Habe ihn mit Hand hinzugefügt und den Wert 00000407 zugeordnet. Es half nichts.

    Die Installation der ENU-Version brachte ebenfalls Fehler.

    Mein SQL Server Express 2005 läuft. Ich kann problemlos mit dem Managementtool zugreifen. Mein Provider hat aber die SQL-DB auf Version 2008 umgestellt. Mit dem Managementtool 2005 kann ich aber nicht auf dessen 2008 Datenbank zugreifen.

    Was kann ich noch tun? 2005 Deinstallieren, das möchte ich nicht, weil ich Angst habe dass ich dann weder den 2005er noch den 2008er SQL Server habe.


    Danke für die Hilfe
    Mittwoch, 7. September 2011 10:26
  • Hallo k.appel,

    falls es wirklich in HKEY_CURRENT_USER\Control Panel\International\ keinen Schlüssel Locale  geben sollte, würde ich zunächst über die Systemsteuerung bei den Regions-und Sprachoptionen Deutschland einstellen

    Alternativ würde ich noch einen neuen Benutzer mit Administratorrechten anlegen. Da dieser Benutzer dann sein eigener "current User" ist, bekommt der auch seinen eigenen Abschnitt in der Registry. Dieser Locale-Schlüssel müsste dann wieder auf 00000407 stehen, um den deutschen SQL Server Express 2008 R2 nach einem Neustart als dieser Benutzer installieren zu können.

    Aber in dieser Windows-Installation scheinen noch mehr Probleme zu stecken, wenn schon die ENU-Version nicht installiert werden kann.
    Donnerstag, 8. September 2011 20:00
  • Auf einmal gehts, im dritten Anlauf! Nicht sehr User freundlich das Ganze. :-( LG P.


    Gleiches Phänomen unter Windows 7 mit vorinstalliertem "Microsoft Office 2010 Starter". Trotz Einstellung auf Deutschland de-DE wurde die Setup-Datei erst im dritten Anlauf akzeptiert! Man muss es wohl nicht verstehen.

     

    Mit freundlichen Grüßen,

    Colin Groebel

    zwei R software & consulting GmbH

    Montag, 24. Oktober 2011 09:29
  • Hallo Mitstreiter,

    auch bei mir gibt es den Schlüssel HKEY_CURRENT_USER\Control Panel\International\Locale nicht (frische Win 7 Prof 64 Installation).

    Was bei mir geholfen hat (weiß der Geier warum):

    in Systemsteuerung --> Regions & Sprachoptionen --> Format den ursprünglichen Eintrag "Deutschland (Deutschland)" auf irgendeinen anderen Wert (z.B. "English....") stellen, OK drücken, und dann wieder "Deutschland (Deutschland)" einstellen und OK drücken. Reboot war nicht notwendig.

    Freitag, 18. November 2011 09:38
  • Ich hatte genau das selbe Problem, nachdem ich meine Regions und Sprachoptionen von Deutsch (Österreich) auf Deutsch (Deutschland) umgestellt habe hat es funktioniert.

    LG Thomas


    Thomas Huber

    • Als Antwort vorgeschlagen Thomas Huber Donnerstag, 19. April 2012 15:55
    Donnerstag, 19. April 2012 15:55
  • Hatte das gleiche Problem mit SQL Server 2012 und konnte es auch per Regestry Eintrag lösen:
    HKEY_CURRENT_USER\Control Panel\International\Locale
    Alter
    Wert:00000c07
    Neuer Wert:00000407

    Klappt bestens - Danke euch!

    lg Gilbert

    Donnerstag, 9. August 2012 06:23
  • Gleiches Problem bei Server 2012 Standard (DE) und SQL Server 2012 (DE) aus dem Actionpack. Danke Microsoft für die Probleme, und danke dem Forum für die Lösung die auch bei uns funktioniert hat.

    Lg. Alex

    Samstag, 18. Januar 2014 00:45