none
TFS2012 - Intern erreichbar, extern Fehler TF31002 RRS feed

  • Frage

  • Ich habe einen TFS 2012 und VS 2010-2017. Seit kurzem kann ich mich mit meinem Laptop nicht mehr von extern verbinden.

    Der Server läuft auf Port 8443, wird intern sowohl unter der gleichen Domain (sagen wir tfs.mydomain.tld/tfs) und dem gleichen Port angesproche wie extern

    Nun der Teil den ich nicht verstehe: Das o. g. Problem tritt nur innerhalb von VS (egal welche Version) auf. Rufe ich von extern die im Browser die Seite https://tfs.mydomain.tld:8443/tfs auf, so ist der Server wie gewohnt zu erreichen.

    Keine Zertifikatsfehler, Zertfifat ist gültig.

    Änderungen am Laptop: Deinstallation und Neuinstallation von VS2012 gefolgt von Update 5 für VS2012 (VS2012 stürzte beim Start trotz Reparatur ab)

    Irgendeine Idee?

    Danke

    Volker


    Und Abends ein Glas Wein von AMAVINO

    Samstag, 23. Dezember 2017 08:01

Alle Antworten

  • Hi Volker,
    und was sagt der Team-Reiter in Excel?

    --
    Viele Grüsse
    Peter Fleischer (ehem. MVP)
    Meine Homepage mit Tipps und Tricks

    Samstag, 23. Dezember 2017 14:02
  • Konnte das jetzt erst kontrollieren, aber das Eregebnis ist das gleiche. Keine Verbindung von extern mit Fehler TF31002.

    Und Abends ein Glas Wein von AMAVINO

    Sonntag, 24. Dezember 2017 10:33
  • Hi Volker,
    tritt das Problem auch auf, wenn Du den Namen der Projektcollection hinzufügst?

    https://tfs.mydomain.tld:8443/tfs/projectcollectionname

    Und wie ist die Firewall für den Port 8443 und die Internet-Zone eingestellt?


    --
    Viele Grüsse
    Peter Fleischer (ehem. MVP)
    Meine Homepage mit Tipps und Tricks


    Sonntag, 24. Dezember 2017 13:35
  • Hi Peter,

    auch mit der ProjectCollection bleibt das Problem.

    Port 8443 für die FW muss ja offen sein, sonst hätte es früher nicht funktioniert und ich komme über diesen Port ja via Browser auch auf den TFS.

    Habe auch mal probiert die %LocalAppData%\Microsoft\Team Foundation\4.0\Cache - Dateien zu löschen. Ergebnis bleibt.

    Mir echt ein Rätsel.


    Und Abends ein Glas Wein von AMAVINO

    Sonntag, 24. Dezember 2017 14:06
  • Hi Volker,
    ich habe schon erlebt, dass nach Updates und Aktualisierungen Einstellungen zurückgesetzt wurden. Deshalb sollte man bei Problemen nochmals den gesamten Weg vom Client zum Server überprüfen. So kann beispielsweise auch ein Proxy durch Arbeiten an einer anderen Software eingestellt bzw. umkonfiguriert wurden sein.

    --
    Viele Grüsse
    Peter Fleischer (ehem. MVP)
    Meine Homepage mit Tipps und Tricks

    Montag, 25. Dezember 2017 07:30