none
Workflow automatisches Mail verschicken RRS feed

  • Frage

  • Hallo,

    folgendes Problem ärgert mich seit über 2 Stunden:

    Wir haben einen Workflow wo ein "Angebot" erstellt wird und eine Mitarbeiterin dann eine Freigabe machen muss. Nun überprüfe ich per Workflow diese "Freigeben" Option (Optionssatzfeld mit Ja oder Nein) und möchte sobald das Feld auf JA geändert wird eine Automatische Mail an den Verkäufer (ist bei dem Angebot hinterlegt) verschickt wird. Die Felder habe ich alle nur leider verschickt er kein Mail....

    Als Absender für den Workflow habe ich den CRM Admin hinterlegt, dort ist auch eingestellt das andere User darüber Mails schicken dürfen. Zusätzlich funktioniert es, wenn ich manuell in meinen CRM User reingehe und dort als Admin "Direktmail schicken" sage... das Mail kommt dann auch an.

    Achja und es handelt sich um eine 2011 On Premise installiation.

    Hat jemand eine Idee? Im Log des Email-Routers sehe ich nicht, das irgendein Mail daher kommen würde :(

    Mittwoch, 21. März 2012 15:15

Antworten

  • Änder mal den Bereich auf Organisation. Vermutlich wirst du dafür einen neuen Prozess anlegen müssen.

    Gruß

    Andreas

    • Als Antwort markiert Marc Hunziker Donnerstag, 22. März 2012 10:21
    Donnerstag, 22. März 2012 10:10
  • Hallo,

    probier doch einfach mal aus, ob der Workflow irgend ein Feld ändern kann, dann weist du auf jedem Fall schon einmal, das er auf das Feld reagiert.

    Dann würde ich prüfen, ob alle Pflichtfelder der Email richtig gefüllt werden.


    Viele Grüße

    Michael Sulz
    MVP für Microsoft Dynamics CRM
    Blog
    Website

    • Als Antwort markiert Michael Sulz Dienstag, 26. Januar 2016 08:13
    Mittwoch, 21. März 2012 15:38

Alle Antworten

  • Ich habe gerade gemerkt das wenn ich als Admin in die Emailaktivitäten (Ausstehende Emails) reinschaue, sind gar keine Mails darin befinden.... anscheinend reagiert der Workflow nicht auf die Veränderung des Feldes??
    Mittwoch, 21. März 2012 15:21
  • Hallo,

    probier doch einfach mal aus, ob der Workflow irgend ein Feld ändern kann, dann weist du auf jedem Fall schon einmal, das er auf das Feld reagiert.

    Dann würde ich prüfen, ob alle Pflichtfelder der Email richtig gefüllt werden.


    Viele Grüße

    Michael Sulz
    MVP für Microsoft Dynamics CRM
    Blog
    Website

    • Als Antwort markiert Michael Sulz Dienstag, 26. Januar 2016 08:13
    Mittwoch, 21. März 2012 15:38
  • Ich habe jetzt schon einen Test gemacht, indem ich bei den Leads ein neues Optionsfeld angelegt habe....

    Beim Workflow habe ich zuerst eine Überprüfungsbedingung auf Feld gleich "JA" und dann Email Senden.

    Zusätzlich ist bei Starten bei: Datensatzfelder werden geändert..." das von mir erstellte Feld ausgewählt.

    Mache ich was Falsch?

    LG

    Mittwoch, 21. März 2012 15:42
  • Hallo Marc!

    Der Workflow kann erst beim Neuladen des Formulars erkennen, ob ein Feld geändert wurde.
    Speicher den Datensatz nach dem Ändern des Feldes. Somit wird das Formular neu geladen und der Workflow wird ausgeführt.


    Ich hoffe das bringt weiter. Andreas(a)Donaubauer.com www.crmfaq.de

    Donnerstag, 22. März 2012 09:10
  • Hallo Andreas,

    natürlich habe ich die änderung gespeichert und den Datensatz somit neu geladen. Ich habe gestern minimum 2 mal zwischen den Optionen hin und her gewechselt. Zwischendurch jedesmal gespeichert und 15 Minuten gewartet... Mail ging keines raus.

    Lg

    Donnerstag, 22. März 2012 09:15
  • Hallo Mark!

    Wurde der Workflow überhaupt ausgeführt?
    Im Formular des Datensatzes kannst du dir unter Prozesse die ausgefürten Workflows anzeigen lassen.


    Ich hoffe das bringt weiter. Andreas(a)Donaubauer.com www.crmfaq.de

    Donnerstag, 22. März 2012 09:42
  • Hallo,

    da scheint der Workflow komischerweise gar nicht auf? obwohl ich beim workflow selbst ausgewählt habe, das es auf Potentialkunden zugeordnet ist??

    lg

    Donnerstag, 22. März 2012 09:51
  • Hallo Marc!

    Erstelle erst einmal einen leeren Workflow und teste ob er ausgelöst wurde.
    Wenn er in der Liste erscheint, wurde er ausgelöst.
    Die Aktion "Email verschicken" kannst du dann im Workflow hinzufügen.


    Ich hoffe das bringt weiter. Andreas(a)Donaubauer.com www.crmfaq.de

    Donnerstag, 22. März 2012 10:00
  • Hallo Andreas,

    soweit bin ich schon. Also folgende Konfiguration habe ich eingerichtet.

    1. Potentialkunde hat ein Optionsfeld (JA/NEIN)

    2. Workflow eingerichtet (Datensatzfelder werden geändert ist das Optionsfeld ausgewählt)

    Was mache ich also falsch? Ich habe mal als test den Workflow als bedarfsabhängig markiert und dann manuell im Potentialkunde ausgelöst. Da hat er dann sofort das Mail verschickt. Wenn ich das allerdings wieder rausnehme, reagiert er auf die Feldveränderung nicht.

    Gruß

    Donnerstag, 22. März 2012 10:07
  • Änder mal den Bereich auf Organisation. Vermutlich wirst du dafür einen neuen Prozess anlegen müssen.

    Gruß

    Andreas

    • Als Antwort markiert Marc Hunziker Donnerstag, 22. März 2012 10:21
    Donnerstag, 22. März 2012 10:10
  • @localh0rst: Danke, das war die Lösung! nun werden die Mails automatisch verschickt.

    gruß

    Donnerstag, 22. März 2012 10:21